2 Fehler, die ich nicht gefixt bekomme

Dieses Thema im Forum "Server Plugins" wurde erstellt von LoganBwDE, 7. März 2015.

  1. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Hallo,

    und zwar hab ich (mal wieder ) 2 Fehler in der Konsole, die ich einfach nicht gefixt bekomme.
    Hoffe ihr könnt mir dabei weiterhelfen.
    Also als erstes ein Fehler mit PLotMe:
    Code (Text):
    1.  
    2. [21:18:32 ERROR]: Could not pass event PlayerMoveEvent to PlotMe v0.13f
    3. org.bukkit.event.EventException
    4.         at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:302) ~[start.jar:git-Spigot-1649]
    5.         at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[start.jar:git-Spigot-1649]
    6.         at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:514) [start.jar:git-Spigot-1649]
    7.         at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:499) [start.jar:git-Spigot-1649]
    8.         at net.minecraft.server.v1_7_R4.PlayerConnection.a(PlayerConnection.java:249) [start.jar:git-Spigot-1649]
    9.         at net.minecraft.server.v1_7_R4.PacketPlayInFlying.a(SourceFile:137) [start.jar:git-Spigot-1649]
    10.         at net.minecraft.server.v1_7_R4.PacketPlayInPositionLook.handle(PacketPlayInPositionLook.java:40) [start.jar:git-Spigot-1649]
    11.         at net.minecraft.server.v1_7_R4.NetworkManager.a(NetworkManager.java:186) [start.jar:git-Spigot-1649]
    12.         at net.minecraft.server.v1_7_R4.ServerConnection.c(ServerConnection.java:81) [start.jar:git-Spigot-1649]
    13.         at net.minecraft.server.v1_7_R4.MinecraftServer.v(MinecraftServer.java:734) [start.jar:git-Spigot-1649]
    14.         at net.minecraft.server.v1_7_R4.DedicatedServer.v(DedicatedServer.java:289) [start.jar:git-Spigot-1649]
    15.         at net.minecraft.server.v1_7_R4.MinecraftServer.u(MinecraftServer.java:584) [start.jar:git-Spigot-1649]
    16.         at net.minecraft.server.v1_7_R4.MinecraftServer.run(MinecraftServer.java:490) [start.jar:git-Spigot-1649]
    17.         at net.minecraft.server.v1_7_R4.ThreadServerApplication.run(SourceFile:628) [start.jar:git-Spigot-1649]
    18. Caused by: java.lang.NoSuchMethodError: com.sk89q.worldedit.LocalSession.getMask()Lcom/sk89q/worldedit/masks/Mask;
    19.         at com.worldcretornica.plotme.PlotWorldEdit.setMask(PlotWorldEdit.java:61) ~[?:?]
    20.         at com.worldcretornica.plotme.PlotWorldEdit.setMask(PlotWorldEdit.java:18) ~[?:?]
    21.         at com.worldcretornica.plotme.listener.PlotWorldEditListener.onPlayerMove(PlotWorldEditListener.java:63) ~[?:?]
    22.         at sun.reflect.GeneratedMethodAccessor56.invoke(Unknown Source) ~[?:?]
    23.         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_31]
    24.         at java.lang.reflect.Method.invoke(Method.java:483) ~[?:1.8.0_31]
    25.         at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:298) ~[start.jar:git-Spigot-1649]
    26.  
    Und dann noch ein Fehler mit GeSuitPortals:
    Code (Text):
    1.  
    2. [14:31:31] [Server thread/ERROR]: Could not load 'plugins/geSuitPortals.jar' in folder 'plugins'
    3. org.bukkit.plugin.UnknownDependencyException: geSuitTeleports
    4.     at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:228) [start.jar:git-Spigot-1649]
    5.     at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugins(CraftServer.java:369) [start.jar:git-Spigot-1649]
    6.     at net.minecraft.server.v1_7_R4.DedicatedServer.init(DedicatedServer.java:152) [start.jar:git-Spigot-1649]
    7.     at net.minecraft.server.v1_7_R4.MinecraftServer.run(MinecraftServer.java:458) [start.jar:git-Spigot-1649]
    8.     at net.minecraft.server.v1_7_R4.ThreadServerApplication.run(SourceFile:628) [start.jar:git-Spigot-1649]
    9.  
    So falls noch etwas benötigt wird, einfach sagen, ich beiße nicht ;)
    Gruß
    LoganBwDE aka Lukas i.A. Townville[/CODE]
     
    #1
  2. Malfrador
    Offline

    Malfrador

    Registriert seit:
    16. Juni 2013
    Beiträge:
    411
    Minecraft:
    Malfrador
    Beim unteren scheint das Plugin "GeSuitTeleports" benötigt zu werden, welches scheinbar nicht vorhanden ist oder nicht funktioniert.
     
    #2
    MiCrJonas gefällt das.
  3. Endersocke
    Offline

    Endersocke

    Er kann das Plugin GeSuitTeleports nicht laden. An Deiner Stelle würde ich das Plugin löschen, den Server stoppen, das Plugin nocheinmal neu herunterladen, schauen ob es die richtige Version hat (also wenn Dein Server auf 1.8 läuft, wäre es nicht von Vorteil, ein Plugin zu nutzen was auf der 1.7.9 läuft, jedoch nicht auf der 1.8). Anschließend das Plugin nocheinmal neu in den Pluginordner ziehen und den Server starten.

    Was Dein Fehler bei PlotMe ist, weiß ich leider nicht.
     
    #3
  4. Giga11
    Offline

    Giga11

    Registriert seit:
    5. März 2012
    Beiträge:
    45
    Ort:
    Hessen
    Minecraft:
    Giga11
    Der PlotMe Fehler sieht nicht weiter tragisch aus, solange alle Features Ingame funktionieren.
    PlotMe hat gerne mal Probleme, die aber meistens nicht schlimm sind.
     
    #4
    Malfrador gefällt das.
  5. Vinnie
    Offline

    Vinnie

    Registriert seit:
    28. Juni 2014
    Beiträge:
    264
    Minecraft:
    Vinnie
    Das mit PlotMe sieht mir so aus, das du die falsche Version für deine Bukkit/Spigot Version benutt. Wird mit diesem Fehler die Console u gespamt, wenn man in deine Plot Welt ist?
     
    #5
  6. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Ja :D Aber totaler Log Spam
     
    #6
  7. Vinnie
    Offline

    Vinnie

    Registriert seit:
    28. Juni 2014
    Beiträge:
    264
    Minecraft:
    Vinnie
    Jop, wie befürchtet nutzt du die falscher Version für deine Server Version. Solltes du vielleicht ma lUpdaten bzw. neu draufspielen :)
     
    #7
  8. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Also momentan benutze ich für unseren Server die Spigot 1.7.10 Protocol Hack mit PlotMe 1.7.9 R02
    Desweiteren benutzen wir Bungeecord 1.8
    Ich weiß halt nicht ob wir nun die 1.8 benutzen sollen, da ja auch 1.7 Versionen draufjoinen
     
    #8
  9. Vinnie
    Offline

    Vinnie

    Registriert seit:
    28. Juni 2014
    Beiträge:
    264
    Minecraft:
    Vinnie
    Also dann müssen die halt mit 1.8 joinen. Die Version läuft ja soweit und Texturepacks, Mods und SHADER gibt es ja auch mittlerweile dafür. Ich hätte den Server auf 1.8 gemacht. :D

    Aber: gucke erst, ob alle deine Plugins mit 1.8 Kompatibel sind! Sonst gibt es böse Überraschungen...

    Muss du eben abwegen, wie du das handhabts. :)
     
    #9