Gelöst Bauwelt sichern | GriefPrevention | WorldGuard

Dieses Thema im Forum "Server Plugins" wurde erstellt von pinkpoint, 13. Oktober 2016.

  1. pinkpoint
    Offline

    pinkpoint

    Registriert seit:
    13. Oktober 2016
    Beiträge:
    72
    Minecraft:
    pinkpoint
    Hii,
    ich möchte die Bauwelt gegen unerlaubtes Farming sichern. Als Plugins sind GriefPrevention und WorldGuard sicher diejenige, mit denen ich die Welt sichern kann.

    Die Spieler sollen mit der Goldschaufel einen Claim erstellen können und dann nur innerhalb dieses Claims Baurechte erhalten. Aber ich habe bisher noch keine WorldGuard-Flags gefunden, die dies richtig handhaben.

    Kiddies halten sich leider nicht immer an Regeln und farmen in der Bauwelt, obwohl eine Farmwelt dafür vorgesehen ist. Also muss ich dem illegalem Farming vorbeugen.

    Wer kann helfen? Danke
     
    #1
  2. SilberRegen
    Offline

    SilberRegen

    Registriert seit:
    23. März 2012
    Beiträge:
    579
    Minecraft:
    SilberRegen
    Vielleicht ist der "Creative Claims Mode" das was du suchst. Er hat nicht direkt mit dem Creativemodus zu tun, sondern mit dem Verhalten der Claims. Wenn du deine Bauwelt auf die Liste der Welten setzt, die diesen Modus nutzen, kann nur in den Claims gebaut werden.
    Hat aber auch ein paar Nachteile im Survival, das müsste man sich mal genauer ansehen.
    Quelle: Hier, weiter unten im Text.

    Die Configuration von WG + Griefprevention funktioniert auch, ist aber etwas fummeliger und ich bin mir nicht mehr sicher, ob es da eine brauchbare Konfiguration gab. Da weiß vielleicht wer anders mehr.
     
    #2
  3. pinkpoint
    Offline

    pinkpoint

    Registriert seit:
    13. Oktober 2016
    Beiträge:
    72
    Minecraft:
    pinkpoint
    Hii SilberRegen,
    kannst Du mir bitte mitteilen, wie ich das richtig konfiguriere, damit das nicht in die Hose geht? Mit WorldGuard hatte ich schon Versuche angestellt, aber sobald die Welt sicher ist, kann leider nicht geclaimt werden.

    Edit:
    Ich habe die richtige Einstellung gefunden.
    Code (Text):
    1. ...
    2. ...
    3.   Claims:
    4.   Mode:
    5.   farmwelt: Disabled
    6.   world_the_end: Disabled
    7.   world_nether: Disabled
    8.   world: SurvivalRequiringClaims
    Ich habe in Zeile 8 den Eintrag von Survival auf SurvivalRequiringClaims geändert. Dies fand ich jedoch ganz am Anfang der verlinkten Seite.
     
    #3
    SilberRegen gefällt das.
  4. SilberRegen
    Offline

    SilberRegen

    Registriert seit:
    23. März 2012
    Beiträge:
    579
    Minecraft:
    SilberRegen
    Ah, perfekt :)
    Meine Kurzsuche hat mich direkt nach unten geschmissen, aber schön, dass sich die Lösung so schnell finden konnte.
    Das wird in Zukunft sicher auch anderen weiterhelfen, die danach suchen.
     
    #4