• Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

Erledigt Beta Phasen Plugin like Bausucht.net

SLINIcraftet204

Minecrafter
Osterei Experte
Mitglied seit
21 Juni 2018
Beiträge
14
Minecraft
SLINIcraftet204
Hey,
ich habe eine Frage... dir wäre ob jemand bereit wäre mir ein Plugin wie auf Bausucht zu programmieren.
Das Plugin ist wiefolgt aufgebaut, wenn man Joined bekommt man eine Nachricht und man muss diese Bestätigen oder ablehnen, bevor man keines von beidem gemacht hat darf der Spieler sich nicht bewegen oder jeglichen befehl eingeben. Wenn man Bestätigt darf der Spieler erst anfangen zu spielen. Beim Ablehnen wird der Spieler auf die Lobby gekickt. Wäre auch cool wenn man die komplette Nachricht die im Bild zusehen ist in einer config.yml anpassbar ist. Wenn es ginge das plugin in der 1.13.2 schreiben und das [Akzeptieren] und [Ablehnen] klickbar machen. Noch cool dazu wäre, dass das immer ausgeführt wird wenn ein Spieler den Server betritt (aber nur bei dem Spieler der auf den Server gejoined ist).
Ich danke im Vorraus :)11379
 

HardSoul

Workaholic
Ehem. Teammitglied
Osterei Experte
Mitglied seit
2 August 2012
Beiträge
758
Minecraft
HardS0ul
Vielleicht hilft ja auch dieses bereits existente Plug-in. Es ist zwar nicht speziell für diesen Zweck gebaut, aber man kann es konfigurieren, dass es in etwa das tut was du willst.

MfG,
HardSoul
 

HansDev

Schafhirte
Mitglied seit
27 September 2018
Beiträge
113
Hey SLINIcraftet204,
ich weiß, dass dieser Thread bereits als "erledigt" markiert wurde.
Ich hatte dir deinen Pluginwunsch neulich prorammiert aber vergessen es hier reinzuschicken :confused:
Deswegen habe ich hier die Jar-Datei für dich. Du kannst alle Nachrichten in der config einstellen. Dabei kannst du das '&'-Zeichen als Colorcode verwenden und '&n' für einen Zeilenumbruch benutzen. Gespeichert wird das alles mit UUID's in der database.yml.
Falls du dir unsicher bist kannst du auch gerne alles decompilen, da ist nichts böses (bis auf unübersichtlichen Code) drin :O
Ich hoffe du findest Verwendung dafür.
Mit freundlichen Grüßen
HansDev

Link zum Plugin: https://workupload.com/file/TNRRWuyb
 

SLINIcraftet204

Minecrafter
Osterei Experte
Mitglied seit
21 Juni 2018
Beiträge
14
Minecraft
SLINIcraftet204
Hey SLINIcraftet204,
ich weiß, dass dieser Thread bereits als "erledigt" markiert wurde.
Ich hatte dir deinen Pluginwunsch neulich prorammiert aber vergessen es hier reinzuschicken :confused:
Deswegen habe ich hier die Jar-Datei für dich. Du kannst alle Nachrichten in der config einstellen. Dabei kannst du das '&'-Zeichen als Colorcode verwenden und '&n' für einen Zeilenumbruch benutzen. Gespeichert wird das alles mit UUID's in der database.yml.
Falls du dir unsicher bist kannst du auch gerne alles decompilen, da ist nichts böses (bis auf unübersichtlichen Code) drin :O
Ich hoffe du findest Verwendung dafür.
Mit freundlichen Grüßen
HansDev

Link zum Plugin: https://workupload.com/file/TNRRWuyb
Vielen Dank ich probier es mal.
 

SLINIcraftet204

Minecrafter
Osterei Experte
Mitglied seit
21 Juni 2018
Beiträge
14
Minecraft
SLINIcraftet204
Hallo @HansDev Leider funktioniert das Plugin nicht ich habe es mehrmals versucht es zum laufen zu bringen doch es geht nicht.
Error Message
Code:
[13:57:,39 ERROR]: Could not load 'plugins\BetaMessage.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: de/hansdev/betamessage/Main has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:136) ~[spigot-1.13.2.jar:git-Spigot-518206a-a5b9c7b]
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:,327) ~[spigot-1.13.2.jar:git-Spigot-518206a-a5b9c7b]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:248) [spigot-1.13.2.jar:git-Spigot-518206a-a5b9c7b]
        at org.bukkit.craftbukkit.v1_13_R2.CraftServer.loadPlugins(CraftServer.java:,323) [spigot-1.13.2.jar:git-Spigot-518206a-a5b9c7b]
        at net.minecraft.server.v1_13_R2.DedicatedServer.init(DedicatedServer.java:213) [spigot-1.13.2.jar:git-Spigot-518206a-a5b9c7b]
        at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:697) [spigot-1.13.2.jar:git-Spigot-518206a-a5b9c7b]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_211]
Caused by: java.lang.UnsupportedClassVersionError: de/hansdev/betamessage/Main has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
        at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_211]
        at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.8.0_211]
        at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.8.0_211]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:130) ~[spigot-1.13.2.jar:git-Spigot-518206a-a5b9c7b]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:80) ~[spigot-1.13.2.jar:git-Spigot-518206a-a5b9c7b]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_211]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_211]
        at java.lang.Class.forName0(Native Method) ~[?:1.8.0_211]
        at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_211]
        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:58) ~[spigot-1.13.2.jar:git-Spigot-518206a-a5b9c7b]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:132) ~[spigot-1.13.2.jar:git-Spigot-518206a-a5b9c7b]
        ... 6 more
Die kommas an bestimmten stellen habe ich nur gemacht das bei einem : und einer 3 kein :3 entsteht
 
Zuletzt bearbeitet von einem Moderator:

HansDev

Schafhirte
Mitglied seit
27 September 2018
Beiträge
113
Hey SLINIcraftet204,
wie du an dieser Zeile in deiner Fehlernachricht siehst ist es kein Fehler in meinem Code, wodurch das Plugin nicht läuft:

Caused by: java.lang.UnsupportedClassVersionError: de/hansdev/betamessage/Main has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0

Da steht, dass ich einfach eine neuere Version von Java zum kompillieren genutzt habe. Das bedeutet du musst entweder die Java-Version auf deiner Host-Maschine updaten oder ich schicke dir das Plugin nochmal in der "richtigen" Version.
Versuche es mal damit (Die müsste jetzt für Java 8 kompatibel sein): https://workupload.com/file/eHuy5zr4

Ich hoffe ich konnte dir helfen :D
Mit freundlichen Grüßen
HansDev
 
Allgemein
Hilfe Benutzer
  • Rabe Rabe:
    Hallo
  • SirYwell SirYwell:
    Morgen
  • Stern☆ Stern☆:
    n‘Abend :)
  • Matthias Matthias:
    Guten Abend zusammen
  • Rabe Rabe:
    Hello
  • SirYwell SirYwell:
    Na zum Glück nur 62 Benachrichtigungen hier
  • LottaXL LottaXL:
    Moin, moin =)
  • Matthias Matthias:
    Guten Morgen
  • maybeto maybeto:
    62 Benachrichtigungen zeugen von einer Abwesenheit von mehr als 2 Stunden. Sowas sollte abgemahnt werden.....
  • iTz_Proph3t iTz_Proph3t:
    Bin schon dabei!
  • ❤️可愛いちゃん️❤️ ❤️可愛いちゃん️❤️:
  • Rabe Rabe:
    Halllllllo
  • Matthias Matthias:
    Guten Morgen
  • LottaXL LottaXL:
    Moin, moin =)
  • maybeto maybeto:
    Bratwurstdöner mit Omas Krautsalat und Knoblauchsauce.... wirklich lecker
  • maybeto maybeto:
    wir leben es der Welt vor, mit Ber haben wir aktuell einen der klimafreundlichsten Flughafen der Welt..... geht doch
  • Majoox Majoox:
    BER - Hafenflug
  • Matthias Matthias:
    Guten Morgen
  • L Luki_xx:
    Guten Morgen
  • Stern☆ Stern☆:
    Morgen :)
  • LottaXL LottaXL:
    Moin, moin =)
  • Soeren1987 Soeren1987:
    Gudde
  • Matthias Matthias:
    Servus
    Matthias Matthias: Servus
    Oben