1. Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

bStats da funktioniert was nicht

Dieses Thema im Forum "Technischer Support" wurde erstellt von YoshiMiner, 13. August 2017 um 16:22 Uhr.


  1. YoshiMiner
    Offline

    YoshiMiner

    Registriert seit:
    3. August 2017
    Beiträge:
    15
    Geschlecht:
    männlich
    Hallo,
    ich hab in bStats.org mein Plugin hinzugefügt und habe die Klasse in mein Plugin eingebunden und dann in onEnable das gemacht:
    Code (Text):
    1. org.spigotmc.yoshiminer.lobby.Metrics metrics = new org.spigotmc.yoshiminer.lobby.Metrics(this);
    der Packagename deswegen weil Java sonst denkt, ich will das Metrics von bukkit (mcstats.org) haben.
    Mein Plugin heißt GENAUSO wie in bStats, aber es wird nichts angezeigt bei bStats.
    Was mache ich falsch?
     
  2. BlackHole
    Offline

    BlackHole

    Registriert seit:
    1. Juli 2012
    Beiträge:
    259
    Geschlecht:
    männlich
    Minecraft:
    BlackHole
    Evtl. muss der Betreiber der Seite jedes Plugin freischalten oder du musst evtl. noch einen Registrierungsmail bestätigen?
     
  3. YoshiMiner
    Offline

    YoshiMiner

    Registriert seit:
    3. August 2017
    Beiträge:
    15
    Geschlecht:
    männlich
    1. ja kann sein
    2. da muss man keine email eingeben
     
  4. YoshiMiner
    Offline

    YoshiMiner

    Registriert seit:
    3. August 2017
    Beiträge:
    15
    Geschlecht:
    männlich
    jetzt kommt beim starten sowas:
    Code (Text):
    1.  
    2. [17:04:41 ERROR]: Error occurred while enabling zensiert v1.0 (Is it up to date?)
    3. java.lang.ExceptionInInitializerError
    4.         at Lobby.onEnable(Lobby.java:26) ~[?:?]
    5.         at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    6.         at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    7.         at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    8.         at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    9.         at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    10.         at org.bukkit.craftbukkit.v1_8_R3.CraftServer.reload(CraftServer.java:741) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    11.         at org.bukkit.Bukkit.reload(Bukkit.java:535) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    12.         at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    13.         at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    14.         at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchCommand(CraftServer.java:641) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    15.         at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchServerCommand(CraftServer.java:627) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    16.         at net.minecraft.server.v1_8_R3.DedicatedServer.aO(DedicatedServer.java:412) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    17.         at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:375) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    18.         at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    19.         at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [spigot-1.12.1.jar:git-Spigot-21fe707-e1ebe52]
    20.         at java.lang.Thread.run(Unknown Source) [?:1.8.0_141]
    21. Caused by: java.lang.NullPointerException
    22.         at Metrics.<clinit>(Metrics.java:47) ~[?:?]
    23.         ... 17 more
    24.  
    ich habe nur die beiden klassen in das default package getan, und das wird auch jetzt erkannt, also jetzt wird das Metrics von bStats genommen und nicht von mcstats.
    und zwar habe ich den import von org.spigotmc.metrics (wie auch immer) entfernt
     
  5. YoshiMiner
    Offline

    YoshiMiner

    Registriert seit:
    3. August 2017
    Beiträge:
    15
    Geschlecht:
    männlich
    ok das hat sich erledigt, aber das nicht:
     
  6. JTK222
    Offline

    JTK222

    Registriert seit:
    5. September 2013
    Beiträge:
    834
    Geschlecht:
    männlich
    Minecraft:
    JTK222
    ... nimm doch auch den richtigen pfad... org.bstats.bukkit.Metrics... außerdem du kannst aussuchen was du Importieren möchtest. Es macht nur sinn dass da hin zu schreiben wenn du beide System benutzen möchtest.
     
  7. BlackHole
    Offline

    BlackHole

    Registriert seit:
    1. Juli 2012
    Beiträge:
    259
    Geschlecht:
    männlich
    Minecraft:
    BlackHole
    Vielleicht werden in der Liste nur Plugins angezeigt, die auf mindestens einen Server laufen. Wenn ich das richtig verstehe werden Plugins auch erst nach einer Minute zum bStats-Server gemeldet.

    Deine spigot.jar solltest du besser selber erstellen, statt aus unsicherer Quelle zu beziehen. Denn offensichtlich ist die Datei spigot-1.12.1.jar tatsächlich eine Version 1.8.8 auf dem Stand von vor 1,5 Jahren.
     
  8. moinless
    Online

    moinless

    Registriert seit:
    4. Oktober 2013
    Beiträge:
    60
    Geschlecht:
    männlich
    Und bevor du fragst, wie man die spigot.jar selber erstellt, hier entlang.
     
    • Hilfreich Hilfreich x 1
  9. YoshiMiner
    Offline

    YoshiMiner

    Registriert seit:
    3. August 2017
    Beiträge:
    15
    Geschlecht:
    männlich
    NEIN
    das ist eine 1.8.8 ja, die hab ich aber auch selbst gemacht, ist aber nur umbennant, weil vorher auf mein server 1.12.1 drauf war und das auch so in der start.bat drinne stehen hatte.
    dann wollte ich 1.8.8 drauf hauen, aber da ich zu faul war die start.bat zu öffnen, hab ich einfach die 1.8.8.jar in 1.12.1.jar umbenannt. der name ist ja auch wurst, es funzt trotzdem