EchoPet

Dieses Thema im Forum "Technischer Support" wurde erstellt von LoganBwDE, 20. April 2015.

  1. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Hallöle,

    kennt den jemand eine EchoPet Version, die ich für meine Spigot 1649 Version benutzen kann, da die neueste Version 2.6.0 bei mir crasht.
    Gruß
    LoganBwDe
     
    #1
  2. Silver_GX
    Offline

    Silver_GX

    Registriert seit:
    2. Juni 2014
    Beiträge:
    64
    Minecraft:
    Silver_GX
    Das einfachste wäre doch einfach einen Dev-Build auszuprobieren diese sind schon im Bukkit-Thread von EchoPet verlinkt.....
     
    #2
    Endersocke und Vinnie gefällt das.
  3. SilberRegen
    Offline

    SilberRegen

    Registriert seit:
    23. März 2012
    Beiträge:
    579
    Minecraft:
    SilberRegen
    Der rote Text auf der Bukkitseite sagt bereits ziemlich knallig, dass es mit älteren Spigotversionen Probleme gibt und man neuere spigot.jars verwenden soll.

    Wenn es unbedingt der besagte Build sein soll (den wohl viele wegen des Protokollhacks mögen) wirst du dich rückwärts durch die Devbuilds hangeln müssen, bis du einen erwischt der fehlerfrei läuft. Vielleicht funktioniert auch die 1.7.9-Version, probiers aus.
    Empfehlen würde ich dir aber, deinen Server auf die neuste Version zu patchen, allein wegen der gefixten Sicherheitsprobleme. Die neuste 1.8.3-Version hat diesen Fix bereits und wenn es dir um den Protokollsupport geht, gibt es da tatsächlich Plugins, wie dieses hier, dafür.

    Extra Tipp: im Changelog von EchoPet steht sogar drin, ab welchem Build der Support für deine Spigotversion eingestellt wurde.
     
    #3
    LoganBwDE und [Dev] iTzSasukeHDxLP gefällt das.
  4. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Also müsste ich dann aber jedes Plugin für die 1.8 holen und nicht für die 1.7?
     
    #4
  5. Silver_GX
    Offline

    Silver_GX

    Registriert seit:
    2. Juni 2014
    Beiträge:
    64
    Minecraft:
    Silver_GX
    Nein eine Spigot Protocol-Hack also 1.7-1.8 Version ist eigentlich eine 1.7.10 Bukkit/Spigot also KEINE 1.8

    1.8er Plugins solltest du NUR nutzen wenn der Entwickler des Plugins es als Abwertskompatibel ausgerichtet hat
     
    #5
  6. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Das weiß ich ja.....ich meinte die Alternative mit der Spigot 1.8.3 und dem Protokollsupport

    Also hab mal diverse Dev-Builds probier...es geht keine :(
     
    #6
  7. SilberRegen
    Offline

    SilberRegen

    Registriert seit:
    23. März 2012
    Beiträge:
    579
    Minecraft:
    SilberRegen
    Für den Fall das du updatest müsstest du natürlich auch entsprechende 1.8-Versionen deiner anderen Plugins zusammensuchen oder Alternativen zu diesen, falls es keine 1.8-Version gibt.
    Manche Plugins funktionieren auch ohne Update weiter, aber das würde ich nur austesten, falls es wirklich nichts Aktuelles gibt.
     
    #7
  8. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Hat jemand vlt eine Build von EchoPet, die für die Spigot-Version 1649 funktioniert?
     
    #8
  9. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Also @SilberRegen ich habe jetzt wirklich viele Dev-Builds von 1.7.9 und 1.7.10 ausprobiert, doch keine scheint zu gehen. Alle mit dem Fehler, das 1.8 nicht unterstützt wird.
    Hast du oder irgendjemand denn hier im Forum eine Alternative oder eine Version, die funktioniert...Oder kann ich es einfach selbst umkompalieren?
     
    #9
  10. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Suche immer noch :(
     
    #10
  11. Malfrador
    Offline

    Malfrador

    Registriert seit:
    16. Juni 2013
    Beiträge:
    412
    Minecraft:
    Malfrador
    Es scheint keins zu gehen, ein Problem welches ich bestätigen kann, mit Protocol-Hack geht es nicht.
     
    #11
  12. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Aber ich finde viele Server, die Protocol-Hack haben und EchoPet. Es muss also irgendwie gehen...
     
    #12