Problem Eclipse Compiler compliance level

Dieses Thema im Forum "Offtopic" wurde erstellt von TimBone, 31. Juli 2013.

  1. TimBone
    Offline

    TimBone

    Hallo minecraft-server.eu,
    ich melde mich zurück mit einem neuen Problem. Ich kann bei Eclipse das Compiler compliance level nicht auf 1.7 setzen.
    Ich habe das jdk und jre 7 installiert.
    [​IMG]
    [​IMG]
    Ich hoffe ich konnte mein Problem schildern, ich würde gerne die switch() Methode auch bei Strings nutzen und kann deshalb nicht bei Java 6 bleiben. Kann mir jemand helfen?
     

    Anhänge:

    #1
  2. Sn0wBlizz4rd
    Offline

    Sn0wBlizz4rd

    Registriert seit:
    26. September 2012
    Beiträge:
    424
    Minecraft:
    Sn0wBlizz4rd
    So wie es aussieht, hast du noch Eclipse Indigo. Lade dir mal Eclipse Juno runter, dann sollte es funktionieren.
    Im Notfall machste halt tausende if-Abfragen ;)
     
    #2
  3. TimBone
    Offline

    TimBone

    Naja, hatte noch Helios am laufen :D Habe mir jetzt Kepler runtergeladen und es funktioniert. Vielen Dank dafür :)
     
    #3