Eclipse/Marven Problem

Dieses Thema im Forum "Programmierung" wurde erstellt von Paulomart, 29. November 2013.

  1. Paulomart
    Offline

    Paulomart

    Registriert seit:
    3. November 2013
    Beiträge:
    148
    Ort:
    C:/Eclipse/Workspace/
    Minecraft:
    Paulomart
    Heyho,

    heute habe ich mal ein Problem.. :D

    Ich habe mit Marven für Eclipse das Project https://github.com/TheUnnamedDude/BungeeCord in meine Workspace kopiert. Außer ein paar Fehlern in allen pom.xml's läuft alles glatt. Es gibt keine Probleme mit irgentwelchen Imports oder so..

    Das Problem ist wenn ich das Projekt jetzt als Runnable JAR File exportiere wähle ich meine Launch config aus. Aber wenn ich versuche die Jar zustarten bekomme ich das:

    Code (Text):
    1. Exception in thread "main" java.lang.NoSuchMethodError: net.md_5.bungee.config.C
    2. onfiguration: method <init>()V not found
    3.         at net.md_5.bungee.BungeeCord.<init>(BungeeCord.java:82)
    4.         at net.md_5.bungee.Bootstrap.main(Bootstrap.java:64)
    5. Drücken Sie eine beliebige Taste . . .
    Hier nochmal die Fehler in der pom:
    http://img.paul-h.de/pomerrors.jpg

    Meine Workspace sieht so aus:
    http://img.paul-h.de/workspaceBungee.jpg

    Irgentwelche Ideen? Denn mit den "normalen" BungeeCord geht das so, auch wenn ich da auch die Errors von der Pom bekomme...


    Vielen Dank im Vorraus ;)


    Edit:

    Habe den Fehler gefunden....
    War einfach nur die Reihenfolge von dem Projekten in der Launch config..
     
    #1