Error Spam in der Konsole

Dieses Thema im Forum "Technischer Support" wurde erstellt von delta242, 23. April 2013.

  1. delta242
    Offline

    delta242

    Registriert seit:
    28. Mai 2012
    Beiträge:
    90
    Hallo,
    seit heute wird die Konsole des Servers mit folgender Fehlermeldung zugespammt:
    Der Server an sich läuft ohne Fehlermeldungen. Man kann auch auf ihn joinen, allerdings wird er auf minecraft-server.eu sowie in der Ingame Minecraft-Serverliste als offline deklariert.
    Dieses Problem existiert erst seit heute, weshalb eine fehlerhafte Bukkit Version nicht des Problems Ursache sein kann. Hat jemand eine Idee, was die Fehlermeldung beduetet, bzw. wie man es beheben kann?

    Mit freundlichen Grüßen
    delta242
     
    #1
  2. ChunkNorris
    Offline

    ChunkNorris

    Poste mal bitte die komplette Meldung, die sollte eigtl. etwas mehr sagen.
     
    #2
  3. delta242
    Offline

    delta242

    Registriert seit:
    28. Mai 2012
    Beiträge:
    90
    Das ist die komplette Meldung...
     
    #3
  4. Crafter6432
    Offline

    Crafter6432

    Registriert seit:
    22. Dezember 2011
    Beiträge:
    686
    Das ganze Log
     
    #4
  5. delta242
    Offline

    delta242

    Registriert seit:
    28. Mai 2012
    Beiträge:
    90
    Was wollt ihr damit? Das bringt euch nichts, wenn ich hier 2000 Konsolen-Zeilen anhänge, wo ihr nicht mehr seht, als Commands die die Spieler eingeben und die Fehlermeldungen.
    Es kommt immer nur genau diese Meldung! Nichts davor oder danach!
     
    #5
  6. Wolfi15
    Offline

    Wolfi15

    Registriert seit:
    4. November 2011
    Beiträge:
    602
    Minecraft:
    Wolfi15
    Server neustarten, bevor Player joinen Log posten... da MUSS eine Fehlermeldung kommen
    oder poste einfach 2-3 Zeilen welche darüber und darunter stehen mit...
    zudem kann das nicht die komplette Fehlermeldung sein...
     
    #6
  7. delta242
    Offline

    delta242

    Registriert seit:
    28. Mai 2012
    Beiträge:
    90
    So, da ja alle heiß drauf sind:
    2013-04-23 16:06:50 [INFO] Query running on -Ip vom ersteller entfernt-
    2013-04-23 16:06:51 [INFO] [glizer] Banlist loaded successfully
    2013-04-23 16:06:51 [INFO] [glizer] Whitelist empty
    2013-04-23 16:06:51 [INFO] YanG4mer [-Ip Entfernt-] lost connection
    2013-04-23 16:06:51 [INFO] /-Ip Entfernt- lost connection
    2013-04-23 16:06:51 [INFO] /-Ip Entfernt- lost connection
    2013-04-23 16:06:51 [INFO] /-Ip Entfernt- lost connection
    2013-04-23 16:06:51 [INFO] /-Ip Entfernt- lost connection
    2013-04-23 16:06:51 [INFO] /-Ip Entfernt- lost connection
    2013-04-23 16:06:51 [INFO] /-Ip Entfernt- lost connection
    2013-04-23 16:06:51 [INFO] /-Ip Entfernt- lost connection
    2013-04-23 16:06:51 [INFO] /-Ip Entfernt- lost connection
    2013-04-23 16:06:51 [INFO] /-Ip Entfernt- lost connection
    2013-04-23 16:06:51 [SEVERE] java.lang.NullPointerException
    2013-04-23 16:06:51 [SEVERE] at net.minecraft.server.v1_5_R2.PendingConnection.a(PendingConnection.java:160)
    2013-04-23 16:06:51 [SEVERE] at net.minecraft.server.v1_5_R2.Packet254GetInfo.handle(SourceFile:23)
    2013-04-23 16:06:51 [SEVERE] at net.minecraft.server.v1_5_R2.NetworkManager.b(NetworkManager.java:292)
    2013-04-23 16:06:51 [SEVERE] at net.minecraft.server.v1_5_R2.PendingConnection.c(PendingConnection.java:50)
    2013-04-23 16:06:51 [SEVERE] at net.minecraft.server.v1_5_R2.DedicatedServerConnectionThread.a(DedicatedServerConnectionThread.java:41)
    2013-04-23 16:06:51 [SEVERE] at net.minecraft.server.v1_5_R2.DedicatedServerConnection.b(SourceFile:29)
    2013-04-23 16:06:51 [SEVERE] at net.minecraft.server.v1_5_R2.MinecraftServer.r(MinecraftServer.java:580)
    2013-04-23 16:06:51 [SEVERE] at net.minecraft.server.v1_5_R2.DedicatedServer.r(DedicatedServer.java:225)
    2013-04-23 16:06:51 [SEVERE] at net.minecraft.server.v1_5_R2.MinecraftServer.q(MinecraftServer.java:476)
    2013-04-23 16:06:51 [SEVERE] at net.minecraft.server.v1_5_R2.MinecraftServer.run(MinecraftServer.java:409)
    2013-04-23 16:06:51 [SEVERE] at net.minecraft.server.v1_5_R2.ThreadServerApplication.run(SourceFile:573)
    2013-04-23 16:06:51 [INFO] /-Ip Entfernt- lost connection
    2013-04-23 16:06:51 [INFO] /-Ip Entfernt- lost connection
    2013-04-23 16:06:52 [SEVERE] java.lang.NullPointerException
    2013-04-23 16:06:52 [SEVERE] at net.minecraft.server.v1_5_R2.PendingConnection.a(PendingConnection.java:160)
    2013-04-23 16:06:52 [SEVERE] at net.minecraft.server.v1_5_R2.Packet254GetInfo.handle(SourceFile:23)
    2013-04-23 16:06:52 [SEVERE] at net.minecraft.server.v1_5_R2.NetworkManager.b(NetworkManager.java:292)
    2013-04-23 16:06:52 [SEVERE] at net.minecraft.server.v1_5_R2.PendingConnection.c(PendingConnection.java:50)
    2013-04-23 16:06:52 [SEVERE] at net.minecraft.server.v1_5_R2.DedicatedServerConnectionThread.a(DedicatedServerConnectionThread.java:41)
    2013-04-23 16:06:52 [SEVERE] at net.minecraft.server.v1_5_R2.DedicatedServerConnection.b(SourceFile:29)
    2013-04-23 16:06:52 [SEVERE] at net.minecraft.server.v1_5_R2.MinecraftServer.r(MinecraftServer.java:580)
    2013-04-23 16:06:52 [SEVERE] at net.minecraft.server.v1_5_R2.DedicatedServer.r(DedicatedServer.java:225)
    2013-04-23 16:06:52 [SEVERE] at net.minecraft.server.v1_5_R2.MinecraftServer.q(MinecraftServer.java:476)
    2013-04-23 16:06:52 [SEVERE] at net.minecraft.server.v1_5_R2.MinecraftServer.run(MinecraftServer.java:409)
    2013-04-23 16:06:52 [SEVERE] at net.minecraft.server.v1_5_R2.ThreadServerApplication.run(SourceFile:573)
    2013-04-23 16:06:52 [INFO] /-Ip Entfernt- lost connection

    Zufrieden? Mal schaun obs euch jetzt was bringt... Da kommt nix davor oder danach, es kommt einfach die Fehlermeldung, ich denke immer dann, wenn irgendwer etwas vom Server abfragen will. Sei es durchs joinen oder durch eine Abfrage von der Ingame Serverliste.
     
    #7
  8. Hecke29
    Offline

    Hecke29

    Wer sonst keine Probleme hat...

    v1_5_R2... überlegen wir mal

    Davon ab fehlt uns immernoch der Startup-Log @TE.
     
    #8
  9. delta242
    Offline

    delta242

    Registriert seit:
    28. Mai 2012
    Beiträge:
    90
    Danke für den Hinweis.
    Craftbukkit Build #2754 - also 1.5.1 R-0.2 (beta) verwende ich. Habe aber auch schon andere Versionen durchprobiert, an der liegt es nicht. Ich glaube ebenfalls nicht, dass die eingetragenen Spieler "kaputt" sind, da man ja wiegesagt normal auf den Server joinen kann und die Inventare funktionieren. Nur der Server wird eben als offline angezeigt, Ingame sowie auf minecraft-server.eu.
     
    #9
  10. Wolfi15
    Offline

    Wolfi15

    Registriert seit:
    4. November 2011
    Beiträge:
    602
    Minecraft:
    Wolfi15
    Wenn da so ist, was sind deine Plugins?
    Irgendwelche veralteten Plugins oder selbstgeschriebene welche zum Problem führen können?

    Was für eine Art von Server hast du?
    vServer? Root?...
     
    #10
  11. delta242
    Offline

    delta242

    Registriert seit:
    28. Mai 2012
    Beiträge:
    90
    Okay, deine genannten Informationen hätten keinem weitergeholfen... Aber trotzdem hat deine Antwort mich zur Lösung des Problems geführt: Die Config meines Plugins hatte einen Fehler, wurde nicht richtig geladen und hat sich somit gelöscht. Damit konnte der motd welcher im ServerListPingEvent abgefragt wurde nicht gesetzt werden und die Fehlermeldung erschien. Somit wurde er in der Ingame-Liste nicht mehr angezeigt.
    Falls jemand dasselbe Problem haben sollte, wär meine Empfehlung also sich mal das ServerListPingEvent noch mal durchzuschaun.
     
    #11