Fehlermeldung in der Konsole

Dieses Thema im Forum "Technischer Support" wurde erstellt von Tec-9, 9. März 2015.

  1. Tec-9
    Offline

    Tec-9

    Registriert seit:
    9. März 2015
    Beiträge:
    7
    Guten Tag,
    und zwar habe ich seit heute bei dem Server neustart folgenden Fehler

    [21:22:21 WARN]: Server permissions file permissions.yml is not valid YAML.
    org.yaml.snakeyaml.error.YAMLException: java.nio.charset.MalformedInputException : Input length = 1
    at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:200) ~[craftbukkit-1.8.jar:git-Bukkit-81ab957]
    at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:60) ~ [craftbukkit-1.8.jar:git-Bukkit-81ab957]
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:412) ~[craftbukkit-1.8.jar:git -Bukkit-81ab957]
    at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadCustomPermissions(Craf tServer.java:756) [craftbukkit-1.8.jar:git-Bukkit-81ab957]
    at org.bukkit.craftbukkit.v1_8_R1.CraftServer.enablePlugins(CraftServer. java:320) [craftbukkit-1.8.jar:git-Bukkit-81ab957]
    at net.minecraft.server.v1_8_R1.MinecraftServer.q(MinecraftServer.java:3 94) [craftbukkit-1.8.jar:git-Bukkit-81ab957]
    at net.minecraft.server.v1_8_R1.MinecraftServer.k(MinecraftServer.java:3 62) [craftbukkit-1.8.jar:git-Bukkit-81ab957]
    at net.minecraft.server.v1_8_R1.MinecraftServer.a(MinecraftServer.java:3 17) [craftbukkit-1.8.jar:git-Bukkit-81ab957]
    at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.jav a:190) [craftbukkit-1.8.jar:git-Bukkit-81ab957]
    at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java :473) [craftbukkit-1.8.jar:git-Bukkit-81ab957]
    at java.lang.Thread.run(Thread.java:745) [?:1.7.0_71]
    Caused by: java.nio.charset.MalformedInputException: Input length = 1
    at java.nio.charset.CoderResult.throwException(CoderResult.java:277) ~[? :1.7.0_71]
    at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:338) ~[?:1.7.0_7 1]
    at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:177) ~[?:1.7.0_71]
    at java.io.InputStreamReader.read(InputStreamReader.java:184) ~[?:1.7.0_ 71]
    at org.yaml.snakeyaml.reader.UnicodeReader.read(UnicodeReader.java:123) ~[craftbukkit-1.8.jar:git-Bukkit-81ab957]
    at java.io.Reader.read(Reader.java:140) ~[?:1.7.0_71]
    at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:184) ~[craftbukkit-1.8.jar:git-Bukkit-81ab957]
    ... 10 more


    Leider verstehe ich nicht so recht wo das Problem genau ist.
    Plugins sind folgende:

    PermissionsEX
    GriefPrevention
    MultiHome
    RemoteToolKitPlugin
    MotdManager


    So sieht die Permission aus
    groups:
    Member:
    default: true
    permissions:
    - griefprevention.restorenature
    - griefprevention.restorenatureaggressive
    - griefprevention.lava
    - griefprevention.claimslistother
    - griefprevention.deleteclaims
    - griefprevention.createclaims
    - griefprevention.transferclaim
    - griefprevention.claims
    - griefprevention.buysellclaimblocks
    - griefprevention.adjustclaimblocks
    - griefprevention.visualizenearbyclaims
    - griefprevention.eavesdrop
    - griefprevention.overrideclaimcountlimit
    - griefprevention.spam
    - griefprevention.siegeimmune
    - griefprevention.softmute
    - mh.set
    - mh.tp
    prefix: '&7[Member]&f'
    Admin:
    default: false
    permissions:
    - '*'
    prefix: '&c[Admin]'


    Ich hoffe jemand weiß ungefähr woran es liegen könnte

    MfG
    Stefan
     
    #1
  2. Endersocke
    Offline

    Endersocke

    Dein Server läuft auf der Version 1.7 und Du hast Plugins für die Version 1.8 installiert?! Dein Ernst?
     
    #2
  3. Tec-9
    Offline

    Tec-9

    Registriert seit:
    9. März 2015
    Beiträge:
    7
    Nein der Server läuft auf 1.8.1 ???

    Edit: wie gesagt der Fehler ist ja auch erst seit Heute da und der Server läuft schon ne Woche
     
    #3
  4. Endersocke
    Offline

    Endersocke

    Okay dann ist's mein Fehler gewesen :D Aber in Deinem Log steht etwas von 1.7

    Code (Text):
    1. at java.nio.charset.CoderResult.throwException(CoderResult.java:277) ~[? :1.7.0_71]
    2. at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java38) ~[?:1.7.0_7 1]
    3. at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:177) ~[?:1.7.0_71]
    4. at java.io.InputStreamReader.read(InputStreamReader.java:184) ~[?:1.7.0_ 71]
    5. at org.yaml.snakeyaml.reader.UnicodeReader.read(UnicodeReader.java:123) ~[craftbukkit-1.8.jar:git-Bukkit-81ab957]
    6. at java.io.Reader.read(Reader.java:140) ~[?:1.7.0_71]
     
    #4
  5. Tec-9
    Offline

    Tec-9

    Registriert seit:
    9. März 2015
    Beiträge:
    7
    Ja dies habe ich auch bemerkt, habe gedacht das es vielleicht an einem Plugin liegt ? aber wüsste nicht wieso die Permission.yml dann nen Fehler wirft.

    Habe extra nochmal nach geschaut haha, Server läuft auf 1.8 man Joint mit 1.8 also wieso da 1.7 steht weiß ich nicht so recht
     
    #5
  6. Endersocke
    Offline

    Endersocke

    Okay. Mich hat's auch irritiert :D
     
    #6
  7. Malfrador
    Online

    Malfrador

    Registriert seit:
    16. Juni 2013
    Beiträge:
    405
    Minecraft:
    Malfrador
    Das wird eher ein anderer Bestandteil von Craftbukkit sein ;)
     
    #7
  8. Kronos197
    Offline

    Kronos197

    Registriert seit:
    20. Dezember 2013
    Beiträge:
    153
    Ort:
    Frankfurt
    Minecraft:
    Kronos197
    Soweit ich das sehe, ist das ein Problem mit deinen Permission! Kannst du uns auch eine datei schicken, in welcher die Permission sind mit Auflistung und Abständen?
     
    #8
  9. MrPyro13
    Offline

    MrPyro13

    Registriert seit:
    29. April 2013
    Beiträge:
    829
    Minecraft:
    MrPyro13
    Hallo,

    in der ersten Zeile steht dein Fehler:
    Also entweder permissions.yml schicken bzw. überprüfen lassen (http://www.yamllint.com/) oder die Permissions neuschreiben.
     
    #9
    SilberRegen gefällt das.
  10. LoganBwDE
    Online

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Du kannst ja mal die permissions.yml von PEX einfach auf pastebin oder auf einer anderen Seite hochladen, so dass ich/wir mal drüber schauen können ;)
     
    #10