• Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

GELÖST - Worldguard: entry deny und build deny funktioniert nicht

Minecraft Version
Java

Ubakaluba

Minecrafter
Registriert
28 Februar 2021
Beiträge
2
Diamanten
100
Moin liebe Minecraft Community,
ich betreibe einen Windows Server 2019 und dort Minecraft Paper 1.16.5-499.
World Guard Version Worldguard_Bukkit-7.0.4 und Worldedit-Bukkit-7.2.2

Ich kann Regionen erstellen und Flags wie Mob-Spawning deny etc. setzen und all das funktioniert wunderbar.

Was nicht geht ist entry deny.
Ich habe um einen Fehler auszuschließen Worldguard vom Server komplett entfernt, dann den Server neu gestartet und eine kleine Region markiert und als einzigen Flag entry deny gesetzt.
Jetzt würde ich eigentlich erwarten, dass andere diesen Bereich nicht betreten dürfen. Geht aber leider nicht.
Irgendeine Idee was ich falsch gemacht habe?

Liebe Grüße
Uba
 

Malfrador

Threadripper
Registriert
16 Juni 2013
Beiträge
1.473
Diamanten
296
Minecraft
Malfrador
Hast du zufällig use-player-move-event in der WorldGuard config.yml auf false gesetzt? Das wird den Flag deaktivieren.

Du kannst versuchen, den Flag nur für nonmembers (also Spieler, die nicht in die Region eingetragen sind) zu setzen (/rg flag <region> entry -g nonmembers deny). Ansonsten sehe ich noch als Möglichkeit, das die Spieler die Bypass-Permission (worldguard.region.bypass.<Weltname>.entry) haben. Die hat man auch automatisch, wenn man alle Worldguard-Permissions hat, was auch der Fall sein kann, wenn du kein Permissions-Plugin nutzen solltest.
 

Ubakaluba

Minecrafter
Registriert
28 Februar 2021
Beiträge
2
Diamanten
100
Hast du zufällig use-player-move-event in der WorldGuard config.yml auf false gesetzt? Das wird den Flag deaktivieren.

Du kannst versuchen, den Flag nur für nonmembers (also Spieler, die nicht in die Region eingetragen sind) zu setzen (/rg flag <region> entry -g nonmembers deny). Ansonsten sehe ich noch als Möglichkeit, das die Spieler die Bypass-Permission (worldguard.region.bypass.<Weltname>.entry) haben. Die hat man auch automatisch, wenn man alle Worldguard-Permissions hat, was auch der Fall sein kann, wenn du kein Permissions-Plugin nutzen solltest.

Hi, vielen Dank für deine zügige Antwort.
Du wirst es kaum glauben, aber 2 Minuten nach meinem Post hier habe ich das Problem gefunden. Hatte in luckperms die Berechtigung worldguard.region.* stehen. Warum auch immer ich diese gesetzt habe, aber das hat mir jetzt eine ganze Woche Kopfzerbrechen bereitet.

Das war ja auch dein Hinweis gewesen mit der Bypass Permission.

Das Problem ist jetzt endlich gelöst.

Dir vielen Dank und ein schönes restliches Wochenende.

Liebe Grüße
Uba
 
Oben