[Hilfe]Bungeecord Ticketsystem - gReq

Dieses Thema im Forum "Server Plugins" wurde erstellt von _SeVen94_, 8. Juni 2015.

  1. _SeVen94_
    Offline

    _SeVen94_

    Registriert seit:
    7. Juni 2015
    Beiträge:
    47
    Ort:
    Regensburg
    Minecraft:
    _SeVen94_
    Sehr verehrte Community,
    ich wollte das Plugin gReq benutzen.
    Leider gibt es im Bukkit Server ein Fehler.

    [Server thread/ERROR]: Error occurred while enabling gReqBukkit v1.2.1 (Is it up to date?)
    java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    at java.util.ArrayList.rangeCheck(ArrayList.java:653) ~[?:1.8.0_45]
    at java.util.ArrayList.get(ArrayList.java:429) ~[?:1.8.0_45]
    at me.sabbertran.greqbukkit.SQLHandler.getCurrentConnection(SQLHandler.java:27) ~[?:?]
    at me.sabbertran.greqbukkit.GReqBukkit.onEnable(GReqBukkit.java:77) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot_server.jar:git-Spigot-2f787bd-ea28011]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:335) [spigot_server.jar:git-Spigot-2f787bd-ea28011]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot_server.jar:git-Spigot-2f787bd-ea28011]
    at org.bukkit.craftbukkit.v1_8_R2.CraftServer.loadPlugin(CraftServer.java:356) [spigot_server.jar:git-Spigot-2f787bd-ea28011]
    at org.bukkit.craftbukkit.v1_8_R2.CraftServer.enablePlugins(CraftServer.java:316) [spigot_server.jar:git-Spigot-2f787bd-ea28011]
    at net.minecraft.server.v1_8_R2.MinecraftServer.r(MinecraftServer.java:416) [spigot_server.jar:git-Spigot-2f787bd-ea28011]
    at net.minecraft.server.v1_8_R2.MinecraftServer.k(MinecraftServer.java:382) [spigot_server.jar:git-Spigot-2f787bd-ea28011]
    at net.minecraft.server.v1_8_R2.MinecraftServer.a(MinecraftServer.java:337) [spigot_server.jar:git-Spigot-2f787bd-ea28011]
    at net.minecraft.server.v1_8_R2.DedicatedServer.init(DedicatedServer.java:257) [spigot_server.jar:git-Spigot-2f787bd-ea28011]
    at net.minecraft.server.v1_8_R2.MinecraftServer.run(MinecraftServer.java:522) [spigot_server.jar:git-Spigot-2f787bd-ea28011]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_45]

    Weiß jemand eventuell an was es liegt?
    -MySQL bereits eingetragen
    -BungeeCord Server zeigt keine Fehler an
    -Plugin ist aktuell (18 Tage alt - kein neueres in github etc. gefunden)

    Liebe Grüße

    _SeVen94_

    @Calenria hast du evtl. ne Idee?
     
    #1
  2. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    java.lang.IndexOutOfBoundsException: Index: 0, Size: 0

    Fehler gefunden :D
    Kontaktiere den Developer und reporte ihm diesen Fehler.
    Kann aber auch daran liegen, dass das Plugin nicht für deine Minecraft-Server-Version kompatibel ist.
     
    #2
  3. _SeVen94_
    Offline

    _SeVen94_

    Registriert seit:
    7. Juni 2015
    Beiträge:
    47
    Ort:
    Regensburg
    Minecraft:
    _SeVen94_
    Habe den Fehler gefunden.
    Lag an der Config mit den MySQL Daten man musste "- host" durch "- localhost" ersetzen hab es dahinter geschrieben
     
    #3
  4. Sabbertran
    Offline

    Sabbertran

    Registriert seit:
    24. April 2012
    Beiträge:
    75
    Minecraft:
    Sabbertran
    Schön das du den Fehler gefunden hast. Die Werte die in der Config drinstehen sind nur Platzhalter und müssen jeweils ersetzt werden.
    Bei weiteren Fragen kannst du dich auch gerne direkt an mich wenden
     
    #4
    _SeVen94_ gefällt das.