1. Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

Mod [Hilfe!] Forge will Mod nicht laden/erkennen!

Dieses Thema im Forum "Programmierung" wurde erstellt von Boy132Lp, 30. Juni 2013.


  1. Boy132Lp
    Offline

    Boy132Lp

    Registriert seit:
    25. Juli 2012
    Beiträge:
    8
    Geschlecht:
    männlich
    Minecraft:
    Boy132
    Heyy!

    Ich habe mit Forge einen Mod geschrieben und in Eclipse ist alles oky: Keine Errors, "Run Client" funktioniert.
    Also recompile ich und reobfuscate ich und packe das ganze in eine .zip Datei. Dieses ziehe ich dann in den mods Ordner und starte Minecraft. Ingame wird angezeigt "3 Mods" obwohl es ja 4 seien müssten. In der Konsole stand dies:
    Code (Text):
    1. [WARNING] [ForgeModLoader] Zip file Boy132.zip failed to read properly, it will be ignored
    2. java.lang.IllegalArgumentException: MALFORMED
    3.     at java.util.zip.ZipCoder.toString(Unknown Source)
    4.     at java.util.zip.ZipFile.getZipEntry(Unknown Source)
    5.     at java.util.zip.ZipFile.access$900(Unknown Source)
    6.     at java.util.zip.ZipFile$1.nextElement(Unknown Source)
    7.     at java.util.zip.ZipFile$1.nextElement(Unknown Source)
    8.     at java.util.Collections.list(Unknown Source)
    9.     at cpw.mods.fml.common.discovery.JarDiscoverer.discover(JarDiscoverer.java:55)
    10.     at cpw.mods.fml.common.discovery.ContainerType.findMods(ContainerType.java:42)
    11.     at cpw.mods.fml.common.discovery.ModCandidate.explore(ModCandidate.java:64)
    12.     at cpw.mods.fml.common.discovery.ModDiscoverer.identifyMods(ModDiscoverer.java:115)
    13.     at cpw.mods.fml.common.Loader.identifyMods(Loader.java:348)
    14.     at cpw.mods.fml.common.Loader.loadMods(Loader.java:480)
    15.     at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:163)
    16.     at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:411)
    17.     at net.minecraft.client.MinecraftAppletImpl.func_71384_a(SourceFile:56)
    18.     at net.minecraft.client.Minecraft.run(Minecraft.java:733)
    19.     at java.lang.Thread.run(Unknown Source)
    Bitte um Hilfe!


    Gruß Boy132
     
  2. AchtungTroll
    Offline

    AchtungTroll

    Registriert seit:
    9. Juli 2012
    Beiträge:
    318
    Minecraft:
    Xusiy
    Versuch mal nicht den .zip Ordner in den Mods Ordner zu schieben, sondern ein ganz normalen Ordner!
     
  3. Boy132Lp
    Offline

    Boy132Lp

    Registriert seit:
    25. Juli 2012
    Beiträge:
    8
    Geschlecht:
    männlich
    Minecraft:
    Boy132
    Danke hat funktioniert!


    Danke danke danke ;D


    Gruß Boy132

    EDIT:

    Heyy!

    Meine Mod zeigt im Spiel nur komische "schwarz lila" Texturen an...
    Auf der 1.5.2 ging es noch! Für mehr Infos einfach eine Antwort posten.

    Bitte um Hilfe!


    Gruß Boy132
     
    Zuletzt von einem Moderator bearbeitet: 5. Juli 2013
  4. AchtungTroll
    Offline

    AchtungTroll

    Registriert seit:
    9. Juli 2012
    Beiträge:
    318
    Minecraft:
    Xusiy
    Ich glaube der Mod ist nicht für die 1.6.1, wenn ja, dann hat der Entwickler vergessen die Texturen einzufügen!
     
  5. Boy132Lp
    Offline

    Boy132Lp

    Registriert seit:
    25. Juli 2012
    Beiträge:
    8
    Geschlecht:
    männlich
    Minecraft:
    Boy132
    Doch die Mod ist auf der 1.6.1 und die Texturen können (laut Konsole) nicht geladen werden...
    Code (Text):
    1. 2013-07-05 20:54:21 [SEVERE] [Minecraft-Client] Using missing texture, unable to load: unimcraft:textures/items/Rubinschaufel.png
    2. 2013-07-05 20:54:21 [SEVERE] [Minecraft-Client] Using missing texture, unable to load: unimcraft:textures/items/Rubin.png
    3. 2013-07-05 20:54:21 [SEVERE] [Minecraft-Client] Using missing texture, unable to load: unimcraft:textures/blocks/Rubinerz.png

    Gruß Boy132
     
  6. Boy132Lp
    Offline

    Boy132Lp

    Registriert seit:
    25. Juli 2012
    Beiträge:
    8
    Geschlecht:
    männlich
    Minecraft:
    Boy132
    Hab die Lösung gefunden: Musste alles klein schreiben -.-

    Trotzdem Danke ;)

    Gruß Boy132