HILFE

Dieses Thema im Forum "Programmierung" wurde erstellt von laserVeit, 24. Januar 2016.

  1. laserVeit
    Offline

    laserVeit

    Registriert seit:
    2. Dezember 2015
    Beiträge:
    13
    Kann mir jemand sagen wie ich das fixen kann?

    Benutze Spigot_server1.8.jar


    [14:17:44 ERROR]: Could not load 'plugins/ChatZ.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: main/PromoteV2 : Unsupported major.minor version 52.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot-server1.8.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot-server1.8.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot-server1.8.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:291) [spigot-server1.8.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:152) [spigot-server1.8.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:505) [spigot-server1.8.jar:git-Spigot-c3c767f-33d5de3]
    at java.lang.Thread.run(Thread.java:745) [?:1.7.0_80]
    Caused by: java.lang.UnsupportedClassVersionError: main/PromoteV2 : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_80]
    at java.lang.ClassLoader.defineClass(ClassLoader.java:800) ~[?:1.7.0_80]
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.7.0_80]
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:449) ~[?:1.7.0_80]
    at java.net.URLClassLoader.access$100(URLClassLoader.java:71) ~[?:1.7.0_80]
    at java.net.URLClassLoader$1.run(URLClassLoader.java:361) ~[?:1.7.0_80]
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355) ~[?:1.7.0_80]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_80]
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354) ~[?:1.7.0_80]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-server1.8.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-server1.8.jar:git-Spigot-c3c767f-33d5de3]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_80]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_80]
    at java.lang.Class.forName0(Native Method) ~[?:1.7.0_80]
    at java.lang.Class.forName(Class.java:278) ~[?:1.7.0_80]
    at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:64) ~[spigot-server1.8.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-server1.8.jar:git-Spigot-c3c767f-33d5de3]
    ... 6 more
     
    #1
  2. MysticRunes
    Offline

    MysticRunes

    Registriert seit:
    19. November 2013
    Beiträge:
    40
    Welche JRE nutzt du? Kann es sein, dass der server mit einer anderen JRE läuft als die, mit der du das Plugin kompilierst?
     
    #2
  3. skcxck
    Offline

    skcxck

    Registriert seit:
    9. November 2013
    Beiträge:
    12
    Ort:
    Frankfurt am Main
    Minecraft:
    skcxck
    Wie mein Vorgänger bereits erläutert hat, kannst du z.B. ein in JDK 8 programmiertes Plugin nicht auf JRE 7> nutzen.
    Einfaches googlen des Errors zeigt dir in Sekunden schnelle Lösungswege:
    http://lmgtfy.com/?q=Unsupported+major.minor+version+51.0+bukkit
     
    #3
    Malfrador und jensIO gefällt das.
  4. Tahrll_
    Offline

    Tahrll_

    Registriert seit:
    31. Januar 2014
    Beiträge:
    35
    Ort:
    Franken
    Minecraft:
    _DarkShadow_
    Hast du schon mal geschaut ob es eine dev Version gibt?

    und was soll das plugin machen?
     
    #4
  5. trikeyyy
    Offline

    trikeyyy

    Registriert seit:
    9. Januar 2016
    Beiträge:
    8
    Minecraft:
    trikeyyy
    Du musst auf deinem Server die gleiche Java-Version laufen lassen, wie die Java-Version, mit der du programmierst.
    Heisst: Wenn du mit Java 8 programmierst, braucht dein Server auch Java 8.
     
    #5
  6. laserVeit
    Offline

    laserVeit

    Registriert seit:
    2. Dezember 2015
    Beiträge:
    13
    Gut Danke Leute ich habe gesehen das mein Server Java 7 Hatte
     
    #6
  7. Kroseida
    Offline

    Kroseida

    Registriert seit:
    28. September 2015
    Beiträge:
    55
    Ort:
    /root/
    Minecraft:
    Kroseida
    irgendwie stand ja genau das im log?
    naja mit bissel Googlen wärst du darauf gekommen...
     
    #7
    jensIO gefällt das.