Kleine Frage

Dieses Thema im Forum "Technischer Support" wurde erstellt von Basti07711, 16. Juli 2013.

  1. Basti07711
    Offline

    Basti07711 Ehem. Teammitglied

    Registriert seit:
    2. August 2012
    Beiträge:
    714
    Ort:
    Hinter dir
    Minecraft:
    Basti07711
    Hi Leute,
    seitdem ich meinen Server auf die CB 1.6.2 geupdatet hab, kommt dieser fehler in der Konsole (er hat keine Auswirkungen, man kann normal Spielen):
    Code (Text):
    1. 2013-07-16 18:50:29 [WARNING] Method "public Class<?> getClassByName(String)" is Deprecated, and may be removed in a future version of Bukkit
    2. org.bukkit.plugin.AuthorNagException:
    3.         at org.bukkit.plugin.java.JavaPluginLoader.getClassByName(JavaPluginLoader.java:284)
    4.         at com.earth2me.essentials.storage.BukkitConstructor.getClassForNode(BukkitConstructor.java:421)
    5.         at org.yaml.snakeyaml.constructor.Constructor$ConstructYamlObject.getConstructor(Constructor.java:321)
    6.         at org.yaml.snakeyaml.constructor.Constructor$ConstructYamlObject.construct(Constructor.java:331)
    7.         at org.yaml.snakeyaml.constructor.BaseConstructor.constructObject(BaseConstructor.java:183)
    8.         at org.yaml.snakeyaml.constructor.BaseConstructor.constructDocument(BaseConstructor.java:142)
    9.         at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:128)
    10.         at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:480)
    11.         at org.yaml.snakeyaml.Yaml.load(Yaml.java:423)
    12.         at com.earth2me.essentials.storage.YamlStorageReader.load(YamlStorageReader.java:47)
    13.         at com.earth2me.essentials.storage.AbstractDelayedYamlFileReader.run(AbstractDelayedYamlFileReader.java:38)
    14.         at org.bukkit.craftbukkit.v1_6_R2.scheduler.CraftTask.run(CraftTask.java:53)
    15.         at org.bukkit.craftbukkit.v1_6_R2.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:53)
    16.         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
    17.         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
    18.         at java.lang.Thread.run(Thread.java:722)
    19. 2013-07-16 18:50:29 [SEVERE] Reached end of stream for null
    20. 2013-07-16 18:50:29 [SEVERE] Reached end of stream for null
    21.  
    Wisst ihr was das soll?
     
    #1
  2. MiCrJonas
    Offline

    MiCrJonas

    Registriert seit:
    29. Oktober 2012
    Beiträge:
    1.069
    Wird wohl noch gefixt. Einfach immer die neusten Versionen benutzen
     
    #2
  3. Chrisliebaer
    Online

    Chrisliebaer

    Das bedeutet, das ein Plugin bei dir entweder steinalt, oder einfach nur schlecht programmiert ist:
    Code (Text):
    1. com.earth2me.essentials.storage.BukkitConstructor.getClassForNode(BukkitConstructor.java:421)
    Riecht stark nach essentials, kann es sein, dass du da irgendwas steinaltes verwendest?
     
    #3
  4. games6471
    Online

    games6471

    Depracted bedeutet, dass die Methode getClassbyName nicht mehr verwendet werden soll.

    Hier die Begründung vom JavaDoc:

    Einfach das Entwickler-Team anschreiben. (Hier Essentials) Vermutlich kennen sie die Meldung schon.
     
    #4
  5. Basti07711
    Offline

    Basti07711 Ehem. Teammitglied

    Registriert seit:
    2. August 2012
    Beiträge:
    714
    Ort:
    Hinter dir
    Minecraft:
    Basti07711
    Eig. ist die Version von Essentials die neuste, die da ist. Sonst sind alle Plugins auf 1.5.2, 1.6.1 oder 1.6.2. Das ist nicht alzu alt.
     
    #5
  6. Crafter6432
    Offline

    Crafter6432

    Registriert seit:
    22. Dezember 2011
    Beiträge:
    686
    Ist Bukkit vllt. zu neu ?
     
    #6
  7. Basti07711
    Offline

    Basti07711 Ehem. Teammitglied

    Registriert seit:
    2. August 2012
    Beiträge:
    714
    Ort:
    Hinter dir
    Minecraft:
    Basti07711
    Nein ist sie eig. nicht.
    Ich habe nun das Essentials-Team kontaktiert.
     
    #7