Lags bei AutoSaveWorld

Dieses Thema im Forum "Server Plugins" wurde erstellt von Kaladial, 29. September 2013.

  1. Kaladial
    Offline

    Kaladial

    Registriert seit:
    25. Mai 2013
    Beiträge:
    91
    moin

    seit letzter woche laufen wir auf craftbukkit 1.6.4 das hab ich zum anlass genommen mal wieder alle plugins zu updaten.
    ein problem was seit dem auftritt : das plugin autosaveworld braucht teilweise 20-25 sekunden zum unsere welten zu saven.

    hier meine frage dazu: wieso ist das so ? version 4.9.1 drauf, bzw wie kann man das ändern ?
    weil viele saves laufen in 1-2 sec und manchmal dauert es halt 20-25 sec?

    kann mir da einer weiter helfen ?

    thx kala
     
    #1
  2. Also ich finde das normal.

    Bei mir ist das auch so.
     
    #2
  3. Endless1989
    Offline

    Endless1989

    Registriert seit:
    31. März 2012
    Beiträge:
    163
    Seit 1.6.4 werden Minecraft Structures irgendwie anders gespeichert. Kann dir nicht genau erklären wieso weshalb, da sind andere schlauer.

    Bei Spigot kannst du auf jeden fall "save-structure-info" auf false setzen. Musst mal schauen ob du das in der bukkit.yml findest.

    Hat aber den Nachteil, das dein Nether dann mit 1.7 irgendwie keine Nether Skelette mehr Spawnt, weil er nicht mehr erkennt wo Netherfestungen sind, oder Hexenhäuser keine Hexen in der Wildnis usw.

    Gruß
    Endless
     
    #3
  4. Kaladial
    Offline

    Kaladial

    Registriert seit:
    25. Mai 2013
    Beiträge:
    91
    naja ok

    ich hab jetzt enfach die abstände zwischen den saves reduziert und nur die maps gesaved die wichtig sind ... farmwelten usw werden jetzt einfach ausgelassen mal gucken ob das was bringt

    aber thx für die hilfe
     
    #4
  5. Arko93
    Offline

    Arko93

    Registriert seit:
    9. März 2012
    Beiträge:
    529
    Minecraft:
    Arko93
    save-structure-info= wo sind NetherFestungen und Hexenhäuser ohne die info spawnen die nicht mehr
     
    #5
  6. afaik4711
    Offline

    afaik4711

    Registriert seit:
    29. Februar 2012
    Beiträge:
    24
    Ich habe bei mir auch das Save-structure-info auf false gesetzt (Spigot Server 1.6.4 #1130)
    Seit dem hat sich der RAM Verbrauch mal eben halbiert. So wie ich es verstanden habe, gilt das nur für die 1.7 und wenn die kommt, kann es sein das dieser Manüpunkt verschwindet.
    Ich kann irgendwie noch nicht so ganz verstehen, warum das structure-saving so unglaublich viele Ressourcen verschlingt.
    Aber ich verzichte lieber auf ein paar Mobs, hab dafür aber einen flüssig-laufenden Server.
    Auch bei mir hat der 15-minütige Force-Save bestimmt 15 - 20 sek. gedauert. Jetzt wieder <1 sek.
     
    #6