Login auf Server geht nicht per BungeeCord

Dieses Thema im Forum "Technischer Support" wurde erstellt von MineCraftPlayer1985, 30. August 2016.

  1. MineCraftPlayer1985
    Offline

    MineCraftPlayer1985

    Registriert seit:
    30. August 2016
    Beiträge:
    3
    Hallo @All,

    ich hoffe Ihr könnt mir helfen denn ich habe ein kleines Problem mit BungeeCord.

    Wenn ich mich auf einen Server direct verbinde geht der Login ohne Probleme, jedoch wenn ich über BungeeCord komme gibt es Fehlermeldungen und die Verbindung bricht ab.

    Auszug aus dem BungeeCord-Log:
    Code (Text):
    1. 14:36:48 [INFO] [###USER###] <-> ServerConnector [server1] has connected
    2. 14:36:51 [SEVERE] [###USER###] <-> DownstreamBridge <-> [server1] - encountered exception
    3. io.netty.handler.codec.DecoderException: java.lang.ArrayIndexOutOfBoundsException: -26
    4.   at io.netty.handler.codec.MessageToMessageDecoder.channelRead(MessageToMessageDecoder.java:99)
    5.   at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:318)
    6.   at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(AbstractChannelHandlerContext.java:304)
    7.   at io.netty.handler.codec.ByteToMessageDecoder.fireChannelRead(ByteToMessageDecoder.java:276)
    8.   at io.netty.handler.codec.ByteToMessageDecoder.callDecode(ByteToMessageDecoder.java:354)
    9.   at io.netty.handler.codec.ByteToMessageDecoder.channelRead(ByteToMessageDecoder.java:244)
    10.   at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:318)
    11.   at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(AbstractChannelHandlerContext.java:304)
    12.   at io.netty.handler.timeout.ReadTimeoutHandler.channelRead(ReadTimeoutHandler.java:152)
    13.   at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:318)
    14.   at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(AbstractChannelHandlerContext.java:304)
    15.   at io.netty.channel.DefaultChannelPipeline.fireChannelRead(DefaultChannelPipeline.java:846)
    16.   at io.netty.channel.epoll.AbstractEpollStreamChannel$EpollStreamUnsafe.epollInReady(AbstractEpollStreamChannel.java:823)
    17.   at io.netty.channel.epoll.EpollEventLoop.processReady(EpollEventLoop.java:339)
    18.   at io.netty.channel.epoll.EpollEventLoop.run(EpollEventLoop.java:255)
    19.   at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:112)
    20.   at java.lang.Thread.run(Thread.java:745)
    21. Caused by: java.lang.ArrayIndexOutOfBoundsException: -26
    22.   at net.md_5.bungee.protocol.Protocol$DirectionData.createPacket(Protocol.java:130)
    23.   at net.md_5.bungee.protocol.MinecraftDecoder.decode(MinecraftDecoder.java:30)
    24.   at net.md_5.bungee.protocol.MinecraftDecoder.decode(MinecraftDecoder.java:10)
    25.   at io.netty.handler.codec.MessageToMessageDecoder.channelRead(MessageToMessageDecoder.java:89)
    26.   ... 16 more
    27. 14:36:51 [INFO] [###USER###] <-> DownstreamBridge <-> [server1] has disconnected
    28. 14:36:51 [INFO] [###USER###] disconnected with: Could not connect to default or fallback server, please try again later: java.net.ConnectException
    Auszug aus dem Server-Log:
    Code (Text):
    1. [14:36:48 INFO]: UUID of player ###USER### is ###UID###
    2. [14:36:48 INFO]: Client protocol version 2
    3. [14:36:48 INFO]: Client attempting to join with 99 mods : BuildCraft|Silicon@6.4.14,DynamicLights_onFire@1.0.5,ProjRed|Expansion@4.7.0pre5.89,ForgeMicroblock@1.2.0.345,ExtraBees@2.0-pre3,DynamicLights@1.3.9,DynamicLights_floodLights@1.0.2,ThaumicExploration@0.6.0,MedicineCraft@V4.0,Botany@2.0-pre3,ProjRed|Integration@4.7.0pre5.89,GardenContainers@1.2.0,McMultipart@1.2.0.345,ImmibisMicroblocks@59.0.0,BiomesOPlenty@2.1.0,ProjRed|Fabrication@4.7.0pre5.89,props@2.2.1,Railcraft@9.9.0.0,ThermalFoundation@1.7.10R1.0.0,ForgeMultipart@1.2.0.345,flenixroads@0.9.0,MCFrames@1.0,DynamicLights_dropItems@1.0.8,CoFHCore@1.7.10R3.0.2,DynamicLights_entityClasses@1.0.1,powersuits@0.11.0.300,BiblioWoodsForestry@1.7,OpenPeripheral@0.5.1,FastCraft@1.21,Forge@10.13.3.1403,ExtraTrees@2.0-pre3,DynamicLights_otherPlayers@1.0.8,GardenTrees@1.2.0,autoswitch@5.1.1,ImmibisCore@59.0.1,AdvancedSolarPanel@1.7.10-3.5.1,BuildCraft|Energy@6.4.14,IC2@2.2.658-experimental,DynamicLights_creepers@1.0.4,ProjRed|Transportation@4.7.0pre5.89,FML@7.10.141.1403,Natura@2.2.0,thebombzenapi@2.4.2,BiblioWoodsNatura@1.5,<CoFH ASM>@000,WailaHarvestability@1.1.1,ProjRed|Illumination@4.7.0pre5.89,Botania@r1.8-249,LogisticsPipes@0.9.1.156,NotEnoughItems@1.0.3.74,Thaumcraft@4.2.3.5,Waila@1.5.4a,ProjRed|Compatibility@4.7.0pre5.89,ForgeRelocation@0.0.1.3,TConstruct@1.7.10-1.8.1.build815,PlayerAPI@1.4,BinnieCore@2.0-pre3,BiblioCraft@1.9.2,BuildCraft|Core@6.4.14,OpenModsCore@0.9.1,RelocationFMP@0.0.1.2,Genetics@2.0-pre3,mcp@9.05,Mantle@1.7.10-0.3.2.jenkins184,ProjRed|Transmission@4.7.0pre5.89,GardenCore@1.2.0,journeymap@5.0.1,OpenPeripheralIntegration@0.5,inventorytweaks@1.58-147-645ca10,harvestcraft@1.7.10g,CompactSolars@4.4.39.315,BuildCraft|Factory@6.4.14,OpenPeripheralCore@1.3,Tubestuff@59.0.4,EnderStorage@1.4.5.27,CarpentersBlocks@3.3.7,ComputerCraft@1.75,neiintegration@1.1.2,AWWayofTime@v1.3.3,MrTJPCoreMod@1.1.0.27,IronChest@6.0.62.742,BinnieFix@1.0-7,numina@0.4.0.131,DynamicLights_mobEquipment@1.0.8,CodeChickenCore@1.0.4.29,DynamicLights_flameArrows@1.0.0,BuildCraft|Transport@6.4.14,chisel@2.9.4.10,Baubles@1.0.1.10,ProjRed|Core@4.7.0pre5.89,ProjRed|Exploration@4.7.0pre5.89,witchery@0.24.1,AS_Ruins@15.4,Forestry@3.3.0.6,OpenMods@0.9.1,BiblioWoodsBoP@1.9,PTRModelLib@1.0.0,BuildCraft|Builders@6.4.14,DynamicLights_thePlayer@1.1.4
    4. [14:36:48 INFO]: Attempting connection with missing mods [] at CLIENT
    5. [14:36:51 INFO]: [Server thread] Server side modded connection established
    6. [14:36:51 INFO]: ###USER###[/xxx.xxx.xxx.xxx:51684] logged in with entity id 1863 at ([world] 0.5, 87.0, 0.5)
    7. [14:36:51 INFO]: [mcjobs] Unable to load ###USER###.dat...  Creating file!
    8. [14:36:51 INFO]: ###USER### lost connection: Internal Exception: java.io.IOException: Broken pipe
    9. [14:36:51 INFO]: ###USER### hat den Server verlassen.
    Ich hoffe ich bekomme von Euch schnelle Hilfe, vielen Dank bereits jetzt an alle die diesen Post lesen.

    Liebe Grüße
    MineCraftPlayer1985
     
    #1
  2. jensIO
    Offline

    jensIO

    Registriert seit:
    28. Juli 2015
    Beiträge:
    602
    Ort:
    Internet, im Neuland
    Minecraft:
    jens1o
    Bitte code-Tag nutzen.

    Ansonsten sieht es danach aus, dass keine User-Dateien erstellt werden dürfen, gebe den Serverordnern bitte testweise mal 777
     
    #2
  3. MineCraftPlayer1985
    Offline

    MineCraftPlayer1985

    Registriert seit:
    30. August 2016
    Beiträge:
    3
    Ich hatte den Code-Button nicht gefunden habe es nun über den ASCI-Editor als Code eingestellt.

    Da die Datei beim Login ohne BungeeCord bereits erstellt wurde denke ich nicht das es darann liegt.
    -> Oder muss bei BungeeCord auch eine User-Datei angelegt werden?
    Welche Ordner sollte ich denn auf "777" stellen?
     
    #3
  4. jensIO
    Offline

    jensIO

    Registriert seit:
    28. Juli 2015
    Beiträge:
    602
    Ort:
    Internet, im Neuland
    Minecraft:
    jens1o
    Code (Text):
    1. [14:36:51 INFO]: [mcjobs] Unable to load ###USER###.dat...  Creating file!
    2.  
    3. [14:36:51 INFO]: ###USER### lost connection: Internal Exception: java.io.IOException: Broken pipe
    Das steht in deinem Serverlog ;)

    Bei beiden müss(t)en Dateien erstellt werden, aber die IOException kann auch gefeuert werden wenn ein Routing Fehler oder ähnliches vorligt. Die ist nicht eindeutig. Probiere trotzdessen mal
    Code (Text):
    1. chmod 777 *
    bei jedem Ordner auszuführen und schau, ob der Fehler immernoch vorkommt.
     
    #4
  5. MineCraftPlayer1985
    Offline

    MineCraftPlayer1985

    Registriert seit:
    30. August 2016
    Beiträge:
    3
    Also habe es versucht, doch leider ist der Fehler immer noch vorhanden!
     
    #5