Mehrere Plugin Probleme

Dieses Thema im Forum "Technischer Support" wurde erstellt von pjroeder10, 27. Juli 2013.

  1. pjroeder10
    Offline

    pjroeder10

    Registriert seit:
    25. April 2012
    Beiträge:
    5
    Hallo,
    ich habe bei meinem Minecraft-Server mehrere Probleme mit verschiedenen Plugins.

    1. SurvivalGames
    Das Plugin stellt gelöschte Arenen immer wieder her. Wenn ich die Dateien der Arenen lösche und den Server neu starte, erscheinen die Arenen jedes mal wieder. Wenn ich versuche die Arenen mit /sg delarena zu löschen bekomme ich folgende Fehlermelgung:
    [SG] [Error] The command [delarena] [1] returned an error
    [SG] Type /sg help for command information
    Ich habe das Plugin bereits 2 mal komplett gelöscht und mit einer neuen .jar installiert, aber die Arenen bleiben.

    2. NPCWarehouse
    Hier habe ich genau das umgekehrte Problem: Nach jedem Restart verschwinden die NPC. In der npcs.yml wird bei allen npcs der Wert dead auf true gesetzt. Wenn ich ihn wieder aus false setze ist die Datei nach dem Restart komplett leer.

    3. Multiverse-Core/Portals
    Nach jedem Serverrestart "vergisst" Multiverse einige meiner Welten. Diese muss ich dann immer wieder mit /mv import reaktiviern. Die Multiverse Portale in den betroffenen Welten verschwinden. Das Problem tritt nur bei einem Restart auf, wenn ich dem Befehl /reload all verwende passiert es nicht. Es sind auch nicht alle Welten betroffen. Die beiden ältesten bleiben, aber drei neuere werden "vergessen".


    Serverlog bei einem Restart im Anhang.

    Mein Server hat 2 GB RAM.

    Plugins:
    ChestShop
    Essentials
    HeadDrops
    Herochat
    iConomy
    Jobs
    LogBlock
    MobArena
    Mulitverse-Core
    Mulitverse-Inventories
    Mulitverse-Portals
    NPCWarehouse
    PermissionsEX
    SimpleClans
    SuperSpleef
    SupplySign
    SurvivalGames
    TerrainControl
    Votifier
    WorldBorder
    WorldEdit
    WorldGuard

    Danke schonmal für die Hilfe!
     

    Anhänge:

    #1
  2. nickless
    Offline

    nickless

    Registriert seit:
    26. August 2011
    Beiträge:
    231
    1. Bei Logblock die mysql daten richtig einstellen
    2. TerrainControl auf Bukkit version anpassen (1.5.2)
    3. Multiverse auf Bukkit Version anpassen (Version 2.4 ist schon relativ alt)
    4. Jobs Config auf ungültige zeichen überprüfen
    5. NPC Warehouse Version überprüfen
    6. Simple Clans auto Updater abschalten
    7 Wordledit updaten
    Bei Survival Games nicht nur die .jar löschen sondern die config ebenso.

    Erklärung:
    Code (Text):
    1.  
    2. 2013-07-26 23:09:23 [SEVERE] [LogBlock] Error while fetching connection:
    3. com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Access denied for user 's362033'@'%' to database 'minecraft'
    4. Das Plugin kann sich nicht am mysql Server anmelden. Prüfe benutzername und Passwort in der Config oder stelle auf sqlite um.
    5.  
    6. 2013-07-26 23:09:23 [SEVERE] Error occurred while enabling TerrainControl v2.4.12 (Is it up to date?)
    7. java.lang.NoClassDefFoundError: net/minecraft/server/v1_5_R3/World
    8. Die Version von TerrainControl (v2.4.12) ist für Minecraft 1.6.2. Dein Server ist auf 1.5.2
    9.  
    10. 2013-07-26 23:09:27 [SEVERE] Error occurred while enabling Multiverse-Core v2.4-b527 (Is it up to date?)
    11. java.lang.NoClassDefFoundError: net/minecraft/server/v1_5_R3/WorldProvider
    12. Die Multiverse Version (v2.4) ist für Minecraft 1.4.5
    13.  
    14. 2013-07-26 23:09:30 [SEVERE] ==================== Jobs ====================
    15. 2013-07-26 23:09:30 [SEVERE] Unable to load jobConfig.yml!
    16. 2013-07-26 23:09:30 [SEVERE] Check your config for formatting issues!
    17. 2013-07-26 23:09:30 [SEVERE] No jobs were loaded!
    18. 2013-07-26 23:09:30 [SEVERE] Error: unacceptable character '�' (0xFFFD) special characters are not allowed
    19. in "<string>", position 622
    20. 2013-07-26 23:09:30 [SEVERE] ==============================================
    21. In deiner Jobs Config sind ungültige Zeichen enthalten.
    22.  
    23. 2013-07-26 23:09:32 [SEVERE] Error occurred while enabling NPCWarehouse v1.0-dev (Is it up to date?)
    24. java.lang.NullPointerException
    25. Wenn du schon Dev Builds verwendest musst du mit bugs Rechnen. Versuche hier eine neuere Version zu nutzen oder Downgrade auf ein Stable Build
    26.  
    27. 2013-07-26 23:09:57 [INFO] SimpleClans [AutoUpdate] [m
    28. 2013-07-26 23:09:57 [INFO] SimpleClans [AutoUpdate] Internal error![m
    29. Auto Updater Kaputt, abschalten hilft.
    30.  
    31. 2013-07-26 23:10:05 [WARNING] [WorldEdit] No compatible nms block class found.
    32. Der Fehler ist in einem neuerem Build behoben.
    33.  
    34. und nochmal ein auto updater
    35. 2013-07-26 23:10:16 [WARNING] [SurvivalGames] [SurvivalGames] could not check for updates.
    36.  
    37.  
    38.  
    Edit: Tippfehler verbessert
     
    #2
  3. games6471
    Online

    games6471

    Multiverse muss nicht geupdatet werden, da es einwandfrei funktioniert und bisher noch keine neue Version auf BukkitDev existiert, sondern nur Builds auf Jenkins. (Der Fehler kam nämlich nur von TerrainControl) Achso und btw 2.4 ist nicht die Build-Nummer,- 527 ist die Build-Nummer.
     
    #3
  4. nickless
    Offline

    nickless

    Registriert seit:
    26. August 2011
    Beiträge:
    231
    #4
  5. pjroeder10
    Offline

    pjroeder10

    Registriert seit:
    25. April 2012
    Beiträge:
    5
    1. Logblock, Jobs, SimpleClans und TerrainControl haben mit den Problemen nichts zu tun.
    2. Mulitverse ist auf dem neusten Stand.
    http://dev.bukkit.org/bukkit-plugins/multiverse-core/files/23-2-4-ab/
    3. Bei SurvivalGames habe ich alle Datein (Ordner+.jar) gelöscht und eine neu gedownloadete .jar benutzt der Fehler tritt dennoch auf.
    4. WorldEdit update hat nichts gebracht
    5. Durch das NPCWarehouse Update kann ich jetzt nicht mal mehr Npc spawnen.
     

    Anhänge:

    #5
  6. games6471
    Online

    games6471

    Das stimmt nicht wirklich. Wenn du dir mal die Fehlermeldung genau anschaust, dann siehst du dass nur TerrainControl den Fehler auslöst und nicht Multiverse. Multiverse nutzt meines Wissens kein NMS oder OBC Code und ist somit zu 90 % mit allen weiteren Version von Bukkit kompatibel.

    Ach schau dir mal die pom.xml an:

    https://github.com/Multiverse/Multiverse-Core/blob/master/pom.xml

     
    #6
  7. nickless
    Offline

    nickless

    Registriert seit:
    26. August 2011
    Beiträge:
    231
    #7
  8. pjroeder10
    Offline

    pjroeder10

    Registriert seit:
    25. April 2012
    Beiträge:
    5
    Ich habe NPCWarehouse auf diese Version geupdatet. Jetzt kann ich nicht einmal mehr Npc spawnen.
    Ein TerrainControl uptate scheint das Multiverse-Problem behoben zu haben. Dafür Danke :)
     
    #8
  9. games6471
    Online

    games6471

    1.
    a. Doch dadurch, dass TerrainControl nicht aktuell ist kann Multiverse auch nicht Welt laden.​
    b. Du sollstest aber auch die anderen Fehler lösen, damit die Plugins ordentlich funktionieren.​

    3. Hast du das gemacht während der Server noch lief? Falls ja, dann hat er vermutlich die Daten beim Runterfahren vom Arbeitspeicher auf die Festplatte geschrieben.

    5. Könntest du uns mal deine Configuration von dem Plugin posten posten. Ich glaube der Wert in dem Punkte General.language ist fehlend.
     
    #9
  10. pjroeder10
    Offline

    pjroeder10

    Registriert seit:
    25. April 2012
    Beiträge:
    5
    Ich habe TerrainControl geupdatet und das Multiverse Problem ist verschwunden, dafür danke :)

    Config:
    General:
    #Use permissionsex (or any fake permissions/permissions bridge)
    use-permissionsex: true

    #Use PermissionsBukkit
    use-permissionsbukkit: false

    #Send plugin stats to metrics (mcstats.org)
    use-metrics: true

    #Allow players to select NPCs by right clicking them
    enable-right-click-selecting: true

    #Allow players to create NPCs by placing sand on top of wool
    enable-npc-crafting: false

    #Should NPCs that have died spawn again on reload/restart
    dead-npcs-respawn-on-reload: true

    #Should players be notified when their NPC dies
    enable-death-message: false

    #Should guards be allowed on the server
    enable-guards: true

    Messages:
    #Format that NPCs talk in. Available tags are {name}, {msg}, {type}, and {world}
    chat-format: <{name}> {msg}

    #Should NPCs talk to players when the player comes within 5 blocks of the NPC?
    enable-talk-close: true

    #How many seconds should the NPC wait between talking to a player? (MUST have enable-talk-close set to true)
    message-interval: 10

    Spout:
    #Enable spout
    use-spout: false

    #Allow players to change NPC skins (use-spout must equal true)
    allow-skin-changing: false

    #Allow players to change NPC capes (use-spout must equal true)
    allow-cape-changing: false

    MailMen:
    #Enable mailman (By enabling mailmen you agree to send information to NPCWarehouse.net in order to link your mailman with other mailmen)
    enable-mailmen: true

    #Prices to perform actions
    Economy:

    #Enable the Economy features. This is needed for traders to be enabled -- The Vault plugin is needed to enable this
    enable-economy: false

    create: 50.0
    toggle:
    mailman: 50.0
    guardian: 50.0
    miner: 50.0
    rename: 10.0
    mailman:
    send-mail: 5.0
    miner:
    mine: 10.0

    Update:
    #What channel to download updates from (options are developmental and recommended)
    channel: recommended

    #DO NOT CHANGE
    config-version: 2


    3. Ja das war mein Fehler, ich habs nochmal gemacht (diesmal richtig) und jetzt geht es - danke dir

    Die anderen Fehler habe ich soweit auch behoben, fehlt nur noch NPCWarehouse
     
    #10
  11. games6471
    Online

    games6471

    Du solltest die Config neu generieren und eventuell deine Alte vorher absichern, denn es fehlt wirklich der Punkt language.
     
    #11
  12. pjroeder10
    Offline

    pjroeder10

    Registriert seit:
    25. April 2012
    Beiträge:
    5
    Habe die Config neu generiert jetzt bekomme ich diese Fehlermeldung wenn ich /npc create mache:
    An internal error occurred while attempting to perform this command

    In der server.log:
    2013-07-27 16:17:36 [INFO] JasPfl issued server command: /npc create Wache
    2013-07-27 16:17:36 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'npc' in plugin NPCWarehouse v0.9.4
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:189)
    at org.bukkit.craftbukkit.v1_6_R2.CraftServer.dispatchCommand(CraftServer.java:523)
    at net.minecraft.server.v1_6_R2.PlayerConnection.handleCommand(PlayerConnection.java:964)
    at net.minecraft.server.v1_6_R2.PlayerConnection.chat(PlayerConnection.java:882)
    at net.minecraft.server.v1_6_R2.PlayerConnection.a(PlayerConnection.java:839)
    at net.minecraft.server.v1_6_R2.Packet3Chat.handle(SourceFile:49)
    at net.minecraft.server.v1_6_R2.NetworkManager.b(NetworkManager.java:296)
    at net.minecraft.server.v1_6_R2.PlayerConnection.e(PlayerConnection.java:118)
    at net.minecraft.server.v1_6_R2.ServerConnection.b(SourceFile:37)
    at net.minecraft.server.v1_6_R2.DedicatedServerConnection.b(SourceFile:30)
    at net.minecraft.server.v1_6_R2.MinecraftServer.t(MinecraftServer.java:590)
    at net.minecraft.server.v1_6_R2.DedicatedServer.t(DedicatedServer.java:226)
    at net.minecraft.server.v1_6_R2.MinecraftServer.s(MinecraftServer.java:486)
    at net.minecraft.server.v1_6_R2.MinecraftServer.run(MinecraftServer.java:419)
    at net.minecraft.server.v1_6_R2.ThreadServerApplication.run(SourceFile:582)
    Caused by: java.lang.NullPointerException
    at net.npcwarehouse.CommandHandler.createNPC(Unknown Source)
    at net.npcwarehouse.CommandHandler.runCommand(Unknown Source)
    at net.npcwarehouse.CommandHandler.onCommand(Unknown Source)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    ... 15 more
     
    #12
  13. games6471
    Online

    games6471

    Ok, dann schick mal die neue Server.log.
     
    #13
  14. games6471
    Online

    games6471

    Sorry hab deinen Edit bis jetzt noch nicht gesehen. Schön wäre auch eine vollständige Server.log gewesen, da die Fehlerursache beim Starten ausgelöst wird. Es wird dort nämlich NMS-Code verwendet. Dieser ist jedoch bei dir nicht vorhanden, da die Version 0.9.4 von dem Plugin nicht für die von dir verwendete Craftbukkit Version vorgesehen ist. Der Entwickler hat bereits eine Version für 1.6.2 gemacht, jedoch ist diese (noch) nicht auf BukkitDev veröffentlicht. Du kannst dir aber bereits de Version auf seiner Dev-Build Seite runterladen hier
     
    #14