Minecraft 1.7.2-Forge startet nicht

Dieses Thema im Forum "Technischer Support" wurde erstellt von Yellowphoenix18, 2. April 2015.

  1. Yellowphoenix18
    Offline

    Yellowphoenix18

    Registriert seit:
    26. März 2013
    Beiträge:
    267
    Ort:
    Niedersachsen
    Minecraft:
    YellowPhoenix18
    Hallo, ich habe derzeit in meinem Minecraft die 1.7.2-Forge eingestellt,da nur mit dieser Version mein CameraStudio-Mod läuft,doch mit dem Update von java gab es bei mir nur Probleme, ich musste bereits eclipse austauschen etc..Nun habe ich alles wieder zum laufen gebracht,nur meine 1.7.2-Forge will nichtmehr. Ich habe auch schon versucht alle Mods zu entfernen,aber das brachte nichts.

    Vlt. kann ja einer von euch mir helfen(Fehler gibt es nicht,der Launcher schließst sich,aber es kommt nicht das Minecraft-Fenster.

    mfg YellowPhoenix18
     
    #1
  2. maxi1498
    Offline

    maxi1498

    Registriert seit:
    19. Februar 2015
    Beiträge:
    145
    Ort:
    Bayern
    Minecraft:
    maxi1498
    Also dein Minecraft Launcher wird den Java Pfad nicht mehr richtig eingespeichert haben! Entweder du richtest den auf eigene Faust! Oder und wesentlich einfacher! Du löscht alles wirklich alles komplett den .minecraft Ordner und installierst den Launcher neu! Normalerweise klappt dann wieder alles!
     
    #2
  3. Angel
    Offline

    Angel Moderator Redakteur

    Registriert seit:
    2. März 2012
    Beiträge:
    1.442
    Ort:
    Niedersachsen
    Minecraft:
    BeatingAngel
    Den Java Pfad auf eigene Faust einzurichten ist wesentlich einfacher als eine komplette Neuinstallation :p Wenn es überhaupt der Java Pfad ist.

    Edit: Zumal Minecraft mittlerweile ne eigene Runtime nutzt.

    @Yellowphoenix18
    Starte das Spiel mal mit geöffneten Launcher und poste mal was für Errors kommen :p
     
    #3
  4. maxi1498
    Offline

    maxi1498

    Registriert seit:
    19. Februar 2015
    Beiträge:
    145
    Ort:
    Bayern
    Minecraft:
    maxi1498
    Hmm.. das mir neu, warum muss ich dann Java installieren um Minecraft zu spielen?
    Und was einfacher ist kommt darauf an wie schnell dein Internet ist ;D
     
    #4
  5. JTK222
    Online

    JTK222

    Registriert seit:
    5. September 2013
    Beiträge:
    665
    Ort:
    Planet Erde
    Minecraft:
    JTK222
    Die eigene Runtime gibts nur beim Installer nicht beim normalen Launcher
     
    #5
    maxi1498 gefällt das.
  6. Yellowphoenix18
    Offline

    Yellowphoenix18

    Registriert seit:
    26. März 2013
    Beiträge:
    267
    Ort:
    Niedersachsen
    Minecraft:
    YellowPhoenix18
    Nein,der ist eingerichtet, scheinbar liegt es an einer ArrayList,habe jetzt mal den launcher beim Game offen gelassen,hier einmal die ausgabe:
    [19:50:43] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [19:50:43] [main/INFO]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [19:50:43] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
    [19:50:43] [main/INFO]: Forge Mod Loader version 7.2.59.999 for Minecraft 1.7.2 loading
    [19:50:43] [main/INFO]: Java is Java HotSpot(TM) Client VM, version 1.8.0_40, running on Windows 7:x86:6.1, installed at C:\Program Files (x86)\Java\jre1.8.0_40
    [19:50:43] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [19:50:43] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [19:50:43] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [19:50:43] [main/ERROR]: Unable to launch
    java.util.ConcurrentModificationException
    at java.util.ArrayList$Itr.checkForComodification(Unknown Source) ~[?:1.8.0_40]
    at java.util.ArrayList$Itr.remove(Unknown Source) ~[?:1.8.0_40]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:117) [launchwrapper-1.9.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
    Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
     
    #6
  7. maxi1498
    Offline

    maxi1498

    Registriert seit:
    19. Februar 2015
    Beiträge:
    145
    Ort:
    Bayern
    Minecraft:
    maxi1498
    Hast du 2 Festplatten?
     
    #7
  8. Yellowphoenix18
    Offline

    Yellowphoenix18

    Registriert seit:
    26. März 2013
    Beiträge:
    267
    Ort:
    Niedersachsen
    Minecraft:
    YellowPhoenix18
    Ja,aber es wird nur die HDD für Daten derzeit genutzt. Es scheint wie gesagt aber an einer Array zu liegen, die bei Java8 nicht genutzt wird, war es nicht so,dass wenn ein Index in Java8 >= oder so abgefragt wird,dass es da Probleme gibt?
     
    #8
  9. maxi1498
    Offline

    maxi1498

    Registriert seit:
    19. Februar 2015
    Beiträge:
    145
    Ort:
    Bayern
    Minecraft:
    maxi1498
    Das Array hat nichts mit dem Problem zu tun wenn man etwas programmiert sortiert man alles in verschiedene "Ordner" und ArrayList ist nichts was Probleme macht das ist nur der Pfad!
     
    #9
  10. Yellowphoenix18
    Offline

    Yellowphoenix18

    Registriert seit:
    26. März 2013
    Beiträge:
    267
    Ort:
    Niedersachsen
    Minecraft:
    YellowPhoenix18
    Ist mir klar,aber es ist ja nur mit Forge(siehe Anfangsthread).Daher bin ich mir sicher,dass in dem Forge-Mod eine Array ist(siehe Fehlermeldung), die diesen fehler hervorruft.

    mfg YellowPhoenix18
     
    #10
  11. maxi1498
    Offline

    maxi1498

    Registriert seit:
    19. Februar 2015
    Beiträge:
    145
    Ort:
    Bayern
    Minecraft:
    maxi1498
    Hmm versuch folgendes!
    1. Erstelle einen Ordner zum kurz reinschieben!
    2. Schiebe einen Mod in den Ordner Starte MC neu
    3. Wenn ein Fehler kommt, schieße MC
    4. Lege den Mod wieder zurück
    5. Wiederhole Schritt 2. aber mit anderem Mod!
    6. Wiederhole Schritt 2. bis 4. bis sich MC normal startet!
    7. Wenn's es dann noch nicht geht, geh mal hier und lade dir die passende Version runter! Und installiere diese neu! ;D

    8. Wenn's dann noch nicht klappt weiß ich auch nicht mehr weiter ;D
     
    #11
  12. JTK222
    Online

    JTK222

    Registriert seit:
    5. September 2013
    Beiträge:
    665
    Ort:
    Planet Erde
    Minecraft:
    JTK222
    Mal ne frage waren alle Forge versionen unter 1.8 nicht mit Java 8 inkompatibel?
     
    #12
  13. Yellowphoenix18
    Offline

    Yellowphoenix18

    Registriert seit:
    26. März 2013
    Beiträge:
    267
    Ort:
    Niedersachsen
    Minecraft:
    YellowPhoenix18
    Mit den Mods habe ich alles getestet geht net ;(
     
    #13