Permissionsex, Permissions werden Rot angezeigt

Dieses Thema im Forum "Technischer Support" wurde erstellt von MBLIVE, 30. Januar 2015.

  1. MBLIVE
    Offline

    MBLIVE

    Registriert seit:
    25. Januar 2015
    Beiträge:
    64
    Hi Leute,
    derzeit arbeite ich an einem Rechtesystem, jedoch zeigt mir Notepad++
    manche Dinge rot an.
    Wisst ihr vielleicht was ich falsch gemacht habe ? Ausserdem wäre es sehr nett, wenn ihr vielleicht wisst, was für Farben es für die Gruppen alles gibt.
    Da ich die Zahlen der Farben leider nicht weis.
    Mit freundlichen Grüßen
    MB-LIVE
    bandicam 2015-01-30 16-33-21-671.jpg
     
    #1
  2. Angel
    Offline

    Angel Moderator Redakteur

    Registriert seit:
    2. März 2012
    Beiträge:
    1.442
    Ort:
    Niedersachsen
    Minecraft:
    BeatingAngel
    Entfern mal die Tabulatoren vor den perms und füg Leerzeichen ein [emoji14]
     
    #2
  3. [Dev] iTzSasukeHDxLP
    Offline

    [Dev] iTzSasukeHDxLP Ehem. Teammitglied

    Registriert seit:
    5. Januar 2014
    Beiträge:
    938
    Zwischen 'join' und die 'Arena<ID>' sollte ein Punkt gehören.
     
    #3
  4. MeeriSchatz
    Offline

    MeeriSchatz

    Registriert seit:
    10. Mai 2013
    Beiträge:
    42
    Minecraft:
    MeeriSchatz
    Das ist ganz einfach :)

    Die Tabs die du setzt machen das Ganze quasi kaputt. Wenn du auf die Optionen in Notepad gehst und dort einstellst, dass Tabs automatisch mit Leerzeichen ausgetauscht werden macht das keine Probleme mehr.

    Hier noch ein Bild, um zu zeigen wo sich die Einstellung befindet.
    [​IMG]
    Die bisherigen roten Einträge musst du dann quasi einmal die Tabs entfernen und durch Leerzeichen ersetzten.

    //Wurde zwar grade geschrieben aber denke der Tipp von oben wird dir helfen :)
     
    #4
    Angel gefällt das.
  5. Vinnie
    Offline

    Vinnie

    Registriert seit:
    28. Juni 2014
    Beiträge:
    264
    Minecraft:
    Vinnie
    Wollte das auch gerade schreiben haha xD

    Von wegen der Farben, ich gehe jetzt mal davon aus, dass du die Colorcodes wie &d etc meinst, Google einfach mal Minecraft colorcodes, stelle auf Bilder und du siehst viele tolle Tabellen, die dir die Codes farblich veranschaulichen. ^^
    (Wäre ich ned am Handy, würde ich hier so Nen Bild reinstellen)

    MfG

    Vinnie aka Dakvain
     
    #5
  6. MBLIVE
    Offline

    MBLIVE

    Registriert seit:
    25. Januar 2015
    Beiträge:
    64
    Vielen Dank für eure Hilfe, das Rote ist nun weg.
    Jedoch funktioniert es immer noch nicht, da Permissionsex bei mir, wenn ich /pl mache Rot angezeigt wird.
    Ich weis aber das es vorhin, als ich eine Vorlage genommen habe, funktionierte.
    Wisst ihr vielleicht ob es noch irgendein Fehler geben kann ?
    Mit freundlichen Grüßen
    bandicam 2015-01-30 19-28-32-189.jpg
     
    #6
  7. Endersocke
    Offline

    Endersocke

    ja - du hast überall "inheritans" geschrieben - das heißt aber inheritance
     
    #7
  8. MBLIVE
    Offline

    MBLIVE

    Registriert seit:
    25. Januar 2015
    Beiträge:
    64
    Leider funktioniert es immer noch nicht, kann es vielleicht an dem 1vs1 plugin wo ich rechte vergeben habe liegen ?
     

    Anhänge:

    #8
  9. MeeriSchatz
    Offline

    MeeriSchatz

    Registriert seit:
    10. Mai 2013
    Beiträge:
    42
    Minecraft:
    MeeriSchatz
    1. du hast @Sasuke's Post übersehen ;)
    2. Schick am besten mal ein Serverlog vom Start vielleicht sehen wir dann ein wenig besser was los ist :)
     
    #9
  10. SilberRegen
    Online

    SilberRegen

    Registriert seit:
    23. März 2012
    Beiträge:
    579
    Minecraft:
    SilberRegen
    Du hast bei der Gruppe Stammspieler ein # statt einem & vor den Farbcode gesetzt. Wenn es daran nicht liegt, schau mal ob Pex bei dir überhaupt richtig läuft. Also einmal mit keiner oder Standardconfig hochfahren. Schau dir auch deinen Serverlog mal an, da steht eigentlich immer drin, warum das Plugin deaktiviert wurde.
     
    #10
  11. MBLIVE
    Offline

    MBLIVE

    Registriert seit:
    25. Januar 2015
    Beiträge:
    64
    Edit:
    Vielen Dank euch allen für die Hilfe, mittlerweile habe ich es hinbekommen.
    Nun wollte ich euch noch Fragen ob ihr vielleicht wisst, wie ich spezielle lobbys nur für VIPs einstellen kann.
    Ich habe es zwar versucht, aber auch normale User können auf die Lobbys zugreifen.
    Hier habe ich meine Config, ich möchte speziell für das Plugin 1vs1 und Bedwars eine lobby nur für VIPs erstellen:
    bandicam 2015-01-31 08-30-44-876.jpg
     
    #11
  12. Angel
    Offline

    Angel Moderator Redakteur

    Registriert seit:
    2. März 2012
    Beiträge:
    1.442
    Ort:
    Niedersachsen
    Minecraft:
    BeatingAngel

    Die Punkte zwischen "join" und "arena" fehlen immer noch.

    [​IMG]
     
    #12
  13. MBLIVE
    Offline

    MBLIVE

    Registriert seit:
    25. Januar 2015
    Beiträge:
    64
    Habe ich nun gemacht, jedoch kann ich immernoch alle Arenas Joinen.
    Habe mich auch DeOpped und mich in die Gruppe eingetragen, es funktioniert dennoch nicht.
    bandicam 2015-01-31 10-14-52-099.jpg
     
    #13
  14. kikelkik
    Offline

    kikelkik

    Registriert seit:
    8. August 2012
    Beiträge:
    49
    Ort:
    Deutschland
    Minecraft:
    kikelkik
    Du hast "inheritans" immer noch nicht durch "inheritance" ersetzt.
    Prüfe danach mal, ob die anderen Permissions stimmen, also versuch, als User z.B. /list und /msg <name> <Nachricht> und danach als VIP nochmal /msg <Name> <Nachricht> zu machen.

    Da kamen aber auch garantiert Fehler im Log beim Laden von PEX. Wäre hilfreich, wenn du -falls es dann immer noch nicht funktioniert- die Fehlermeldungen von PEX anhängst.
     
    #14
  15. M_Johny
    Offline

    M_Johny

    Registriert seit:
    16. Februar 2014
    Beiträge:
    57
    Minecraft:
    M_Johny
    Ist es auch beabsichtigt, dass der VIP von einer Gruppe Gast erben soll?

    Ich denke mal der VIP soll vom User erben. Das müsstest du dann auch noch ändern
     
    #15
  16. MBLIVE
    Offline

    MBLIVE

    Registriert seit:
    25. Januar 2015
    Beiträge:
    64
    Vielen Dank für deine Hilfe, leider funktionieren auch dinge wie /msg als normaler User.
    Hier ist übrigens der Log (ich habe mal alle Fehler herausgesucht, damit ihr nicht so viel Arbeit habt) vielleicht weis ja jemand was die Fehler bedeuten:
    [08:12:15] [Server thread/WARN]: java.io.IOException: Couldn't get lock for plugins/Multiverse-SignPortals/debug.log
    [08:12:15] [Server thread/WARN]: at java.util.logging.FileHandler.openFiles(FileHandler.java:422)
    [08:12:15] [Server thread/WARN]: at java.util.logging.FileHandler.<init>(FileHandler.java:318)
    [08:12:15] [Server thread/WARN]: at com.onarandombox.MultiverseCore.utils.DebugLog.<init>(DebugLog.java:44)
    [08:12:15] [Server thread/WARN]: at com.onarandombox.MultiverseSignPortals.MultiverseSignPortals.onLoad(MultiverseSignPortals.java:84)
    [08:12:15] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_7_R3.CraftServer.loadPlugins(CraftServer.java:363)
    [08:12:15] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.DedicatedServer.init(DedicatedServer.java:135)
    [08:12:15] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.MinecraftServer.run(MinecraftServer.java:457)
    [08:12:15] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.ThreadServerApplication.run(SourceFile:628)

    [08:12:17] [Server thread/ERROR]: Error occurred while enabling iDisguise v3.1pre3 (Is it up to date?)
    java.lang.NoClassDefFoundError: net/minecraft/server/v1_7_R4/EntityHuman
    at de.robingrether.idisguise.iDisguise.onEnable(iDisguise.java:67) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:316) ~[1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:324) [1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at org.bukkit.craftbukkit.v1_7_R3.CraftServer.loadPlugin(CraftServer.java:465) [1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at org.bukkit.craftbukkit.v1_7_R3.CraftServer.enablePlugins(CraftServer.java:383) [1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at net.minecraft.server.v1_7_R3.MinecraftServer.n(MinecraftServer.java:359) [1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at net.minecraft.server.v1_7_R3.MinecraftServer.g(MinecraftServer.java:333) [1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at net.minecraft.server.v1_7_R3.MinecraftServer.a(MinecraftServer.java:289) [1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at net.minecraft.server.v1_7_R3.DedicatedServer.init(DedicatedServer.java:193) [1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at net.minecraft.server.v1_7_R3.MinecraftServer.run(MinecraftServer.java:457) [1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at net.minecraft.server.v1_7_R3.ThreadServerApplication.run(SourceFile:628) [1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_7_R4.EntityHuman
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:67) ~[1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62) ~[1.7.9-R0.3-Build1502.jar:git-Spigot-1502]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_25]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_25]
    ... 12 more

    [08:12:17] [Server thread/WARN]: [TagAPI] Inconsistency found: Potential mod detected. TagAPI may not run properly. Let's try it anyway!

    [08:12:18] [Server thread/WARN]: [Multiverse-Core] WorldManager: Can't load this world because the folder was deleted/moved: neuewelt_nether
    [08:12:18] [Server thread/WARN]: [Multiverse-Core] Use '/mv remove' to remove it from the config!

    [08:12:18] [Thread-8/WARN]: [PermissionsEx] An update to PermissionsEx version 1.23.1 is available to download from http://dev.bukkit.org/bukkit-plugins/permissionsex/. Please review the changes and update as soon as possible!

    [08:12:19] [Server thread/WARN]: [Multiverse-Core] WorldManager: Can't load this world because the folder was deleted/moved: neuewelt_the_end
    [08:12:19] [Server thread/WARN]: [Multiverse-Core] Use '/mv remove' to remove it from the config!

    [08:12:20] [Server thread/WARN]: java.lang.NullPointerException
    [08:12:20] [Server thread/WARN]: at me.BukkitPVP.bedwars.Main.loadExternalPlugins(Main.java:182)
    [08:12:20] [Server thread/WARN]: at me.BukkitPVP.bedwars.Main.onEnable(Main.java:54)
    [08:12:20] [Server thread/WARN]: at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:316)
    [08:12:20] [Server thread/WARN]: at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:324)
    [08:12:20] [Server thread/WARN]: at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405)
    [08:12:20] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_7_R3.CraftServer.loadPlugin(CraftServer.java:465)
    [08:12:20] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_7_R3.CraftServer.enablePlugins(CraftServer.java:383)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.MinecraftServer.n(MinecraftServer.java:359)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.MinecraftServer.g(MinecraftServer.java:333)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.MinecraftServer.a(MinecraftServer.java:289)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.DedicatedServer.init(DedicatedServer.java:193)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.MinecraftServer.run(MinecraftServer.java:457)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.ThreadServerApplication.run(SourceFile:628)
    [08:12:20] [Server thread/INFO]: [0;37;22m[[0;36;1mBedWars[0;37;22m] [0;36;22mLoaded game [0;32;1mbedwars[m
    [08:12:20] [Server thread/INFO]: [0;37;22m[[0;36;1mBedWars[0;37;22m] [0;36;22mLoaded game [0;32;1mbedwars2[m
    [08:12:20] [Server thread/INFO]: [Multiverse-SignPortals] Enabling Multiverse-SignPortals v2.4-b523
    [08:12:20] [Server thread/WARN]: java.io.IOException: Couldn't get lock for plugins/Multiverse-SignPortals/debug.log
    [08:12:20] [Server thread/WARN]: at java.util.logging.FileHandler.openFiles(FileHandler.java:422)
    [08:12:20] [Server thread/WARN]: at java.util.logging.FileHandler.<init>(FileHandler.java:318)
    [08:12:20] [Server thread/WARN]: at com.onarandombox.MultiverseCore.utils.DebugLog.<init>(DebugLog.java:44)
    [08:12:20] [Server thread/WARN]: at com.onarandombox.MultiverseSignPortals.MultiverseSignPortals.onEnable(MultiverseSignPortals.java:55)
    [08:12:20] [Server thread/WARN]: at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:316)
    [08:12:20] [Server thread/WARN]: at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:324)
    [08:12:20] [Server thread/WARN]: at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405)
    [08:12:20] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_7_R3.CraftServer.loadPlugin(CraftServer.java:465)
    [08:12:20] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_7_R3.CraftServer.enablePlugins(CraftServer.java:383)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.MinecraftServer.n(MinecraftServer.java:359)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.MinecraftServer.g(MinecraftServer.java:333)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.MinecraftServer.a(MinecraftServer.java:289)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.DedicatedServer.init(DedicatedServer.java:193)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.MinecraftServer.run(MinecraftServer.java:457)
    [08:12:20] [Server thread/WARN]: at net.minecraft.server.v1_7_R3.ThreadServerApplication.run(SourceFile:628)

    [08:13:20] [Thread-10/ERROR]: [BW] The updater could not contact dev.bukkit.org for updating.
    [08:13:20] [Thread-10/ERROR]: [BW] If you have not recently modified your configuration and this is the first time you are seeing this message, the site may be experiencing temporary downtime.
    [08:13:20] [Thread-10/ERROR]: [BW] null
    java.io.IOException: Server returned HTTP response code: 504 for URL: https://api.curseforge.com/servermods/files?projectIds=68003
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1838) ~[?:1.8.0_25]
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1439) ~[?:1.8.0_25]
    at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254) ~[?:1.8.0_25]
    at me.BukkitPVP.bedwars.Updater.read(Updater.java:547) [Bedwars.jar:?]
    at me.BukkitPVP.bedwars.Updater.access$1(Updater.java:535) [Bedwars.jar:?]
    at me.BukkitPVP.bedwars.Updater$UpdateRunnable.run(Updater.java:585) [Bedwars.jar:?]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_25]
     
    #16
  17. Heikosservertutorials
    Offline

    Heikosservertutorials

    Registriert seit:
    27. Januar 2015
    Beiträge:
    57
    Ort:
    Deutschland
    Minecraft:
    HST_Tutorials
    @MBLIVE Die meisten Plugins können nicht enabled werden, stelle sicher, dass sie auch auf deiner Version funktionieren. :) Bei deinem Problem mit den Permissions gibt es auch eine einfache Lösung. Du hast folgende Permissions-Node für das Msg-Recht gesetzt:
    [​IMG]
    Das zweite "Minus-Zeichen" vor dem essentials.msg muss weg, denn so wird ja die Permission verweigert. :)
    Ich hoffe ich konnte ein wenig helfen. ;)

    Mit lieben Grüßen

    Heiko l Heikosservertutorials
     
    #17