Pex Chatmanagar

Dieses Thema im Forum "Server Plugins" wurde erstellt von Vakarian, 5. März 2013.

  1. Vakarian
    Offline

    Vakarian

    Registriert seit:
    25. Juni 2012
    Beiträge:
    247
    Ort:
    Pegasus Galaxie
    Minecraft:
    Camaro2009
    hi

    kleines Problem
    ich hätte gerne mit dem ChetManagar von pex folgendes im Chat angezeigt(die klammer um der welt und um den PREFIX ist wichtig)
    [Welt][PREFIX]<Player> : Nachricht
    habe dann auch folgendes eingetragen
    Code (Text):
    1. enable: true
    2. message-format: [%world][%prefix]<%player%suffix> %message
    3. global-message-format: <%prefix%player%suffix> &e%message
    4. ranged-mode: false
    5. chat-range: 100.0
    6.  
    das geht aber nicht da zeigt das plugin fehler an

    dan habe ich das so gemacht

    Code (Text):
    1. enable: true
    2. message-format: <%world%prefix%player%suffix> %message
    3. global-message-format: <%prefix%player%suffix> &e%message
    4. ranged-mode: false
    5. chat-range: 100.0
    6.  
    dan sieht das so aus
    <welt[prefix]name>
    PS: Ich habe enable auf true gehabt geht immer noch nicht
    PS2: Ich möchte kein HeroChat, Essentials Chat oder sonst was
     
    #1
  2. Basti07711
    Offline

    Basti07711 Ehem. Teammitglied

    Registriert seit:
    2. August 2012
    Beiträge:
    714
    Ort:
    Hinter dir
    Minecraft:
    Basti07711
    Wenn ich du wäre, dann würde ich mal enable auf TRUE stellen.
     
    #2
  3. Vakarian
    Offline

    Vakarian

    Registriert seit:
    25. Juni 2012
    Beiträge:
    247
    Ort:
    Pegasus Galaxie
    Minecraft:
    Camaro2009
    ja stand es ja aber blos durch fehler im syntax hat er das wieder resettet steht auch im PS oben
     
    #3
  4. Basti07711
    Offline

    Basti07711 Ehem. Teammitglied

    Registriert seit:
    2. August 2012
    Beiträge:
    714
    Ort:
    Hinter dir
    Minecraft:
    Basti07711
    Hast du beim Gruppenpreifx [gruppe] eingegeben?
     
    #4
  5. games6471
    Offline

    games6471

    Könntest du vllt mal die Fehlermeldung mit in den Post rein schreiben?
     
    #5
  6. Vakarian
    Offline

    Vakarian

    Registriert seit:
    25. Juni 2012
    Beiträge:
    247
    Ort:
    Pegasus Galaxie
    Minecraft:
    Camaro2009
    ja habe mir gedacht das man das auch bei der welt machen kann aber dann haben die klammer der welt die selbe farbe wie die welt also [Welt] aber es soll so ausehen [Welt]



    Code (Text):
    1. 2013-03-05 16:20:10 [SEVERE] Cannot load plugins\ChatManager\config.yml
    2. org.bukkit.configuration.InvalidConfigurationException: while scanning for the next token
    3. found character %'%' that cannot start any token
    4.  in "<string>", line 2, column 17:
    5.     message-format: %[world]%[prefix]S<%player%suffi ...
    6.                     ^
    7.  
     
    #6
  7. Basti07711
    Offline

    Basti07711 Ehem. Teammitglied

    Registriert seit:
    2. August 2012
    Beiträge:
    714
    Ort:
    Hinter dir
    Minecraft:
    Basti07711
    Schreibe das dann so:
    &f[&3Welt&f]
     
    #7
  8. games6471
    Offline

    games6471

    Welt ist eine Variable und muss mit %% gekennzeichnet werden.
     
    #8
  9. Basti07711
    Offline

    Basti07711 Ehem. Teammitglied

    Registriert seit:
    2. August 2012
    Beiträge:
    714
    Ort:
    Hinter dir
    Minecraft:
    Basti07711
    Ich weiss, sollte ja nur ein Beispiel sein.
     
    #9
  10. Vakarian
    Offline

    Vakarian

    Registriert seit:
    25. Juni 2012
    Beiträge:
    247
    Ort:
    Pegasus Galaxie
    Minecraft:
    Camaro2009
    alos jetzt habe ich es so geschrieben geht nicht


    Code (Text):
    1. enable: true
    2. message-format: [%world%][%prefix%]<%prefix%player%> %message
    3. global-message-format: <%prefix%player%suffix> &e%message
    4. ranged-mode: false
    5. chat-range: 100.0
    6.  

    ich habe das mit &f[&1Welt&f] geschrieben einmal in multivers multiverso sagt nein geht nicht und im gruppenmanagar das selbe
     
    #10