1. Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

Pex verhält sich komisch bzw. buggt

Dieses Thema im Forum "Technischer Support" wurde erstellt von Crafter6432, 3. Oktober 2012.

Status des Themas:
Es sind keine weiteren Antworten möglich.

  1. Crafter6432
    Offline

    Crafter6432 Workaholic

    Registriert seit:
    22. Dezember 2011
    Beiträge:
    681
    Hi,
    ich habe seit neustem das Problem, das Pex nach dem nächtlichen restart die Konsole spammt und nicht Funktioniert.Und auf den Server kommt auch niemand, es kommt "Internal Server Error". Wenn ich den Server aber dann enmal aus/an mache klappt es wieder Problemlos, das yml von den Permissions hab ich schon gescheckt die is OK.Hat jmd. ne Idee wo der Fehler liegen könnte?
     
  2. Spongebob1399
    Offline

    Spongebob1399 Minecraft-Architekt

    Registriert seit:
    4. April 2012
    Beiträge:
    1.273
    Minecraft:
    Spongebob1399
    Schreib mal deinen Fehler-Log und deine Pex Datei bei Pastebin.com rein und gieb uns den Link :D
    Du weißt ja, "Geht nicht, hilft nicht" ;)


    Mfg Sponge
     
  3. Crafter6432
    Offline

    Crafter6432 Workaholic

    Registriert seit:
    22. Dezember 2011
    Beiträge:
    681
  4. Spongebob1399
    Offline

    Spongebob1399 Minecraft-Architekt

    Registriert seit:
    4. April 2012
    Beiträge:
    1.273
    Minecraft:
    Spongebob1399
    Du sollst de Auschnitte, wo PEX failt bei Pastebin.com reinschreiben -.-
    Ansonsten, schreib mal alle Permissions klein ;)


    Mfg Sponge
     
    Zuletzt bearbeitet: 3. Oktober 2012
  5. Crafter6432
    Offline

    Crafter6432 Workaholic

    Registriert seit:
    22. Dezember 2011
    Beiträge:
    681
    Code (Text):
    1. 2012-10-04 08:26:27 [SEVERE] Error loading permissions file initializing PermissionsEx v1.19.2 (Is it up to date?)java.lang.IllegalStateException: Error loading permissions file
    2.     at ru.tehkode.permissions.backends.FileBackend.reload(FileBackend.java:251)
    3.     at ru.tehkode.permissions.backends.FileBackend.initialize(FileBackend.java:79)
    4.     at ru.tehkode.permissions.PermissionManager.setBackend(PermissionManager.java:423)
    5.     at ru.tehkode.permissions.PermissionManager.initBackend(PermissionManager.java:485)
    6.     at ru.tehkode.permissions.PermissionManager.<init>(PermissionManager.java:52)
    7.     at ru.tehkode.permissions.bukkit.PermissionsEx.onLoad(PermissionsEx.java:69)
    8.     at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:228)
    9.     at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:199)
    10.     at net.minecraft.server.ServerConfigurationManagerAbstract.<init>(ServerConfigurationManagerAbstract.java:50)
    11.     at net.minecraft.server.ServerConfigurationManager.<init>(SourceFile:11)
    12.     at net.minecraft.server.DedicatedServer.init(DedicatedServer.java:105)
    13.     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:377)
    14.     at net.minecraft.server.ThreadServerApplication.run(SourceFile:539)
    15. Caused by: org.bukkit.configuration.InvalidConfigurationException: unacceptable character '?' (0xFFFD) special characters are not allowed
    16. in "<string>", position 83099
    17.     at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:55)
    18.     at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:138)
    19.     at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:105)
    20.     at ru.tehkode.permissions.backends.FileBackend.reload(FileBackend.java:247)
    21.     ... 12 more
    22. Caused by: unacceptable character '?' (0xFFFD) special characters are not allowed
    23. in "<string>", position 83099
    24.     at org.yaml.snakeyaml.reader.StreamReader.checkPrintable(StreamReader.java:70)
    25.     at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:50)
    26.     at org.yaml.snakeyaml.Yaml.load(Yaml.java:399)
    27.     at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:53)
    28.     ... 15 more
    Das es ist scheinbar doch ein YAML-Fehler, der der YAML-Praser nicht erkannt hat.

    EDIT: ein ä und ein ö waren schuld, die drüfen wohl troz UTF-8 nicht im Knotennamen vorkommen.
     
    Zuletzt bearbeitet: 4. Oktober 2012
Status des Themas:
Es sind keine weiteren Antworten möglich.