Plötzliche Fehler bei Plugins!

Dieses Thema im Forum "Server Plugins" wurde erstellt von fs626, 25. Juli 2012.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. fs626
    Offline

    fs626

    Registriert seit:
    24. Juli 2012
    Beiträge:
    193
    Ort:
    Deutschland
    Hallo,
    Ich habe ein Problem mit manchen plugin! Ich habe versucht z.B ein Muteplugin zu installieren dies kappt zwar auf meinem hamachi server (zum test) aber auf meinem anderen gehosteten Server erhalte ich immer diese meldung: (beide Server haben die identischen plugins drauf!)

    Code (Text):
    1. 22:22:44 [SCHWERWIEGEND] Could not load 'plugins/MuteAll.jar' in folder 'plugins'
    2.  
    3. org.bukkit.plugin.InvalidPluginException:
    4. java.lang.UnsupportedClassVersionError: eu/benni1000/muteall/MuteAll :
    5. Unsupported major.minor version 51.0
    6.  
    7. at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:151)
    8.  
    9. at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:305)
    10.  
    11. at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:230)
    12.  
    13. at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:214)
    14.  
    15. at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:190)
    16.  
    17. at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:55)
    18.  
    19. at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:158)
    20.  
    21. at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:424)
    22.  
    23. at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    24.  
    25. Caused by: java.lang.UnsupportedClassVersionError: eu/benni1000/muteall/MuteAll : Unsupported major.minor version 51.0
    26.  
    27. at java.lang.ClassLoader.defineClass1(Native Method)
    28.  
    29. at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
    30.  
    31. at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    32.  
    33. at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
    34.  
    35. at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
    36.  
    37. at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
    38.  
    39. at java.security.AccessController.doPrivileged(Native Method)
    40.  
    41. at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    42.  
    43. at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
    44.  
    45. at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    46.  
    47. at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    48.  
    49. at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    50.  
    51. at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:334)
    52.  
    53. at java.lang.Class.forName0(Native Method)
    54.  
    55. at java.lang.Class.forName(Class.java:264)
    56.  
    57. at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:140)
    58.  
    59. ... 8 more
    60.  
    An was kann das liegen?
    MfG fs
     
    #1
  2. Smuil
    Online

    Smuil

    Falsche Java-version denke ich:

    Erkennst du an:

    Unsupported major.minor version 51.0

    Soweit ich denke, wurde das Plugin wahrscheinlich in Java 7 developed, aber du hast auf deinem Server nur Java 6. Zuhause auf deinem Rechner hast du dann wahrscheinlich auch java 7.
     
    #2
  3. Benni1000
    Offline

    Benni1000 Ehem. Teammitglied

    Registriert seit:
    4. Mai 2012
    Beiträge:
    1.408
    Ich hab nur java7, er kann es sich sparen mich anzuschreiben :p.
     
    #3
  4. fs626
    Offline

    fs626

    Registriert seit:
    24. Juli 2012
    Beiträge:
    193
    Ort:
    Deutschland
    Ja aber warum geht es dann auf meinem Hamachi test server einwandfrei? Und ich habe 3 Global mute Plugins getestet die alle auf meinem Hamachi test server gehen aber nur nicht auf meinem eigendlichen! :cursing: :cursing:
     
    #4
  5. Smuil
    Online

    Smuil

    Ich glaube manche Leute wollen einfach nicht lesen.... Das habe ich im ersten Post schon gesagt...
     
    #5
  6. fs626
    Offline

    fs626

    Registriert seit:
    24. Juli 2012
    Beiträge:
    193
    Ort:
    Deutschland
    Ich bin bei Rock-Server was kann ich jetzt machen ?
     
    #6
  7. Smuil
    Online

    Smuil

    Support anschreiben und fragen ob sie Java 7 installieren?
     
    #7
  8. fs626
    Offline

    fs626

    Registriert seit:
    24. Juli 2012
    Beiträge:
    193
    Ort:
    Deutschland
    Das ist die Antwort: "Sie können Java leider nicht von 6 auf 7 updaten.
    Zum einen gibt es
    nicht für jeden einzelnen Minecraftserver auf unseren Rootservern Java,
    sondern Java ist global für alle Minecraftserver auf einem RootServer
    vorhanden.
    Desweiteren haben wir ein Kernel, das speziell auf Minecraft angepasst wurde.
    Ein einfaches Update geht daher schon einmal nicht.
    Gibt
    es denn zu dem Plugin keine Alternativen, welche auch unter JAVA 6
    laufen oder noch besser, gibt es eine JAVA 6 Version des Plugins?"
     
    #8
  9. KevKillerx333
    Offline

    KevKillerx333

    Registriert seit:
    17. Mai 2012
    Beiträge:
    189
    wenns nicht anders geht such dir nen neuen hoster ^^
     
    #9
  10. Smuil
    Online

    Smuil

    Ich guck mal, wenn Benni mir es erlaubt, ob ich es in Java6 mit den Sourcecode kompilen kann....
     
    #10
  11. Benni1000
    Offline

    Benni1000 Ehem. Teammitglied

    Registriert seit:
    4. Mai 2012
    Beiträge:
    1.408
    Na klar darfst du das, ist ja opensource.
     
    #11
  12. Es ist gleichzeitig aber total unnötig Bukkit Plugins auf Java 7 oder 6 zu builden. (Wobei ich auch standartmäßig Java 6 benutze)
    Bukkit selber läuft auch auf Java 5 und alle Plugins können auch auf Java 5 gebuildet werden.

    Warum man dafür den Hoster wechseln muss ist mir fragwürdig.
     
    #12
  13. Smuil
    Online

    Smuil

    Weil nicht jeder auf Java 5 builded. Mit jeder Javaversion kommen neue features etc dazu. Also welches Java wird man wohl benutzen?

    Desweiteren kann ich es auch nicht in java 6 compilen...besitze auch nur noch java7
     
    #13
  14. Benni1000
    Offline

    Benni1000 Ehem. Teammitglied

    Registriert seit:
    4. Mai 2012
    Beiträge:
    1.408
    Ich besitze nur noch Java7, warum sollte ich mir java6 installieren?
    Die leute sollten früher oder später sowieso alle umsteigen, ich mein Java 7 ist ja jetzt nicht wirklich ganz neu.
     
    #14
  15. TheTechno23
    Offline

    TheTechno23

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    2
    Suche Mute Plugin
     
    #15
  16. Smuil
    Online

    Smuil

    am besten schaust du selbst mal bei dev.bukkit.org nach mute oder globalmute.

    Außerdem wäre es wünschenswert, wenn du deine Höflichkeit verbesserst. "Suche MutePlugin" ist noch nicht mal ein deutscher Satz. Etwas höflicheres wie: "Könntet ihr mir ein Link zu einen Muteplugin geben"
    wäre angemessener.
     
    #16
Status des Themas:
Es sind keine weiteren Antworten möglich.