• Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

Plotsqared will nicht mehr

Minecraft Version
Java

KaktusEsser

Minecrafter
Registriert
1 September 2021
Beiträge
10
Diamanten
50
Hey ich habe schon seit geraumer zeit einen CB server mit plotsqared usw doch neuerdings reagiert plotsqared auf KEINEN befehl mehr zb /p claim
fals ihr mir helfen köntet währe schön

server bei MGServers
 

SirYwell

PlotSquared Entwickler
Registriert
30 Juni 2017
Beiträge
536
Diamanten
336
Minecraft
SirYwell
Hallo KaktusEsser,

in solchen Fällen geben die Logs Aufschluss über die Situation. Probleme, die "neuerdings" auftreten, werden außerdem meist durch Änderungen am System ausgelöst. Dementsprechend wären auch zuletzt vorgenommene Maßnahmen dieser Art erwähnenswert.
 

KaktusEsser

Minecrafter
Registriert
1 September 2021
Beiträge
10
Diamanten
50

Taracraft

Minecrafter
Registriert
1 Januar 2021
Beiträge
27
Alter
39
Diamanten
69
Minecraft
Taracraft
Java 16 ist die aktuelle mittlerweile, einfach Suchen von Oracle. Zum Downloaden ist mittlerweile aber ein Account erforderlich. Der aber schnell erstellt ist.
Post automatically merged:

Damit du Plotsquared selber Compilieren kannst, kannst du wie folgt vorgehen:
Mit Git das Repository von https://github.com/IntellectualSites/PlotSquared Clonen.
Gradley Downloaden https://gradle.org/releases/
Gradle is the recommended way to build the project. Use ./gradlew build in the main project directory to build the project. Gradle is required if you intend to build or develop the Sponge module.
und damit dann Neu Compilieren, allerdings wenn die die Begriffe nicht geläufig sind solltest du dir von jemand helfen lassen.
 
Zuletzt bearbeitet:

KaktusEsser

Minecrafter
Registriert
1 September 2021
Beiträge
10
Diamanten
50
Java 16 ist die aktuelle mittlerweile, einfach Suchen von Oracle. Zum Downloaden ist mittlerweile aber ein Account erforderlich. Der aber schnell erstellt ist.
Post automatically merged:

Damit du Plotsquared selber Compilieren kannst, kannst du wie folgt vorgehen:
Mit Git das Repository von https://github.com/IntellectualSites/PlotSquared Clonen.
Gradley Downloaden https://gradle.org/releases/

und damit dann Neu Compilieren, allerdings wenn die die Begriffe nicht geläufig sind solltest du dir von jemand helfen lassen.
sagt mir nicht aber sol ich da einfach googlen oder wie
 

JOO200

Braumeister
Registriert
18 Dezember 2016
Beiträge
422
Diamanten
191
Java 16 ist die aktuelle mittlerweile, einfach Suchen von Oracle. Zum Downloaden ist mittlerweile aber ein Account erforderlich. Der aber schnell erstellt ist.
Schlechte Idee, da die Lizenzen von Oracle sehr strikt sind und gerade die kommerzielle Nutzung (= Server mit Shop) ohne Lizenzgebühren nicht erlaubt ist.
In diesem Fall ist die Nutzung von öffentlichen JDKs wie openjdk (z.B. https://adoptopenjdk.net/ ) die deutlich bessere Variante. Wäre nämlich nicht ganz so cool, wenn du eines Tages von Oracle Post bekommst, dass du für deinen Minecraft-Server Geld für Java bezahlen solltest.
 

Taracraft

Minecrafter
Registriert
1 Januar 2021
Beiträge
27
Alter
39
Diamanten
69
Minecraft
Taracraft
Da geb ich dir Recht allerdings kann es passieren das fehlende Classes in openjdk drin sind. Man muss schauen das wenn man einen Echtgeld shop hat auch eine Java Lizenz hat.
Post automatically merged:

sagt mir nicht aber sol ich da einfach googlen oder wie
Du hast 2 möglichkeiten. Zurück zur alten Version gehen dann sollte es ja wieder alles Laufen(Hoffentlich hast du Backups). Falls du die Neue Version haben willst kannst du das Plugin entweder kaufen oder selber Compilieren wie ich beschrieben hab.
Wie mein Vorredner gesagt hat solltest du nur Oracle Java benutzen wenn es Privat genutzt wird, das heißt ohne Echtgeldshop wo man auch ein Gewerbeschein für braucht. Sonst openjdk verwenden.
 
Zuletzt bearbeitet:

JOO200

Braumeister
Registriert
18 Dezember 2016
Beiträge
422
Diamanten
191
Mir ist in Jahren der Minecraft Entwicklung, der Administration verschiedener Server (Bukkit, Spigot, Forge) und dem Support von einigen OpenSource Plugins es noch nie passiert, dass für den Betrieb eines Servers bei openjdk zu wenig Klassen vorhanden waren.

Daher ist es grundsätzlich auch nicht problematisch, openjdk auch für private Server zu benutzen. Daher bitte nicht weiter Falschinformationen verteilen, Oracle Java hat im Betrieb keine nennenswerten Vorteile.
 

KaktusEsser

Minecrafter
Registriert
1 September 2021
Beiträge
10
Diamanten
50
Mir ist in Jahren der Minecraft Entwicklung, der Administration verschiedener Server (Bukkit, Spigot, Forge) und dem Support von einigen OpenSource Plugins es noch nie passiert, dass für den Betrieb eines Servers bei openjdk zu wenig Klassen vorhanden waren.

Daher ist es grundsätzlich auch nicht problematisch, openjdk auch für private Server zu benutzen. Daher bitte nicht weiter Falschinformationen verteilen, Oracle Java hat im Betrieb keine nennenswerten Vorteile.
meinst du mich oder wen
?
Post automatically merged:

Mir ist in Jahren der Minecraft Entwicklung, der Administration verschiedener Server (Bukkit, Spigot, Forge) und dem Support von einigen OpenSource Plugins es noch nie passiert, dass für den Betrieb eines Servers bei openjdk zu wenig Klassen vorhanden waren.

Daher ist es grundsätzlich auch nicht problematisch, openjdk auch für private Server zu benutzen. Daher bitte nicht weiter Falschinformationen verteilen, Oracle Java hat im Betrieb keine nennenswerten Vorteile.
und was soll ich deiner meinung nach machen?
Post automatically merged:

Da geb ich dir Recht allerdings kann es passieren das fehlende Classes in openjdk drin sind. Man muss schauen das wenn man einen Echtgeld shop hat auch eine Java Lizenz hat.
Post automatically merged:


Du hast 2 möglichkeiten. Zurück zur alten Version gehen dann sollte es ja wieder alles Laufen(Hoffentlich hast du Backups). Falls du die Neue Version haben willst kannst du das Plugin entweder kaufen oder selber Compilieren wie ich beschrieben hab.
Wie mein Vorredner gesagt hat solltest du nur Oracle Java benutzen wenn es Privat genutzt wird, das heißt ohne Echtgeldshop wo man auch ein Gewerbeschein für braucht. Sonst openjdk verwenden.
Mein server besitzt keinen echtgeld shop das heisst einfach oracle java 14 auf den pc oder auf den server instalieren?
 
Zuletzt bearbeitet:

Taracraft

Minecrafter
Registriert
1 Januar 2021
Beiträge
27
Alter
39
Diamanten
69
Minecraft
Taracraft
meinst du mich oder wen
?
Post automatically merged:


und was soll ich deiner meinung nach machen?
Post automatically merged:


Mein server besitzt keinen echtgeld shop das heisst einfach oracle java 14 auf den pc oder auf den server instalieren?
zum 1. Nein mich aber mach dir da keinen Kopf drüber.
zum 2. das musst du selber entscheiden, es wäre nartürlich einfacher es zu kaufen wenn du keine ahnung hast wie man das Compiliert oder dich daran schwer tust.
zum 3. Wenn es außschlielich Privat betrieben wird würde ich zu Orace Java Version 16 tendieren.
DU kannst mich auch gerne im Voice kontaktieren wenn ich da bin :
 
Zuletzt bearbeitet von einem Moderator:
Oben