• Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

PlotSqured funtionirt nicht!

Minecraft Version
Java

Max [Server_Owner]

Minecrafter
Registriert
2 September 2022
Beiträge
18
Diamanten
103
Hallo,
ich habe PlotSquared (v4: v6) zusammen mit WorldEdit auf meinem Spigot 1.18.2 Server installiert.
Wenn ich jetzt aber /p setup oder /plot setup eingebe passirt: NICHTS.
Wenn ich /pl eingebe ist PlotSquard Grün, und wenn ich /help PlotSquard eingebe steht da:

------------------- help: PlotSquard ---------------------
below is a list of all PlotSquard commands:
/plots: Plot command.

Ich bin auf diesem Server op und habe alle rechte.
Wenn jemand eine Lösung für das Problem hat schreibt mir bitte.

Danke im voraus
-Max
 

Max [Server_Owner]

Minecrafter
Registriert
2 September 2022
Beiträge
18
Diamanten
103
Ok mache ich, allerdings sind die Logs SEHR voll dah ich insgesamt 27Plugins installirt habe, ich schike sie, klein moment

So hier die Logs:
-------------------------------------------------------------------------------------------------------------------------
Code:
Error, this build is outdated
Please download a new build as per instructions from httpswww.spigotmc.orggooutdated-spigot
Server will start in 20 seconds
Loading libraries, please wait...
[110347] [ServerMainINFO] Environment authHost='httpsauthserver.mojang.com', accountsHost='httpsapi.mojang.com', sessionHost='httpssessionserver.mojang.com', servicesHost='httpsapi.minecraftservices.com', name='PROD'
[110352] [Worker-Main-20INFO] Loaded 7 recipes
[110347] [ServerMainINFO] Environment authHost='httpsauthserver.mojang.com', accountsHost='httpsapi.mojang.com', sessionHost='httpssessionserver.mojang.com', servicesHost='httpsapi.minecraftservices.com', name='PROD'
[110352] [Worker-Main-20INFO] Loaded 7 recipes
[110355] [Server threadINFO] Starting minecraft server version 1.18.2
[110355] [Server threadINFO] Loading properties
[110356] [Server threadINFO] This server is running CraftBukkit version 3484-Spigot-b6d12d1-7bc728a (MC 1.18.2) (Implementing API version 1.18.2-R0.1-SNAPSHOT)
[110356] [Server threadINFO] Debug logging is disabled
[110356] [Server threadINFO] Server Ping Player Sample Count 12
[110356] [Server threadINFO] Using 4 threads for Netty based IO
[110356] [Server threadINFO] Default game type ADVENTURE
[110356] [Server threadINFO] Generating keypair
[110356] [Server threadINFO] Starting Minecraft server on 176.57.148.12525565
[110357] [Server threadINFO] Using epoll channel type
[110357] [Server threadERROR] Could not load 'pluginsBuildTools.jar' in folder 'plugins'
org.bukkit.plugin.InvalidDescriptionException Invalid plugin.yml
at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java170) ~[spigot-api-1.18.2-R0.1-SNAPSHOT.jar]
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java144) ~[spigot-api-1.18.2-R0.1-SNAPSHOT.jar]
at org.bukkit.craftbukkit.v1_18_R2.CraftServer.loadPlugins(CraftServer.java407) ~[spigot-1.18.2-R0.1-SNAPSHOT.jar3484-Spigot-b6d12d1-7bc728a]
at net.minecraft.server.dedicated.DedicatedServer.e(DedicatedServer.java232) ~[spigot-1.18.2-R0.1-SNAPSHOT.jar3484-Spigot-b6d12d1-7bc728a]
at net.minecraft.server.MinecraftServer.w(MinecraftServer.java1007) ~[spigot-1.18.2-R0.1-SNAPSHOT.jar3484-Spigot-b6d12d1-7bc728a]
at net.minecraft.server.MinecraftServer.lambda$0(MinecraftServer.java304) ~[spigot-1.18.2-R0.1-SNAPSHOT.jar3484-Spigot-b6d12d1-7bc728a]
at java.lang.Thread.run(Thread.java833) []
Caused by java.io.FileNotFoundException Jar does not contain plugin.yml
... 7 more
[110358] [Server threadWARN] Initializing Legacy Material Support. Unless you have legacy plugins andor data this is a bug!
[110406] [Server threadWARN] Legacy plugin Invsee v1.0 does not specify an api-version.
[110406] [Server threadWARN] Legacy plugin LinkArmy-Gamemode v1.0 does not specify an api-version.
[110406] [Server threadWARN] Legacy plugin FreeBuild v2.2 does not specify an api-version.
[110407] [Server threadINFO] [NickAPI] Loading NickAPI v6.4.1
[110407] [Server threadINFO] [WorldEdit] Loading WorldEdit v7.2.12+6240-87f4ae1
[110409] [Server threadINFO] Got request to register class com.sk89q.worldedit.bukkit.BukkitServerInterface with WorldEdit [com.sk89q.worldedit.extension.platform.PlatformManager@67b723bf]
[110409] [Server threadINFO] [AdvancedBan] Loading AdvancedBan v2.3.0
[110409] [Server threadINFO] [Invsee] Loading Invsee v1.0
[110409] [Server threadINFO] [LinkArmy-Gamemode] Loading LinkArmy-Gamemode v1.0
[110409] [Server threadINFO] [FreeBuild] Loading FreeBuild v2.2
[110409] [Server threadINFO] [PowerRanks] Loading PowerRanks v1.10.5R2
[110409] [Server threadINFO] [PlotSquared] Loading PlotSquared v4.4.495
rate limit exceeded
[110409] [Server threadINFO] [WorldEdit] Enabling WorldEdit v7.2.12+6240-87f4ae1
[110412] [Server threadINFO] [WorldEdit] ====================================================
[110412] [Server threadINFO] [WorldEdit] WorldEdit works better if you use Paper
[110412] [Server threadINFO] [WorldEdit] as your server software.
[110412] [Server threadINFO] [PowerRanks] Enabling PowerRanks v1.10.5R2
[110413] [Server threadINFO] [PlotSquared] Enabling PlotSquared v4.4.495
[110413] [Server threadINFO] -------- World Settings For [world_the_end] --------
rate limit exceeded
[110414] [Worker-Main-21INFO] Preparing spawn area 0%
[110415] [Worker-Main-29INFO] Preparing spawn area 2%
[110416] [Server threadINFO] Time elapsed 2540 ms
[110417] [Worker-Main-16INFO] Preparing spawn area 6%
[110417] [Server threadINFO] Time elapsed 1457 ms
[110422] [Server threadWARN] [FreeBuild] Loaded class me.leoko.advancedban.shaded.org.hsqldb.jdbc.JDBCDriver from AdvancedBan v2.3.0 which is not a depend or softdepend of this plugin.
[110422] [Server threadINFO] [MySQL] Die Verbindung zur MySQL ist fehlgeschlagen! Fehler Could not create connection to database server. Attempted reconnect 3 times. Giving up.
[110422] [Server threadERROR] Error occurred while enabling FreeBuild v2.2 (Is it up to date)
java.lang.NullPointerException Cannot invoke java.sql.Connection.createStatement() because this.con is null
at de.Cypix.FreeBuild.API.MySQL.update(MySQL.java49) ~[]
at de.Cypix.FreeBuild.Main.main.ConnectMySQL(main.java125) ~[]
at de.Cypix.FreeBuild.Main.main.onEnable(main.java91) ~[]
at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java264) ~[spigot-api-1.18.2-R0.1-SNAPSHOT.jar]
at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java342) ~[spigot-api-1.18.2-R0.1-SNAPSHOT.jar]
at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java480) ~[spigot-api-1.18.2-R0.1-SNAPSHOT.jar]
at org.bukkit.craftbukkit.v1_18_R2.CraftServer.enablePlugin(CraftServer.java518) ~[spigot-1.18.2-R0.1-SNAPSHOT.jar3484-Spigot-b6d12d1-7bc728a]
at org.bukkit.craftbukkit.v1_18_R2.CraftServer.enablePlugins(CraftServer.java432) ~[spigot-1.18.2-R0.1-SNAPSHOT.jar3484-Spigot-b6d12d1-7bc728a]
at net.minecraft.server.MinecraftServer.loadWorld0(MinecraftServer.java612) ~[spigot-1.18.2-R0.1-SNAPSHOT.jar3484-Spigot-b6d12d1-7bc728a]
at net.minecraft.server.MinecraftServer.loadLevel(MinecraftServer.java414) ~[spigot-1.18.2-R0.1-SNAPSHOT.jar3484-Spigot-b6d12d1-7bc728a]
at net.minecraft.server.dedicated.DedicatedServer.e(DedicatedServer.java263) ~[spigot-1.18.2-R0.1-SNAPSHOT.jar3484-Spigot-b6d12d1-7bc728a]
at net.minecraft.server.MinecraftServer.w(MinecraftServer.java1007) ~[spigot-1.18.2-R0.1-SNAPSHOT.jar3484-Spigot-b6d12d1-7bc728a]
at net.minecraft.server.MinecraftServer.lambda$0(MinecraftServer.java304) ~[spigot-1.18.2-R0.1-SNAPSHOT.jar3484-Spigot-b6d12d1-7bc728a]
at java.lang.Thread.run(Thread.java833) []
[110422] [Server threadINFO] [ServersNPC] Enabling ServersNPC v3.9
rate limit exceeded
[110422] [Server threadINFO] -------- World Settings For [CB_Test] --------
[110423] [Worker-Main-29INFO] Preparing spawn area 0%
[110424] [Worker-Main-27INFO] Preparing spawn area 5%
[110425] [Server threadINFO] Time elapsed 2504 ms
[110426] [Worker-Main-16INFO] Preparing spawn area 8%
[110426] [Worker-Main-29INFO] Preparing spawn area 85%
[110427] [Worker-Main-27INFO] Preparing spawn area 0%
rate limit exceeded
[110428] [Worker-Main-29INFO] Preparing spawn area 73%
[110429] [Worker-Main-28INFO] Preparing spawn area 0%
[110429] [Worker-Main-28INFO] Preparing spawn area 0%
[110430] [Worker-Main-18INFO] Preparing spawn area 28%
[110431] [Server threadINFO] Entity Activation Range An 32  Mo 32  Ra 48  Mi 16  Tiv true  Isa false
[110432] [Worker-Main-16INFO] Preparing spawn area 0%
[110432] [Worker-Main-28INFO] Preparing spawn area 0%
[110432] [Worker-Main-23INFO] Preparing spawn area 0%
rate limit exceeded
[110433] [Worker-Main-21INFO] Preparing spawn area 10%
[110433] [Worker-Main-21INFO] Preparing spawn area 35%
[110435] [Worker-Main-21INFO] Preparing spawn area 0%
[110435] [Worker-Main-22INFO] Preparing spawn area 1%
[110436] [Worker-Main-27INFO] Preparing spawn area 99%
[110437] [Server threadWARN] handleDisconnection() called twice
 
Zuletzt bearbeitet von einem Moderator:

SirYwell

PlotSquared Entwickler
Registriert
30 Juni 2017
Beiträge
540
Diamanten
438
Minecraft
SirYwell
Für Minecraft 1.18.2 solltest du PlotSquared v6 nutzen. Außerdem würde ich dir raten, Paper statt Spigot zu nutzen.
Weshalb PlotSquared in deinem Fall nicht funktioniert geht aber aus den Logs nicht hervor, die sind aber auch definitiv unvollständig.
 
Oben