• Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

Spigot PlugIn Plugin already initialized!

Onyxzium

Minecrafter
Mitglied seit
26 September 2018
Beiträge
17
Minecraft
Onyxzium
#1
Code:
[19:31:24] [Server thread/ERROR]: Could not load 'plugins/[Hyc] LuckCoins.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.IllegalArgumentException: Plugin already initialized!
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_191]
Caused by: java.lang.IllegalArgumentException: Plugin already initialized!
    at org.bukkit.plugin.java.PluginClassLoader.initialize(PluginClassLoader.java:122) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:66) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at me.onyxzium.spigot.Main.<init>(Main.java:9) ~[?:?]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_191]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:1.8.0_191]
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:1.8.0_191]
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_191]
    at java.lang.Class.newInstance(Class.java:442) ~[?:1.8.0_191]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:76) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    ... 6 more
Caused by: java.lang.IllegalStateException: Initial initialization
    at org.bukkit.plugin.java.PluginClassLoader.initialize(PluginClassLoader.java:125) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:66) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at me.onyxzium.spigot.Main.<init>(Main.java:9) ~[?:?]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_191]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:1.8.0_191]
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:1.8.0_191]
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_191]
    at java.lang.Class.newInstance(Class.java:442) ~[?:1.8.0_191]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:76) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    ... 6 more
 
Zuletzt bearbeitet von einem Moderator:
Mitglied seit
30 Juni 2017
Beiträge
165
Bewertungen
177
Alter
19
Minecraft
SirYwell
#2
Hast du zufällig bereits ein anderes Plugin, das eine Main-Klasse im gleichen Package hat? Generell ist es sinnvoll, die Main-Klasse nicht Main zu nennen, sondern etwas aussagekräftiger
 

Onyxzium

Minecrafter
Mitglied seit
26 September 2018
Beiträge
17
Minecraft
Onyxzium
#3
Naja meine plugins sind generell unter me.onyxzium.[spigot oder bungee].[Main Klasse] abgespeichert
 
Mitglied seit
30 Juni 2017
Beiträge
165
Bewertungen
177
Alter
19
Minecraft
SirYwell
#4
Da liegt das Problem. Du kannst in Java eben nicht mehrere Klassen mit gleichem Package- und Klassenname haben. Also entweder du passt das Benennungsschema so um, dass das Package sich unterscheidet, oder du gibst deinen Klassen unterschiedliche Namen.
 
Mitglied seit
1 Juli 2012
Beiträge
749
Bewertungen
253
Minecraft
BlackHole
#5
Es sollten sich auch keine anderen Klassen zwischen den Plugins überschneiden. Spigot wird jede Klasse mit einem eindeutigen Namen nur einmal laden.
 
Allgemein
Help Benutzer
  • SirYwell SirYwell:
    ok cool
  • MiningVillains MiningVillains:
    mein Suche post ist auch im Suchebereich drinn
  • SirYwell SirYwell:
    Hervorragend
  • maybeto maybeto:
    Leute, der Mann is gut, nehmt euch ein Beispiel an ihm....
  • SirYwell SirYwell:
    So Kinder, auf zur Demo
    +3
  • maybeto maybeto:
    wie wohl @SirYwell s Teilnahme an der Demo endet? Wird er nun den Rest seines Lebens bei Wasser und Brot in ner Zelle dahinvegetieren? Vielleicht ertrinkt er auch beim Einsatz eines Wasserwerfers oder sammelt mit seinem Hintern unzählige Gummigeschosse ein.... Oder noch schlimmer, die Demo endet für ihn mit Burgern in Haddes Laden :eek: Wie mutig er sich doch dafür einsetzt, das wir weiterhin Spaß im Internet haben können...
  • Matthias Matthias:
    hab gelesen in berlin sind es über 10.000. das schon krass
  • maybeto maybeto:
    ich finde es toll, das in Deutschland endlich mal wieder eine Generation heranwächst, die öffentlich ihre Meinung vertritt. Auch Fridays for future finde ich toll. Unsere Politik wird umdenken müssen, vorbei die Zeiten, in der die Bürger nur in ihren eigenen vier Wänden gemosert haben, öffentlich aber den Mund gehalten und zugeschaut haben
  • ❤️可愛いちゃん️❤️ ❤️可愛いちゃん️❤️:
    Sind doch alle nicht wahlberechtigt, also interessiert niemanden ¯\_(ツ)_/¯
    +1
  • Daniel Daniel:
    Absolut richtig. Und wenn sie wählen dürfen, haben sich die meisten bereits in die Abgeordneten-Rente verabschiedet
  • maybeto maybeto:
    mag ja sein, aber auf jeden Fall wird sich in Zukunft einiges ändern. Die Gegenwart haben wir verbockt, es war mal unsere Zukunft.....
  • Matthias Matthias:
    Solmeckes Umfrage zeigt da aber ein anderes Ergebnis:
    +3
  • iTz_Proph3t iTz_Proph3t:
    Ich weiß schonmal, dass ich sicher NICHT die CDU wählen werde
  • maybeto maybeto:
    ich denke mal, das es an der Zeit ist, das sich alle Parteien in gewisser Weise erneuern müssen, wollen sie künftig erfolgreich sein
  • ❤️可愛いちゃん️❤️ ❤️可愛いちゃん️❤️:
    Was willste denn Wählen? SPD, Grüne, AfD, FDP? Sind alle für die Urheberrechtsreform.
  • Panossa Panossa:
    Die PARTEI, denn sie ist sehr gut. SPD spricht sich wohl jetzt auch immer mehr gegen die aus.
    (Piratenpartei ist auch dagegen, iirc)
  • ❤️可愛いちゃん️❤️ ❤️可愛いちゃん️❤️:
    SPD hat das ganze mitgetragen. Bitte nicht öffentliche Erklärungen mit dem verwechseln, was die Parteien wirklich machen
  • KillawOrCarel KillawOrCarel:
    Politiker können lügen? Ich bitte dich
  • Lukas DST Lukas DST:
    Die CDU ist jetzt ja sogar zurückgerudert und hat gesagt "mit uns gibt's keine Uploadfilter" ... nur konnten sie auch nicht sagen, wie man es anders lösen kann und zweitens ... wann halten die schon mal ein was sie "sagen".
  • Matthias Matthias:
    Guten Morgen
  • LottaXL LottaXL:
    Moin, moin =)
  • maybeto maybeto:
    guten Morgen
  • Stern☆ Stern☆:
    morgen :)
  • Bella Bella:
    Hallihallo
  • nero_2411 nero_2411:
    Moin :)
    nero_2411 nero_2411: Moin :)
    Oben