Plugin-Ersatz für 1.8

Dieses Thema im Forum "Technischer Support" wurde erstellt von Yellowphoenix18, 29. Oktober 2014.

  1. Yellowphoenix18
    Offline

    Yellowphoenix18

    Registriert seit:
    26. März 2013
    Beiträge:
    267
    Ort:
    Niedersachsen
    Minecraft:
    YellowPhoenix18
    Hey,ich denke viele werden das Problem auch haben,daher mache ich hier so zu sagen einen SammelThread,denn ab der 1.8 werden viele APIs nicht mehr richtig nutzbar sein,wie z.B. die BarAPI oder iDisguise.Dieser Thread soll dazu da sein evtl. Ersatz-APIs/Plugins zu finden.

    --------------------------------------------------
    Zu meiner Suche: Ich suche dringend Ersatz für die BarAPI und iDisguise

    mfg YellowPhoenix18
     
    #1
  2. LordRazen
    Offline

    LordRazen

    Registriert seit:
    23. Oktober 2013
    Beiträge:
    299
    Minecraft:
    LordRazen
    Erm, korrigier mich wenn ich falsch liege, BarAPI ist zB ein BUKKIT-Plugin, und soweit ich weiß wird Bukkit möglicherweise eingestellt und Spigot ist auch noch weit entfernt von einem Update. Ist es da nicht etwas verfrüht über Alternativen für Plugins nachzudenken? Auf welcher Serversoftware willst du die einsetzen?
     
    #2
    Souliii gefällt das.
  3. GermanElectronix
    Offline

    GermanElectronix

    Registriert seit:
    9. März 2014
    Beiträge:
    5
    Minecraft:
    leNic
    Wenn es möglich ist, dass jemand ein Ersatzplugin schreibt, wird der Entwickler von z.B. BarAPI sein Plugin wohl auch einfach aktualisieren.
     
    #3
  4. obviousAce
    Offline

    obviousAce

    Registriert seit:
    16. Mai 2014
    Beiträge:
    28
    Minecraft:
    EtwasBequem; obviousAce_
    Viele Entwickler publishen neue Versionen einfach abseits von Bukkit.org auf ihren Jenkins-Plattformen oder woanders. Nur weil Bukkit den Pluginsupport eingestellt hat heißt das nicht, dass die Entwickler gleiches tun.
     
    #4
  5. Basti07711
    Offline

    Basti07711 Ehem. Teammitglied

    Registriert seit:
    2. August 2012
    Beiträge:
    714
    Ort:
    Hinter dir
    Minecraft:
    Basti07711
    Bukkit mag zwar eingestellt werden und Spigot braucht noch für ein Update, aber es gibt eine viel versprechende Alternative: Sponge.
    Es wurde zwar noch kein Release-Datum veröffentlicht, aber ein Teil der bukkit-Entwickler, einige Plugin-Developer, ein Teil des Spigot-Team, des Canary-Teams und des Glowstone-Teams sind dabei.
    Das ist bis dato eine der wenigen alternativen. Bevor man alternativ-plugins sucht, würde ich auf APIs warten.
     
    #5
    Pardrox gefällt das.