1. Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

Plugin funktioniert nicht mehr?!

Dieses Thema im Forum "Server Plugins" wurde erstellt von fabian3636, 21. Dezember 2012.

Status des Themas:
Es sind keine weiteren Antworten möglich.

  1. fabian3636
    Offline

    fabian3636

    Registriert seit:
    26. März 2012
    Beiträge:
    47
    [Erledigt] Plugin funktioniert nicht mehr?!

    Hallo, hab da ein Problem mit meinem Plugin und zwar funktioniert es einfach nicht mehr! Es funktionierte eig. immer nur jetzt auf einmal nicht mehr?

    Fehlermeldung:


    2012-12-21 13:00:58 [SEVERE] Could not load 'plugins/Serverplugin.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: main/Serverplugin : Unsupported major.minor version 51.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:184)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:305)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:230)
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.loadPlugins(CraftServer.java:235)
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.<init>(CraftServer.java:213)
    at net.minecraft.server.v1_4_6.PlayerList.<init>(PlayerList.java:52)
    at net.minecraft.server.v1_4_6.DedicatedPlayerList.<init>(SourceFile:11)
    at net.minecraft.server.v1_4_6.DedicatedServer.init(DedicatedServer.java:104)
    at net.minecraft.server.v1_4_6.MinecraftServer.run(MinecraftServer.java:399)
    at net.minecraft.server.v1_4_6.ThreadServerApplication.run(SourceFile:849)
    Caused by: java.lang.UnsupportedClassVersionError: main/Serverplugin : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(Unknown Source)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$000(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at org.bukkit.plugin.java.PluginClassLoader.findClass0(PluginClassLoader.java:80)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:53)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:173)
    ... 9 more
     
    Zuletzt bearbeitet: 21. Dezember 2012
  2. Werbung
    Online

    Werbung

  3. Oregano
    Offline

    Oregano Gesperrt

    Registriert seit:
    17. Oktober 2012
    Beiträge:
    91
    Minecraft:
    REgoran
    Hast du die neu Craftbukkit drin?
     
  4. herberti
    Offline

    herberti

    Das deuted auf die falsche Java Version hin.
     
  5. Goldencreeper
    Offline

    Goldencreeper

    Registriert seit:
    3. Januar 2012
    Beiträge:
    662
    Geschlecht:
    männlich
    Wenn du die Craftbukkit Rec Build hast solltest du lieber wieder auf dei Beta oder auf den Dev wechseln da die Rec build doch einige Fehler enthält und die Plugins nicht mehr richtig Funktionieren.
    Betroffen sind die Plugins von sk89q also WorldEdit WorldGuard Permissionsex usw....
     
  6. Calenria
    Offline

    Calenria

    Registriert seit:
    28. Juli 2012
    Beiträge:
    386
    Minecraft:
    Calenria
    Unsupported major.minor version 51.0 <-- Hat nichts mit 1.4.5/6 sondern tritt nur bei einer falschen Java Version auf :)

    Was bedeutet das du kein Java 7 hast aber das Plugin damit Kompiliert wurde.
     
  7. herberti
    Offline

    herberti

    Danke Calenria :p
     
  8. fabian3636
    Offline

    fabian3636

    Registriert seit:
    26. März 2012
    Beiträge:
    47
    Jetzt gehts ;)
    Mein Server lief mit java 6 ;) jetzt mit 7 danke ;)
     
Status des Themas:
Es sind keine weiteren Antworten möglich.