Plugins und neue Bukkit 1.7.5

Dieses Thema im Forum "Server Plugins" wurde erstellt von KungLaoHD, 24. März 2014.

  1. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    Hat schon Jemand geschafft, folgende Plugins unter Bukkit 1.7.5 zum Laufen zu bekommen ?
    Die sind so weit ich sehe , noch nicht mit 1.7.5 kompatibel. Mit den u. a. kommen nur Fehler im Serverlog.

    TrailofBlood
    Builder (für Citizens2)
    dtlTraders (für Citizens2)
    ClearLagg
    Worldedit
    NoCheatPlus
    Paintball
     
    #1
  2. ReolatHD
    Offline

    ReolatHD

    Registriert seit:
    22. März 2014
    Beiträge:
    51
    Hallo ich könnte eventuell helfen. Woher hast du bukkit 1.7.5?
    Bitte schicke mir den link. Dann könnte ich mir das mal anschauen.
     
    #2
  3. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    - DownloadLink Craftbukkit 1.7.5-R01

    - DownloadLink Spigot 1.7.5-R01
     
    #3
  4. Wolfi15
    Offline

    Wolfi15

    Registriert seit:
    4. November 2011
    Beiträge:
    602
    Minecraft:
    Wolfi15
    Benutz ich selbst und bekomm keine Fehler...
    #3020 CB Version
     
    #4
  5. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    Hm ich nutze die Plugins auch mit anderen und nur die o. a. machen servre fehler.
     
    #5
  6. Vielleicht könntest du auch den Fehler hier schreiben? Wäre sinnvoll, damit dieser nachvollziehbar ist.
     
    #6
  7. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    Ok nach langem basteln kommen nur noch folgende Fehler:

    Code (Text):
    1. 24.03.2014 20:00:53 [SEVERE] Could not load 'plugins\TrailofBlood.jar' in folder 'plugins'
    2. 24.03.2014 20:00:53     at net.minecraft.server.v1_7_R2.ThreadServerApplication.run(SourceFile:618) [spigot-1.7.5-R0.1-SNAPSHOT.jar:git-Spigot-1352]
    3. 24.03.2014 20:00:53     ... 6 more
    4. 24.03.2014 20:00:53     ... 6 more
    5.  
    6. [20:01:50] [Server thread/INFO]: [Citizens] The trait sentry failed to load for NPC ID: 248.
    7. [20:01:50] [Server thread/ERROR]: [Citizens] An exception occurred while the trait sentry was spawning for NPC ID 248.
    8. [20:01:50] [Server thread/WARN]: java.lang.NoClassDefFoundError: net/minecraft/server/v1_7_R1/World
    9. [20:01:50] [Server thread/WARN]:    at net.aufdemrand.sentry.SentryTrait.ensureInst(SentryTrait.java:136)
    10. [20:01:50] [Server thread/WARN]:    at net.aufdemrand.sentry.SentryTrait.onSpawn(SentryTrait.java:117)
    11. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.npc.CitizensNPC.spawn(CitizensNPC.java:196)
    12. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.npc.CitizensNPC.load(CitizensNPC.java:114)
    13. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.api.npc.SimpleNPCDataStore.loadInto(SimpleNPCDataStore.java:59)
    14. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.Citizens$2.run(Citizens.java:295)
    15. [20:01:50] [Server thread/WARN]:    at org.bukkit.craftbukkit.v1_7_R2.scheduler.CraftTask.run(CraftTask.java:58)
    16. [20:01:50] [Server thread/WARN]:    at org.bukkit.craftbukkit.v1_7_R2.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:345)
    17. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.MinecraftServer.v(MinecraftServer.java:618)
    18. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.DedicatedServer.v(DedicatedServer.java:273)
    19. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.MinecraftServer.u(MinecraftServer.java:566)
    20. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.MinecraftServer.run(MinecraftServer.java:472)
    21. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.ThreadServerApplication.run(SourceFile:618)
    22. [20:01:50] [Server thread/WARN]: Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_7_R1.World
    23. [20:01:50] [Server thread/WARN]:    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:67)
    24. [20:01:50] [Server thread/WARN]:    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62)
    25. [20:01:50] [Server thread/WARN]:    at java.lang.ClassLoader.loadClass(Unknown Source)
    26. [20:01:50] [Server thread/WARN]:    at java.lang.ClassLoader.loadClass(Unknown Source)
    27. [20:01:50] [Server thread/WARN]:    ... 13 more
    28. [20:01:50] [Server thread/INFO]: [Citizens] The trait sentry failed to load for NPC ID: 255.
    29. [20:01:50] [Server thread/ERROR]: [Citizens] An exception occurred while the trait sentry was spawning for NPC ID 255.
    30. [20:01:50] [Server thread/WARN]: java.lang.NoClassDefFoundError: net/minecraft/server/v1_7_R1/World
    31. [20:01:50] [Server thread/WARN]:    at net.aufdemrand.sentry.SentryTrait.ensureInst(SentryTrait.java:136)
    32. [20:01:50] [Server thread/WARN]:    at net.aufdemrand.sentry.SentryTrait.onSpawn(SentryTrait.java:117)
    33. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.npc.CitizensNPC.spawn(CitizensNPC.java:196)
    34. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.npc.CitizensNPC.load(CitizensNPC.java:114)
    35. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.api.npc.SimpleNPCDataStore.loadInto(SimpleNPCDataStore.java:59)
    36. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.Citizens$2.run(Citizens.java:295)
    37. [20:01:50] [Server thread/WARN]:    at org.bukkit.craftbukkit.v1_7_R2.scheduler.CraftTask.run(CraftTask.java:58)
    38. [20:01:50] [Server thread/WARN]:    at org.bukkit.craftbukkit.v1_7_R2.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:345)
    39. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.MinecraftServer.v(MinecraftServer.java:618)
    40. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.DedicatedServer.v(DedicatedServer.java:273)
    41. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.MinecraftServer.u(MinecraftServer.java:566)
    42. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.MinecraftServer.run(MinecraftServer.java:472)
    43. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.ThreadServerApplication.run(SourceFile:618)
    44. [20:01:50] [Server thread/WARN]: Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_7_R1.World
    45. [20:01:50] [Server thread/WARN]:    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:67)
    46. [20:01:50] [Server thread/WARN]:    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62)
    47. [20:01:50] [Server thread/WARN]:    at java.lang.ClassLoader.loadClass(Unknown Source)
    48. [20:01:50] [Server thread/WARN]:    at java.lang.ClassLoader.loadClass(Unknown Source)
    49. [20:01:50] [Server thread/WARN]:    ... 13 more
    50. [20:01:50] [Server thread/INFO]: [Citizens] The trait sentry failed to load for NPC ID: 256.
    51. [20:01:50] [Server thread/ERROR]: [Citizens] An exception occurred while the trait sentry was spawning for NPC ID 256.
    52. [20:01:50] [Server thread/WARN]: java.lang.NoClassDefFoundError: net/minecraft/server/v1_7_R1/World
    53. [20:01:50] [Server thread/WARN]:    at net.aufdemrand.sentry.SentryTrait.ensureInst(SentryTrait.java:136)
    54. [20:01:50] [Server thread/WARN]:    at net.aufdemrand.sentry.SentryTrait.onSpawn(SentryTrait.java:117)
    55. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.npc.CitizensNPC.spawn(CitizensNPC.java:196)
    56. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.npc.CitizensNPC.load(CitizensNPC.java:114)
    57. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.api.npc.SimpleNPCDataStore.loadInto(SimpleNPCDataStore.java:59)
    58. [20:01:50] [Server thread/WARN]:    at net.citizensnpcs.Citizens$2.run(Citizens.java:295)
    59. [20:01:50] [Server thread/WARN]:    at org.bukkit.craftbukkit.v1_7_R2.scheduler.CraftTask.run(CraftTask.java:58)
    60. [20:01:50] [Server thread/WARN]:    at org.bukkit.craftbukkit.v1_7_R2.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:345)
    61. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.MinecraftServer.v(MinecraftServer.java:618)
    62. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.DedicatedServer.v(DedicatedServer.java:273)
    63. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.MinecraftServer.u(MinecraftServer.java:566)
    64. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.MinecraftServer.run(MinecraftServer.java:472)
    65. [20:01:50] [Server thread/WARN]:    at net.minecraft.server.v1_7_R2.ThreadServerApplication.run(SourceFile:618)
    66. [20:01:50] [Server thread/WARN]: Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_7_R1.World
    67. [20:01:50] [Server thread/WARN]:    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:67)
    68. [20:01:50] [Server thread/WARN]:    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62)
    69. [20:01:50] [Server thread/WARN]:    at java.lang.ClassLoader.loadClass(Unknown Source)
    70. [20:01:50] [Server thread/WARN]:    at java.lang.ClassLoader.loadClass(Unknown Source)
    71. [20:01:50] [Server thread/WARN]:    ... 13 more
    Ich habe die neusten DEV von Citizens2, Sentry und TrailofBlood drauf.
     
    #7
  8. Das Plugin benutzt native Klassen, es wird also nicht mit der neusten Version kompatibel sein.
     
    #8
  9. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    Schade, habe TrailofBlood, Sentry entfernt und keine Fehler mehr. Nur 3 Warnings-Infos.

    1. ClearLag: build is made for 1.7.2
    2. WorldEdit: no compatible nms block class found
    3. NochetPlus: could not set up native access for your specific Minecraft + Server version

    An sonsten läuft es alles mit 1.7.5 nun

    Ich hoffe, das die die 2 Plugins auch bald updaten, damit sie mit der 1.7.5 kompatibel sind. Laufen zwar aber sind für 1.7.2
     
    #9