Plugins werden nicht geladen

Dieses Thema im Forum "Technischer Support" wurde erstellt von keahie, 5. August 2015.

  1. keahie
    Offline

    keahie

    Registriert seit:
    22. Februar 2014
    Beiträge:
    23
    Minecraft:
    keahie
    Liebe Minecraft-Server.eu Community,
    ein Freund von mir hat bei Dawn-Server einen Server gemietet und bis jetzt hat alles einigermaßen gut geklappt. Ich habe schon einige Plugins installiert (WorldEdit, WorldGuard, Essentials, ...), als ich allerdings meine eigenen Plugins benutzen wollte, werden die Plugins einfach nicht geladen und dass bei jedem Plugin das ich selber geschrieben habe. Alle anderen die ich heruntergeladen habe, funktionieren. Da der Server unter Dawn-Server gemietet worden ist, kann ich leider nicht in die Konsole schauen und in der Server.log Datei stehen auch keine Fehler. Wenn sich da einer auskennt, bitte hier schreiben. Ich danke euch.
    Mit freundlichen Grüßen,

    keahie, aka panfernox
     
    #1
    ItZMichii gefällt das.
  2. SilberRegen
    Offline

    SilberRegen

    Registriert seit:
    23. März 2012
    Beiträge:
    578
    Minecraft:
    SilberRegen
    Funktionieren sie denn auf anderen Servern (deinem Testserver)?
     
    #2
  3. keahie
    Offline

    keahie

    Registriert seit:
    22. Februar 2014
    Beiträge:
    23
    Minecraft:
    keahie
    Ja das habe ich getestet. Ich habe sogar die selbe Server.jar benutzt wie auf dem richtigen Server.
     
    #3
  4. Vanityra
    Offline

    Vanityra

    Registriert seit:
    9. Juni 2015
    Beiträge:
    219
    Ort:
    Heidelberg
    Minecraft:
    Vanityra
    Andere Java-Version?
     
    #4
  5. keahie
    Offline

    keahie

    Registriert seit:
    22. Februar 2014
    Beiträge:
    23
    Minecraft:
    keahie
    Das könnte es vielleicht sein. Ich probiere es einmal aus.
     
    #5
  6. keahie
    Offline

    keahie

    Registriert seit:
    22. Februar 2014
    Beiträge:
    23
    Minecraft:
    keahie
    Es liegt nicht an der Java Version :(
     
    #6
  7. SilberRegen
    Offline

    SilberRegen

    Registriert seit:
    23. März 2012
    Beiträge:
    578
    Minecraft:
    SilberRegen
    Auch mit den gleichen Plugins? Ansonsten wüsste ich echt nicht woran es liegen könnte, außer, dass da irgendwo was vergessen wurde.
     
    #7
  8. keahie
    Offline

    keahie

    Registriert seit:
    22. Februar 2014
    Beiträge:
    23
    Minecraft:
    keahie
    Also, ich habe mir jetzt einen Nitrado Server für 1€ gekauft und habe dort die Konsole nach dem Fehler durchsucht, und habe einen bekommen: http://pastebin.com/R61f6fDx . Diesen Fehler bekomme ich auf meinem Privaten Server nicht. Falls mir jemand mit dem Fehler helfen kann würde mich das sehr freuen (kenne diesen Fehler noch nicht). Eine erklärung wäre auch sehr schön und hier noch der Source Code: http://pastebin.com/k3M1uPsf
    http://pastebin.com/wVfYV9Wr http://pastebin.com/R7mYDViZ
    Das Plugin ist noch nicht fertig also nicht wundern das es noch sehr unfertig ist.
    Danke :)
     
    #8
    ItZMichii gefällt das.
  9. Vanityra
    Offline

    Vanityra

    Registriert seit:
    9. Juni 2015
    Beiträge:
    219
    Ort:
    Heidelberg
    Minecraft:
    Vanityra
    Unsupported major.minor version 52.0
     
    #9
  10. Inkemann
    Offline

    Inkemann

    Registriert seit:
    3. Mai 2015
    Beiträge:
    341
    Ort:
    Aachen
    Minecraft:
    Inkemann
    Das Plugin benutzt Funktionen die mit Java 8 eingeführt wurden oder wurde mit Java 8 kompiliert, der Server hat aber nur Java 7. Genau das bedeutet dieser Fehler.
     
    #10
  11. keahie
    Offline

    keahie

    Registriert seit:
    22. Februar 2014
    Beiträge:
    23
    Minecraft:
    keahie
    Ok ich habe versucht das Problem zu lösen, habe es aber nicht geschafft. Weiß wer wie ich den Fehler lösen kann?
     
    #11
  12. Inkemann
    Offline

    Inkemann

    Registriert seit:
    3. Mai 2015
    Beiträge:
    341
    Ort:
    Aachen
    Minecraft:
    Inkemann
    Änder mal das Compiler-level in deiner IDE auf 1.7 und guck ob es Fehler gibt. Wenn es Fehler gibt benutzt du Funktionen aus Java 8, wenn es keine gibt, dann kompiliere auf 1.7 und dann sollte es gehen.
     
    #12
  13. keahie
    Offline

    keahie

    Registriert seit:
    22. Februar 2014
    Beiträge:
    23
    Minecraft:
    keahie
    Ich danke jedem der hier geschrieben hat und auf jeden Fall Inkemann und Vanityra, es hat jetzt funktioniert :)
    LG keahie aka panfernox
     
    #13
  14. Vanityra
    Offline

    Vanityra

    Registriert seit:
    9. Juni 2015
    Beiträge:
    219
    Ort:
    Heidelberg
    Minecraft:
    Vanityra
    Gerne, auch wenn meine Beiträge nicht hilfreich waren. :)
    Wobei, ich hab das mit der Java-Version auf den Tisch gebracht :D

    *vote4close*

    Die Moderation scheint immernoch nicht wirklich zu wissen, dass ich damit "erledigt, bitte schließen" meine, denn dies nutze ich oft und es wurde noch nie wahrgenommen.
     
    #14