Problem mit Skript und Worldguard bei 1.8 ...

Dieses Thema im Forum "Technischer Support" wurde erstellt von fabigamer235, 12. Mai 2015.

  1. fabigamer235
    Online

    fabigamer235

    Hallo,
    habe da so ein Problem: Mein Server ist für 1.8. Für Skript gibts ja keine 1.8-Version. Habe Skripts wo Regionen-Angaben sind, also "if player is in region" und so. Wenn ich die 1.8-Worldguard-Version habe funktioniert das jedoch nicht und der Server stürzt ab und zu ab und es gibt Fehler im Log, weil Skript damit nicht kompatibel ist. Nutze ich eine 1.7 Version geht es zwar, aber Spieler können überall Rüstungsständer platzieren, auch da wo protectet ist, weil ja Worldguard das noch nicht kennt. Blockieren kann ich es somit auch nicht mit Skript, da Skript ja nicht für 1.8 ist^^

    Was kann ich da tun?
     
    #1
  2. CaptAim
    Online

    CaptAim

    Registriert seit:
    25. September 2011
    Beiträge:
    269
    Ort:
    Hamburg
    Minecraft:
    kinglibero
    Brauchst du die Rüstungsständer ? Wenn nein setzte sie auf die Blacklist
     
    #2
  3. fabigamer235
    Online

    fabigamer235

    Wo? Worldguard? Kennt doch denke mal nicht mit der 1.7-Version.
     
    #3
  4. SilberRegen
    Offline

    SilberRegen

    Registriert seit:
    23. März 2012
    Beiträge:
    579
    Minecraft:
    SilberRegen
    Wenn es sich um dieses Plugin hier handelt, ist es klar an der Zeit sich nach einer aktuellen Alternative umzusehen. Das Projekt urde seit letztem Jahre nicht mehr aktualisiert und wenn es nun Probleme gibt, wirst du entweder auf etwas anderes umstellen oder dir jemanden suchen müssen der dieses wartet oder ein ähnliches Plugin für dich erstellt.

    Die WorldGuard-Version nach einem inaktiven Plugin zu richten ist auf jeden Fall keine gute Idee.
     
    #4
  5. fabigamer235
    Online

    fabigamer235

    Hm ok. Kennt vielleicht jemand eine Alternative?
     
    #5
  6. Malfrador
    Online

    Malfrador

    Registriert seit:
    16. Juni 2013
    Beiträge:
    413
    Minecraft:
    Malfrador
    Skript bekommt laut dem Dev ein größeres Update, an dem momentan gearbeitet wird. Inaktiv ist es nicht. Und zu deinem Problem: WG 5.9 und Rüstungsständer anders blocken, eine andere Möglichkeit gibt es eher nicht. Alternative für Skript wäre Denizen, das ist aber eher auf Quests und NPCs ausgelegt und komplizierter als Skript.
     
    #6
  7. BuildingDave
    Offline

    BuildingDave

    Registriert seit:
    5. Juli 2012
    Beiträge:
    321
    Kann dir gerne ein Plugin zur Verfügung stellen mit dem man JEDES Item sperren kann.
    Sowohl das craften, das aufheben, das wegwerfen als auch das nutzen kann man separat aus schalten.
    Bei Interesse einfach melden
     
    #7
    fabigamer235 gefällt das.
  8. fabigamer235
    Online

    fabigamer235

    Danke, Problem gelöst ;)
     
    #8
  9. BuildingDave
    Offline

    BuildingDave

    Registriert seit:
    5. Juli 2012
    Beiträge:
    321
    gern geschehen
     
    #9
    fabigamer235 gefällt das.