[Problem] recv fail

Dieses Thema im Forum "Technischer Support" wurde erstellt von MARODEUR, 24. August 2013.

  1. MARODEUR
    Offline

    MARODEUR

    Registriert seit:
    18. Oktober 2011
    Beiträge:
    38
    Hallo,

    ich hab seit inzwischen schon mehreren Wochen folgendes Problem mit meinem Minecraft Server, vielleicht kann mir ja einer von euch helfen.

    Mitten beim bauen werden alle Spieler vom Server gekickt mit der Message: Internal exception: java.netSocketException: Software caused connection abort: recv failed

    Der Server startet daraufhin einfach. Ich kann nichtmal sagen dass er neustartet, im Log sieht es so aus als würde er denken er wäre noch gar nicht gestartet und startet einfach. Ich habe bereits verschiedene Lösungen im Internet gesucht und ausprobiert, jedoch hat bisher nichts geholfen.
    Der Server läuft unter 1.6 Bukkit beta build auf Debian Wheezy, mit dem Remote Toolkit Plugin. Oracle Server JRE java 7_25 falls das relevant sein sollte.
    Falls jemand eine Idee hat wäre ich sehr dankbar, ich bekomm das Problem einfach nicht in den Griff.
    So sieht das ganze im Server Log aus:

    2013-08-24 18:33:53 [INFO] WorldEdit: ** (in "**"): /set 98,98:1,98:2 - Region: (-462.0, 49.0, 631.0) - (-462.0, 49.0, 631.0)
    2013-08-24 18:33:55 [INFO] [[0;36;1mAutoMessage[m] [0;31;22m *ZENSIERT*[m
    2013-08-24 18:34:02 [INFO] *** issued server command: //set 98,98:1,98:2
    2013-08-24 18:34:02 [INFO] WorldEdit: *** (in "Hauptwelt"): /set 98,98:1,98:2 - Region: (-462.0, 44.0, 626.0) - (-462.0, 48.0, 631.0)
    2013-08-24 18:34:31 [INFO] Starting minecraft server version 1.6.2
    2013-08-24 18:34:31 [INFO] Loading properties
    2013-08-24 18:34:31 [INFO] Default game type: SURVIVAL
    2013-08-24 18:34:31 [INFO] Generating keypair
    2013-08-24 18:34:32 [INFO] Starting Minecraft server on *:25565
    2013-08-24 18:34:32 [INFO] This server is running CraftBukkit version git-Bukkit-1.6.2-R0.1-10-ga3390f5-b2850jnks (MC: 1.6.2) (Implementing API version 1.6.2-R0.2-SNAPSHOT)
    2013-08-24 18:34:32 [INFO] ----- Bukkit Auto Updater -----

    Nicht über die WorldEdit sachen wundern, wir sind aktuell noch im Server aufbau und hierbei handelte es sich jeweils um kleinere Änderungen welche nicht für die Crashs verantwortlich sind. Im Log ist erkennbar dass zudem einfach 30 sekunden fehlen...
     
    #1
  2. Thomas
    Offline

    Thomas

    Registriert seit:
    14. Juli 2011
    Beiträge:
    644
    Sieht mir danach aus, dass einfach der Prozess vom Server abgestürtzt ist und durch RTK neugestartet wird. Dieses Problem hat mich auch mal eine Zeit lang beschäftigt, als ich RTK verwendet habe. Sonst ist es mir nie untergekommen, nachdem ich auf Multicraft umgestellt habe, passiert dies nie mehr. Wodran das liegt, weiß ich jedoch nicht.
     
    #2
  3. MARODEUR
    Offline

    MARODEUR

    Registriert seit:
    18. Oktober 2011
    Beiträge:
    38
    Dachte ja auch erst es liegt am RTK, welches ich daraufhin mal deaktiviert hab, den Fehler gabs jedoch immer noch. Hab auch mal das ganze unter Spigot versucht, der fehler blieb bestehen. Hab echt keine Ahnung mehr >.<
     
    #3