1. Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

PlugIn Professionelle Hilfe gebraucht

Dieses Thema im Forum "Programmierung" wurde erstellt von TimBone, 28. Oktober 2012.

Status des Themas:
Es sind keine weiteren Antworten möglich.

  1. TimBone
    Offline

    TimBone

    Liebe Community,
    ich habe wieder einmal ein Problem - Und zwar habe ich ein Plugin für unseren Server geschrieben (GameServer - 6GB RAM - 20 Sslots - Java 7). Das Plugin wurde von mir mit Java 7 compiled. Auf meine Localhost Server funktioniert es einwand frei...auf dem Server kommt allerdings eine Fehlermeldung...http://pastebin.com/wiJFMBsN

    Kann mir einer behilflich sein?
     
  2. gmx206
    Offline

    gmx206 Gesperrt

    Registriert seit:
    1. April 2012
    Beiträge:
    151
    Minecraft:
    Teedy
    config nicht richtig eingestellt ?
     
  3. TimBone
    Offline

    TimBone

    Ne, die Config wird vom Plugin generiert und in der Config sind nur Preise und Texte festgelegt, aber nichts was denn Start behindern sollte.

    Die Config: http://pastebin.com/paM8KBcp
     
  4. Benni1000
    Offline

    Benni1000 Ehem. Teammitglied

    Registriert seit:
    4. Mai 2012
    Beiträge:
    1.397
    Das Plugin wurde mit Java7 compiliert, aber auf euerem Server läuft Java6.
    Compile das Plugin mit Java6 und alles sollte problemlos funktionieren.
     
  5. TimBone
    Offline

    TimBone

    Ich habe es mit Java 6 probiert, das hat nicht funktioniert. Auf Nachfrage habe ich erfahren, dass der Server mit Open JDK 7 JRE läuft.
     
  6. Benni1000
    Offline

    Benni1000 Ehem. Teammitglied

    Registriert seit:
    4. Mai 2012
    Beiträge:
    1.397
    Ich bezweifle das der Server auf version 7 läuft.
    Diese Fehlermeldung gibt es nur wenn die version mit der compiliert wurde höher ist als die benutze version.
    Was hat denn nicht funktioniert als du mit Java 6 compiliert hast?
     
  7. TimBone
    Offline

    TimBone

    Da kam die gleiche Meldung
     
  8. Benni1000
    Offline

    Benni1000 Ehem. Teammitglied

    Registriert seit:
    4. Mai 2012
    Beiträge:
    1.397
    Ok ich bezweifle das du wirklich mit Java6 kompiliert hast.
    Wie hast du das denn umgestellt mit was du compilierst?
     
  9. f14_tomcat
    Offline

    f14_tomcat

    Registriert seit:
    16. Oktober 2012
    Beiträge:
    12
    Minecraft:
    f14_tomcat
    Da du ja vermutlicherweise mit Eclipse arbeitest, sage ich dir hier kurz, wie man das umstellt.
    1. Einstellungen öffnen
    2. Auf den Pfeil vor Java klicken
    3. Auf den Pfeil vor Compiler compliance level und sonst überall 1.6 einstellen
    Dann sollte es nach erneutem compilen funktionieren ;)
     
  10. TimBone
    Offline

    TimBone

    Also erst einmal kann ich wohl Java und weis auch wie man mit Eclipse umgeht... Ich habe ein Plugin entwickelt mit dem man einen Countdown erstellen kann und habe es unter den gleichen Einstellungen compiled. Das Plugin funktioniert! Das ist irgendwie seltsam...
     
  11. TimBone
    Offline

    TimBone

    mySQL

    Kann es auch an einem Problem mit mySQL liegen?
     
  12. Calenria
    Offline

    Calenria

    Registriert seit:
    28. Juli 2012
    Beiträge:
    386
    Minecraft:
    Calenria
    nein kann es nicht. Klick
     
Status des Themas:
Es sind keine weiteren Antworten möglich.