Root Server MC join/spawn/home lag

Dieses Thema im Forum "Technischer Support" wurde erstellt von Desmond_Rae, 6. Januar 2016.

  1. Desmond_Rae
    Offline

    Desmond_Rae

    Registriert seit:
    21. Januar 2012
    Beiträge:
    2
    Hallo zusammen
    ich bin schon seit fast 1 Monat auf der suche Nach Problem Lösung

    wen Spieler in eine andre Welt sich tp Dann haben die Spieler immer so eine 1 bis 2 sec lag

    wir haben ein Root Server

    intel i5-4590 Quad-Core 4x 3.7 Ghz
    32Gb DDR4
    2 x 256 GB SSD 96.000 IOPS
    Anschlussbandbreite 1.000 Mbit/s
    Datentransfer Unbegrenzt
    Garantierte Bandbreite 200 Mbit/s
    Außenanbindung 550 Gbit/s
    Provider Deutsche Telekom, Level 3, Global Crossing, cogent, DE-CIX, interoute, u.a.
    Verfügbarkeit 99,9%

    der Server bekommt 22 Gb Ram
    Wir Nutzen Spigot 1.8.8

    Und der Server hat kein Plugins im mom drauf da wir das Problem erst mal beheben wollen mit den lag
    (wir haben schon server aufgebaut aber der ist noch geschlossen da her spielen unsre User auf ein test Server der keine Plugins hat)

    wir würden uns freuen wen uns da einer helfen könnte

    start bat
    @echo off
    :Minecraft
    echo (%time%) Minecraft started.
    java -version
    java -Xmx22G -jar craftbukkit.jar
    echo (%time%) WARNING: Minecraft closed or crashed, restarting.
    ping 1.1.1.1 -n 1 -w 3000 >nul
    goto Minecraft
     

    Anhänge:

    #1
  2. Asgarioth
    Offline

    Asgarioth

    Registriert seit:
    17. Juli 2014
    Beiträge:
    51
    Ort:
    Hessen
    Minecraft:
    Asgarioth
    Hallo Desmond_Rae,

    Die Informationen sind ein wenig dürftig, um sich ein Bild zu machen. Die Eckdaten des Servers allein sind an der Stelle aus meiner Sicht erstmal nicht ganz so wichtig und helfen erst im Kontext weiter (Fragen unten).

    Zunächst einmal die Frage nach dem grundsätzlichen Setup, wie genau ihr mehrere Welten realisiert habt (ich nehme an, dass Du hier nicht die "Standard"-Welten Overworld + Nether + End meinst). Das ihr da völlig ohne Plugins unterwegs seid ist kaum zu glauben (auch bzgl. Homes etwa).

    Ansonsten folgende grundsätzliche Fragen:

    - Wie schaut es mit der Konfiguration des Servers generell und problemspezifisch (View Distance, Bulk Chunks) aus?
    - Sind in den jeweiligen Welten die betreffenden Zielbereiche dauerhaft geladen oder nicht?
    - Wie gut ist grundsätzlich die Verbindung tatsächlich zwischen Client und Server?

    Der Ablauf ist ja immer der, dass zunächst alle Chunks um den Spieler vom Server an den Client gesendet werden müssen. Das kann natürlich ganz schnell zu einer Lagg-Situation führen. Es müssen ja zunächst vom Server alle relevanten Map-Daten geladen werden und dann an den Client geschickt werden. Je nach Konfiguration ist das unterschiedlich viel zu einem Zeitpunkt. Später werden dann nur noch kleinere Mengen an den Client geschickt, abhängig von der Bewegung der Spieler.

    Grundsätzlich gilt das für alle im Titel genannten Fälle:
    - Spawn-Bereiche
    - Homes
    - Joins (was auf Spawn-Bereich, Home oder den letzten Ort irgendwo auf einer Map hinausläuft)

    So long,
    ~Asgarioth
     
    #2
  3. Malfrador
    Offline

    Malfrador

    Registriert seit:
    16. Juni 2013
    Beiträge:
    407
    Minecraft:
    Malfrador
    In so einem Fall wären Timings ganz sinnvoll. /timings on, auf einen Lagg warten und /timings paste. Dann uns den Link schicken.

    Informationen über die Sichtweite wären auch noch wichtig, mehr als 10 ist selten ein guter Wert
     
    #3
  4. UnityGaming
    Offline

    UnityGaming

    Registriert seit:
    25. Oktober 2015
    Beiträge:
    89
    Ort:
    Hohenfels
    Minecraft:
    FastFelix771
    Zusätzlich wäre es eine gute Idee von den 22GB wegzukommen... das ist Wahnsinn!
    Java haushaltet besser mit den Ressourcen wenn du weniger zur Verfügung stellst, probiere es mal mit 4 - 8GB.
    Außerdem können ein paar Tuning Argumente nicht schaden, einfach nur "java -jar craftbukkit.jar" ist alles andere als optimal.

    Informationen zur Java Version, sowie Betriebssystem wären auch sehr hilfreich!
    Da du oben eine Batch Datei gepostet hast, gehe ich mal von Windoof aus?
    Wie ich sehe ist McMyAdmin installiert, hast du schon probiert den Server ohne MCMA laufen zu lassen?
    Handelt es sich um einen Managed Root?

    Wenn man in den Server Configs exorbitante Werte stehen hat, kann es auch helfen wenn man diese etwas senkt...
     
    #4
    jensIO gefällt das.