Server besser auf Festplatte anpassen?

Dieses Thema im Forum "Technischer Support" wurde erstellt von xgamer405, 20. Dezember 2013.

  1. xgamer405
    Offline

    xgamer405

    Registriert seit:
    11. Juni 2012
    Beiträge:
    91
    Minecraft:
    xgamer405
    Hallo zusammen,

    ich besitze einen Tekkit Server auf dem es möglich ist, relativ schnell zu fliegen. Fliegt man nun in ungenerierte Chunks müssen diese generiert und auf der Festplatte gespeichert werden. Dieser Vorgang ist allerdings zu langsam, fliegen die Spieler weit genug in ein Gebiet hinein welches noch nicht generiert wurde stürzt der Server ab.
    Nun kann ich über Gadgets sehen das der Tekkit Server die Festplattengeschwindigkeit nicht vollkommen ausnutzt, der schreibt ca. mit 1 MB/s obwohl der Server auf einer SSD läuft welche bis zu 300MB/s schreiben kann. Gibt es vielleicht irgend einen Startbefehl oder andere Tricks das der Tekkit Server die Festplatte besser nutzt, wie es bei der CPU ja beispielsweise ParallelGCThreads gibt?

    Mit freundlichen Grüßen
    XGaMeR
     
    #1
  2. Es kommt ja auf das Internet von dem Spieler an. Auch deine Server Anbindung kommt da ins Spiel.

    Sowohl im Single Player oder im Multiplayer auf "Speed 10" funktioniert allgemein ohne Minecraft Crash / Server Absturtz nicht.

    Schätze das liegt halt an Java.
     
    #2
  3. xgamer405
    Offline

    xgamer405

    Registriert seit:
    11. Juni 2012
    Beiträge:
    91
    Minecraft:
    xgamer405
    Es kommt in meinem Fall zu einem kompletten Server Crash und nicht nur dazu das der Client rausgeschmissen wird.
    Die Anbindung des Roots ist 1Gbit, das ist nicht das Problem.

    Kann man an dieser Stelle nichts optimieren das es vielleicht doch geht?
     
    #3
  4. Ebenso liegt es auch daran, welche Einstellungen der Spieler hat. Chunks werden schneller geladen wenn die Grafikauflösung nicht so hoch ist, Chunks werden langsam geladen wenn man alles an hat.
     
    #4
  5. PyroFZ
    Offline

    PyroFZ

    Registriert seit:
    22. Januar 2013
    Beiträge:
    81
    Minecraft:
    PyroFZ
    Auf unserem Server hatten wir das Problem, dass wenn jemand schnell über neue Chunks fliegt der Server extrem angefangen hat zu laggen.

    Grund hierfür war, dass Vorgänge in einem Chunk (Waterflow/Lavaflow usw.) noch nicht abgeschlossen waren und da wurden bereits neu Chunks geladen. Und so konnten entsprechende Events nicht abgeschlossen werden.

    Abhilfe hat eine Anpassung der Worldguard Config gebracht. So das diese Vorgänge (Events) disabled wurden.

    Folgendes habe ich verändert und die Laggs waren weg:

    Die Funktion des Sponges deaktiviert
    Obsidian Generator geblockt
    high frequenzy flags deaktiviert
    Keine Blöcke unter lava/water spread blocks gelistet!

    Vielleicht hilft es dir was!
     
    #5
  6. Chrisliebaer
    Online

    Chrisliebaer

    Die Terraingenerierung hängt hauptsächlich von der Rechenleistung ab. Du kannst daher über die Festplattte nicht viel optimieren. Verbiete einfach das schnelle Fliegen, das ist eh in meinen Augen Blödsinn.
     
    #6
  7. xgamer405
    Offline

    xgamer405

    Registriert seit:
    11. Juni 2012
    Beiträge:
    91
    Minecraft:
    xgamer405
    Ich habe mal deine Tipps befolgt und das eingestellt, allerdings fürchte ich das das nicht so viel bringt. Dennoch danke für den Tipp PyroFZ!

    Chris:
    Naja, aber die CPU Leistung ist in diesem Moment auch nicht enorm höher. Die CPU wird nie mehr als zu 50% verwendet..
     
    #7
  8. Chrisliebaer
    Online

    Chrisliebaer

    Das klingt verdächtig nach 2 Kernen. Minecraft ist keine Multicoreanwendung und lastet daher immer nur einen Kern aus. Teilweise haben Bukkit und vor allem Spigot da zwar kleines Fixes, damit zumindest manches auf anderen Kernen läuft, aber die Terraingeneration soweit ich weiß nicht.

    Klingt daher also noch immer nach einer ausgelasteten CPU.
     
    #8
  9. xgamer405
    Offline

    xgamer405

    Registriert seit:
    11. Juni 2012
    Beiträge:
    91
    Minecraft:
    xgamer405
    Nene, wir haben acht Kerne. Ich denke ich habe den Problemverursacher gefunden, ist nicht die CPU gewesen sondern die Mod MythCraft über die die Welt geladen wird. Ich setz die Welt in Zukunft über ein Plugin auf dann sollte das besser funktionieren.

    Danke für die Hilfestellung!
    MfG
    XGaMeR
     
    #9