Server Lag: Skipping 1200+ Ticks!

Dieses Thema im Forum "Technischer Support" wurde erstellt von Blindhero, 15. März 2014.

  1. Blindhero
    Offline

    Blindhero

    Registriert seit:
    23. Januar 2014
    Beiträge:
    24
    Ort:
    Deutschland
    Minecraft:
    BlinderHeld
    Hallo. Bei mir tauchen regelmäßig Lags auf und es sind immer ca 1211 oder mal 1213 Ticks... Ich hab keine Ahnung warum..
    Vielleicht hat da jemand ne Ahnung.
    Mein Server hat 4GB ram, die aber nie voll ausgenutzt werden - es spielen ca 5 Spieler zu selben Zeit.
    Im folgendem eine Liste der Plugins:
    <<<
    ChatManagerPlus
    ChestShop
    ColoredText
    CommandSigns
    Essentials [+Anti Build, Commands ...]
    FrameProtector
    WorldGuard
    WorldEdit
    WorldBorder
    Glizer
    LogBlock
    Lwc
    Multiverse
    PermissionsEx
    PetitionPlugin
    SignEdit
    TagApi
    Vault
    Votifier
    HostWerbung
    ServerPlugin
    >>>
    Wobei das ServerPlugin selbst programmiert wurde und HostWerbung - naja vom Host halt :D
    Hätte da jemand eine Idee oder braucht ihr noch mehr Informationen?
     
    #1
  2. bformine
    Offline

    bformine

    Registriert seit:
    6. Juli 2012
    Beiträge:
    329
    Ort:
    join.mc-skyblock.eu
    Minecraft:
    bformine
    Wie wäre es mit einer Server.log Datei? :)
     
    #2
  3. Blindhero
    Offline

    Blindhero

    Registriert seit:
    23. Januar 2014
    Beiträge:
    24
    Ort:
    Deutschland
    Minecraft:
    BlinderHeld
    Oh tut mir Leid - Habe ich vergessen :D Aber kann grundsätzlich sagen dass da nich mehr steht als mit "Can't keep up" bliblablub.
    wenn ihr da mehr rauslesen könnt, gerne :D
    Und jetzt als ich mir den Log ma genauer anschaue...
    Diese Zeile taucht immer wieder auf:
    [22:49:44] [Server thread/INFO]: [Frame Protector] §cFrame Protector updater was unable to contact DBO to download the update!
    [22:49:44] [Server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 60574ms behind, skipping 1211 tick(s)

    ----
    Also liegts wohl am Frame Protector!
    Tja. Manchmal muss man nur die Frage stellen um eine Antowort von sich selbst zu bekommen :)
     

    Anhänge:

    #3
  4. ImpactCP
    Offline

    ImpactCP

    Registriert seit:
    21. Oktober 2012
    Beiträge:
    23
    Minecraft:
    ImpactCP
    Vermutlich ein schlecht programmiertes Plugin: Der Updater läuft (vermutlich) im mainthread.

    Lösung: Updater im Plugin deaktivieren.

    Jedenfalls kann man nicht sehr viel mehr daraus erkennen, ausser natürlich einer im GM1 hat was tolles gebaut.... ;)
     
    #4
  5. Blindhero
    Offline

    Blindhero

    Registriert seit:
    23. Januar 2014
    Beiträge:
    24
    Ort:
    Deutschland
    Minecraft:
    BlinderHeld
    Nein :) Lag wirklich an diesem Plugin (das nicht von mir stammt Ö_Ö). Einfach Updater ausgemacht und schon lief alles flüssig :) Wurde aber auch mal Zeit
     
    #5