Server mit 1.6.4 UND 1.7.2 joinen

Dieses Thema im Forum "Technischer Support" wurde erstellt von BuildingDave, 28. November 2013.

  1. BuildingDave
    Offline

    BuildingDave

    Registriert seit:
    5. Juli 2012
    Beiträge:
    321
    Hallo an alle...

    ich habe leider nicht verwertbares gefunden, deshalb meine Frage hier.
    Es gibt wohl die Möglichkeit einen Server so einzustellen, dass man mit 1.6.4 und mit 1.7.2 joinen kann.
    Das in diesem Fall die Blöcke von 1.7 noch nicht integriert sind ist mir völlig klar...

    Hat jemand Kenntnis darüber wie man das einstellen kann, und würde das hier posten?

    Gruß Dave
     
    #1
  2. Sn0wBlizz4rd
    Offline

    Sn0wBlizz4rd

    Registriert seit:
    26. September 2012
    Beiträge:
    424
    Minecraft:
    Sn0wBlizz4rd
    "Einstellen" kann man das nicht, die ganzen Server machen das mit BungeeCord, jedoch mit einer modifizierten Version ;)
     
    #2
  3. BuildingDave
    Offline

    BuildingDave

    Registriert seit:
    5. Juli 2012
    Beiträge:
    321
    das es nicht lediglich eine einstellung von false auf true ist ist mir schon klar.
    die frage ist, woher man die benötigten komponenten bekommt und wie man es dann zum laufen bekommt... es sind ja mittlerweile schon einige server.
     
    #3
  4. Sn0wBlizz4rd
    Offline

    Sn0wBlizz4rd

    Registriert seit:
    26. September 2012
    Beiträge:
    424
    Minecraft:
    Sn0wBlizz4rd
    Theoretisch könnte man die Ping-Funktion der 1.7 der Vanilla-Server JAR entnehmen und in Bukkit einbauen, und die Versionchecks ID auf >= 73 stellen. Das würde in der Theorie bewirken, dass man mit Mit 1.6.2, 1.6.4, 1.7.2 joinen kann.
     
    #4
  5. Crafter6432
    Offline

    Crafter6432

    Registriert seit:
    22. Dezember 2011
    Beiträge:
    686
    Wenn das mal so einfach wäre, den wenn der Server von einem 1.7 Clienten ein Paket erhält welches er nicht kennt gibt es einen kick. Das mit dem ping hat bei 1.6.2 und 1.6.4 nur geklappt, da das Protokoll sich nicht verändert hat.
     
    #5
  6. Sn0wBlizz4rd
    Offline

    Sn0wBlizz4rd

    Registriert seit:
    26. September 2012
    Beiträge:
    424
    Minecraft:
    Sn0wBlizz4rd
    Naja, meine Theorie könnte man dann jedoch in der 1.7 Spigot verwenden ;)
     
    #6
  7. ChunkNorris
    Offline

    ChunkNorris

    Nein! Das Protokoll wurde mit 1.7.2 KOMPLETT geändert. Das Packetdesign, die Loginsequenz und vieles anderes am Protokoll wurde geändert.
    Wenn man beide Versionen unterstützen will, dann muss man beide Protokolle und auch teilweise doppeltes Packethandling implementieren. Das ist eine Arbeit von ein paar tausend Zeilen und ich habe schon gehört das Patches für 5000$ über den Tisch gegangen sind. :D
     
    #7
  8. Living-Bots
    Offline

    Living-Bots Verifiziert

    Registriert seit:
    7. Januar 2013
    Beiträge:
    364
    Ort:
    Bremen
    Minecraft:
    NickPicks
    Also für 5000$ kann ich das auch auftreiben, glaube nur nicht dass das wirklich jemand bezahlt.
     
    #8
  9. Moehritz
    Offline

    Moehritz

    Registriert seit:
    3. Mai 2012
    Beiträge:
    54
    Minecraft:
    Moehritz
    Die Ammis zahlen da 5000$ für. Schau mal ins Spigotforum, wie viel da einem Developer für ein Plugin geboten wird.
     
    #9
  10. Living-Bots
    Offline

    Living-Bots Verifiziert

    Registriert seit:
    7. Januar 2013
    Beiträge:
    364
    Ort:
    Bremen
    Minecraft:
    NickPicks
    Auch gut, dannn werde ich das so mal weitergeben an jemanden, der das bereits für sich programmiert hat.
     
    #10
  11. ChunkNorris
    Offline

    ChunkNorris

    #11