Suche Permissions-Plugin für BungeeCord-Netzwerk

Dieses Thema im Forum "Server Plugins" wurde erstellt von CreeperMania, 15. Mai 2014.

  1. CreeperMania
    Offline

    CreeperMania

    Registriert seit:
    17. November 2013
    Beiträge:
    8
    Minecraft:
    CreeperManHD
    Hallo,
    ich suche ein Permissions-Plugin für BungeeCord, das globale Gruppen, aber Per-Server-Permissions unterstützt, also zum Beispiel so:
    Der Spieler xy ist im gesamten Netzwerk in der Gruppe VIP. Diese Gruppe hat auf dem Server "Lobby" die Permission "beispiel.fly", auf allen anderen Servern nicht. Man soll den Spieler mit einem Befehl promoten/demoten können. Diese Aktion wirkt sich dann auf das gesamte Netzwerk aus (innerhalb 5 Minuten zum Beispiel). Wäre mit MySQL ja möglich.

    Bisher habe ich versucht:
    Groupmanager - keine MySQL Unterstützung
    PEX - wird aus einem mir unbekannten Grund nach Server-Restart immer rot angezeigt

    Auch BungeePerms habe ich versucht: BungeePerms.jar in den plugins-Ordner von BungeeCord und BungeePermsBukkit.jar sowie BungeePermsBukkitBridge.jar in den plugins-Ordner eines Servers (soll später mit allen Servern funktionieren). Beim Start keine Fehlermeldungen, Umstellung auf MySQL hat auch perfekt funktioniert.
    Allerdings weiß ich nicht ob und wie Per-Server-Permissions funktionieren. Außerdem hatte man in der Gruppe Owner mit allen Permissions nur Rechte für BungeeCord und BungeePerms selbst, nicht für Bukkit.

    Kann mir jemand ein Plugin empfehlen oder mir mit BungeePerms weiterhelfen?
    MfG. CreeperMania
     
    #1
  2. Crazy_Marcel
    Offline

    Crazy_Marcel

    Registriert seit:
    29. Oktober 2013
    Beiträge:
    269
    Ort:
    Bayern
    Minecraft:
    Crazy_Marcel
    Poste mal Plugins und Serverlog wenn du PEX draufziehst
     
    #2
  3. CreeperMania
    Offline

    CreeperMania

    Registriert seit:
    17. November 2013
    Beiträge:
    8
    Minecraft:
    CreeperManHD
    Hier die Daten von einem einzelnen Server, auf dem das Problem besteht:

    Plugins: Citizens, TeleportSigns, WorldEdit, iConomy, CreeperMode (selber programmiert), PermissionsEx, Multiverse-Core, WorldGuard, Essentials, EssentialsProtect, WorldRegions, EssentialsSpawn, CraftBook, EssentialsChat, EssentialsAntiBuild

    Code (Text):
    1.  
    2. [19:18:51] [Server thread/INFO]: Starting minecraft server version 1.7.2
    3. [19:18:51] [Server thread/INFO]: Loading properties
    4. [19:18:51] [Server thread/INFO]: Default game type: SURVIVAL
    5. [19:18:51] [Server thread/INFO]: Generating keypair
    6. [19:18:51] [Server thread/INFO]: Starting Minecraft server on *:25567
    7. [19:18:52] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-1.7.2-R0.3-b3020jnks (MC: 1.7.2) (Implementing API version 1.7.2-R0.3)
    8. [19:18:52] [Thread-6/INFO]: ----- Bukkit Auto Updater -----
    9. [19:18:52] [Thread-6/INFO]: It appears that you're running a Beta Build, when you've specified in bukkit.yml that you prefer to run Recommended Builds.
    10. [19:18:52] [Thread-6/INFO]: If you would like to be kept informed about new Beta Build releases, it is recommended that you change 'preferred-channel' in your bukkit.yml to 'beta'.
    11. [19:18:52] [Thread-6/INFO]: With that set, you will be told whenever a new version is available for download, so that you can always keep up to date and secure with the latest fixes.
    12. [19:18:52] [Thread-6/INFO]: If you would like to disable this warning, simply set 'suggest-channels' to false in bukkit.yml.
    13. [19:18:52] [Thread-6/INFO]: ----- ------------------- -----
    14. [19:18:52] [Server thread/INFO]: DataSourcePool [TeleportSigns] autoCommit[false] transIsolation[SERIALIZABLE] min[2] max[20]
    15. [19:18:52] [Server thread/INFO]: SubClassFactory parent ClassLoader [org.bukkit.plugin.java.PluginClassLoader]
    16. [19:18:52] [Server thread/INFO]: Entities enhanced[0] subclassed[1]
    17. [19:18:52] [Server thread/INFO]: [Citizens] Loading Citizens v2.0.11-SNAPSHOT (build 1053)
    18. [19:18:52] [Server thread/INFO]: [TeleportSigns] Loading TeleportSigns v1.3.1-b74
    19. [19:18:52] [Server thread/INFO]: [WorldEdit] Loading WorldEdit v5.6.2
    20. [19:18:52] [Server thread/INFO]: [iConomy] Loading iConomy v7.0
    21. [19:18:52] [Server thread/INFO]: [CreeperMode] Loading CreeperMode v1.0
    22. [19:18:52] [Server thread/INFO]: [PermissionsEx] Loading PermissionsEx v1.21.4
    23. [19:18:52] [Server thread/WARN]: [PermissionsEx] This server is in offline mode. Unless this server is configured to integrate with a supported proxy (see http://dft.ba/-8ous), UUIDs *may not be stable*!
    24. [19:18:52] [Server thread/INFO]: [Multiverse-Core] Loading Multiverse-Core v2.4-b527
    25. [19:18:52] [Server thread/INFO]: [WorldGuard] Loading WorldGuard v5.9
    26. [19:18:52] [Server thread/INFO]: [Essentials] Loading Essentials v2.13.1
    27. [19:18:52] [Server thread/INFO]: [EssentialsProtect] Loading EssentialsProtect v2.13.1
    28. [19:18:52] [Server thread/INFO]: [WorldRegions] Loading WorldRegions v1.0.1
    29. [19:18:52] [Server thread/INFO]: [WorldRegions] Injected flags!
    30. [19:18:52] [Server thread/INFO]: [EssentialsSpawn] Loading EssentialsSpawn v2.13.1
    31. [19:18:52] [Server thread/INFO]: [CraftBook] Loading CraftBook v3.8-SNAPSHOT:3803-e037f90,master
    32. [19:18:52] [Server thread/INFO]: [EssentialsChat] Loading EssentialsChat v2.13.1
    33. [19:18:52] [Server thread/INFO]: [EssentialsAntiBuild] Loading EssentialsAntiBuild v2.13.1
    34. [19:18:53] [Server thread/WARN]: **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
    35. [19:18:53] [Server thread/WARN]: The server will make no attempt to authenticate usernames. Beware.
    36. [19:18:53] [Server thread/WARN]: While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    37. [19:18:53] [Server thread/WARN]: To change this, set "online-mode" to "true" in the server.properties file.
    38. [19:18:53] [Server thread/INFO]: Preparing level "Build"
    39. [19:18:53] [Server thread/INFO]: Preparing start region for level 0 (Seed: -7768034228240980632)
    40. [19:18:54] [Server thread/INFO]: Preparing spawn area: 74%
    41. [19:18:54] [Server thread/INFO]: [Citizens] Enabling Citizens v2.0.11-SNAPSHOT (build 1053)
    42. [19:18:54] [Server thread/ERROR]: [Citizens] Unable to find Rhino classes - javascript scripts won't see non-CraftBukkit classes
    43. [19:18:54] [Server thread/INFO]: [Citizens] Fehler bei der Economy-Integration. Wurde Vault aktiviert?
    44. [19:18:54] [Server thread/INFO]: [TeleportSigns] Enabling TeleportSigns v1.3.1-b74
    45. [19:18:54] [Server thread/INFO]: [WorldEdit] Enabling WorldEdit v5.6.2
    46. [19:18:54] [Server thread/INFO]: WEPIF: Using the Bukkit Permissions API.
    47. [19:18:54] [Server thread/INFO]: [iConomy] Enabling iConomy v7.0
    48. [19:18:54] [Server thread/INFO]: [iConomy - April Fools] Enabled (30 ms)
    49. [19:18:54] [Server thread/INFO]: [iConomy] Hello, I'm Nijikokun. Yes, this is an April Fools joke, but '/money top' was fixed! Enjoy :) - Rare Version!
    50. [19:18:54] [Thread-11/INFO]: [iConomy - April Fools] Purged accounts with default balance.
    51. [19:18:54] [Server thread/INFO]: [CreeperMode] Enabling CreeperMode v1.0
    52. [19:18:54] [Server thread/INFO]: [PermissionsEx] Enabling PermissionsEx v1.21.4
    53. [19:18:54] [Server thread/INFO]: [PermissionsEx] Initializing file backend
    54. [19:18:54] [Server thread/INFO]: [PermissionsEx] Permissions file successfully reloaded
    55. [19:18:54] [Server thread/ERROR]: [PermissionsEx] ============================================================================================
    56. [19:18:54] [Server thread/ERROR]: [PermissionsEx] As of version 1.21, PEX requires a version of Bukkit with UUID support to function (>1.7.5). Please download a non-UUID version of PermissionsEx to continue.
    57. [19:18:54] [Server thread/ERROR]: [PermissionsEx] Beginning reversion of potential invalid UUID conversion
    58. [19:18:54] [Server thread/ERROR]: [PermissionsEx] Reversion complete, disabling. Permissions will not work until downgrade is complete
    59. [19:18:54] [Server thread/ERROR]: [PermissionsEx] ============================================================================================
    60. [19:18:54] [Server thread/INFO]: [PermissionsEx] Disabling PermissionsEx v1.21.4
    61. [19:18:54] [Server thread/INFO]: WEPIF: Using the Bukkit Permissions API.
    62. [19:18:54] [Server thread/INFO]: WEPIF: Using the Bukkit Permissions API.
    63. [19:18:54] [Server thread/INFO]: [Multiverse-Core] Enabling Multiverse-Core v2.4-b527
    64. [19:18:54] [Server thread/INFO]: [Multiverse-Core] - Version 2.4-b527 (API v14) Enabled - By Rigby, fernferret, lithium3141 and main--
    65. [19:18:54] [Server thread/INFO]: [AllPay] - Version 10.0 - hooked into iConomy 6 for Multiverse-Core v2.4-b527
    66. [19:18:54] [Server thread/INFO]: [Multiverse-Core] Loading World & Settings - 'Build' - Env: NORMAL - Type: NORMAL & seed: -7768034228240980632
    67. [19:18:54] [Server thread/INFO]: [Multiverse-Core] 1 - World(s) loaded.
    68. [19:18:54] [Server thread/INFO]: [WorldGuard] Enabling WorldGuard v5.9
    69. [19:18:54] [Server thread/INFO]: [WorldGuard] (Build) TNT ignition is PERMITTED.
    70. [19:18:54] [Server thread/INFO]: [WorldGuard] (Build) Lighters are PERMITTED.
    71. [19:18:54] [Server thread/INFO]: [WorldGuard] (Build) Lava fire is blocked.
    72. [19:18:54] [Server thread/INFO]: [WorldGuard] (Build) Fire spread is UNRESTRICTED.
    73. [19:18:54] [Server thread/INFO]: [WorldGuard] Loaded configuration for world 'Build'
    74. [19:18:54] [Server thread/INFO]: [WorldGuard] 1 regions loaded for 'Build'
    75. [19:18:54] [Server thread/INFO]: [Essentials] Enabling Essentials v2.13.1
    76. [19:18:55] [Server thread/INFO]: Essentials: Using config file enhanced permissions.
    77. [19:18:55] [Server thread/INFO]: Permissions listed in as player-commands will be given to all users.
    78. [19:18:55] [Server thread/INFO]: [Essentials] Payment method found (iConomy version: 6)
    79. [19:18:55] [Server thread/INFO]: [EssentialsProtect] Enabling EssentialsProtect v2.13.1
    80. [19:18:55] [Server thread/INFO]: [WorldRegions] Enabling WorldRegions v1.0.1
    81. [19:18:55] [Server thread/INFO]: [EssentialsSpawn] Enabling EssentialsSpawn v2.13.1
    82. [19:18:55] [Server thread/INFO]: [CraftBook] Enabling CraftBook v3.8-SNAPSHOT:3803-e037f90,master
    83. [19:18:55] [Server thread/INFO]: [CraftBook] Loading persistent data from YAML!
    84. [19:18:55] [Server thread/INFO]: [CraftBook] Enumerating chunks for self-triggered components...
    85. [19:18:55] [Server thread/INFO]: [WorldEdit] Using external NmsBlock for this version: CBXNmsBlock_172
    86. [19:18:55] [Server thread/INFO]: [CraftBook] 625 chunk(s) for 1 world(s) processed (54ms elapsed)
    87. [19:18:56] [Server thread/INFO]: [CraftBook] CraftBook v3.8.9 is the latest version available, and the updatability of it is: NO_UPDATE. You currently have version CraftBook v3.8.9 installed.
    88. [19:18:56] [Server thread/INFO]: [EssentialsChat] Enabling EssentialsChat v2.13.1
    89. [19:18:56] [Server thread/INFO]: [EssentialsAntiBuild] Enabling EssentialsAntiBuild v2.13.1
    90. [19:18:56] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    91. [19:18:56] [Server thread/INFO]: Done (3.680s)! For help, type "help" or "?"
    92. [19:18:56] [Server thread/INFO]: [Citizens] 1 NPCs geladen.
    93. [19:18:57] [Server thread/WARN]: [CraftBook] §cWarning! You have no mechanics enabled, the plugin will appear to do nothing until a feature is enabled!
    94.  
    95.  
    Ich habe vorher gemerkt, dass das Problem am UUID-Support liegt und ich PEX downgraden müsste. Gibt es außer PEX noch eine Lösung (ich hab das Plugin noch nie richtig gemocht) oder unterstützt BungeePerms Per-World-Permissions (damit wäre das Problem auch gelöst -> Die Welt auf dem Lobby-Server heißt zum Beispiel statt world Lobby...)?
     
    #3
  4. Juliplayer00
    Offline

    Juliplayer00

    Registriert seit:
    30. November 2013
    Beiträge:
    56
    Minecraft:
    Juliplayer00
    Hey, ich hab genau das gleiche Problem wie du auch. Hab auch schon so ziemlich alles probiert, nix hat so richtig funktioniert...
     
    #4
  5. [Dev] iTzSasukeHDxLP
    Offline

    [Dev] iTzSasukeHDxLP Ehem. Teammitglied

    Registriert seit:
    5. Januar 2014
    Beiträge:
    938
    HTML:
    1. [19:18:54] [Server thread/ERROR]: [PermissionsEx] As of version 1.21, PEX requires a version of Bukkit with UUID support to function (>1.7.5). Please download a non-UUID version of PermissionsEx to continue.[19:18:54] [Server thread/ERROR]: [PermissionsEx] Beginning reversion of potential invalid UUID conversion [19:18:54] [Server thread/ERROR]: [PermissionsEx] Reversion complete, disabling. Permissions will not work until downgrade is complete
     
    #5
  6. CreeperMania
    Offline

    CreeperMania

    Registriert seit:
    17. November 2013
    Beiträge:
    8
    Minecraft:
    CreeperManHD
    Die Lösung für PEX: auf Version 1.20.4 downgraden, da alle zukünftigeren Versionen schon auf UUID (für "Namechanges") umgestellt sind.
    Aber da ich nach einer Alternative zu PEX (siehe 1. Beitrag) suche, nützt mir das nichts.
     
    #6
  7. brainscript
    Offline

    brainscript

    Registriert seit:
    18. Juni 2015
    Beiträge:
    1
    Minecraft:
    brainscript
    @CreeperMania Die Antwort kommt jetzt etwas spät, aber die BungeePerms.jar musst du in den BungeeCord UND den Bukkit-Plugins-Ordner legen. Die BungeePermsBukkit-Datei existiert in neueren Versionen nicht mehr. Falls du immer noch Probleme hast, melde diese bitte auf GitHub.
     
    #7
  8. Malfrador
    Offline

    Malfrador

    Registriert seit:
    16. Juni 2013
    Beiträge:
    408
    Minecraft:
    Malfrador
    Eine eventuell sinnvollere Lösung wäre den Server zu updaten. Entweder auf 1.8, oder solltest du das nicht wollen (warum auch immer), auf 1.7.10. Das ist in fast allen Fällen deutlich sinnvoller.

    Alle deine Plugins dürften mit 1.8 funktionieren, nur das selbstgeschriebene müsstest du wohl updaten.
    iConomy könnte nicht mehr gehen, da gibt es aber gute Alternativen die auch einen Import der iConomy-Daten erlauben.
     
    #8
  9. crafterjuli
    Offline

    crafterjuli

    Registriert seit:
    8. Mai 2015
    Beiträge:
    9
    Minecraft:
    crafterjuli
    Es gibt noch das kostenlose Plugin BungeePerms. Hat eine schöne Gastaltung und funktioniert pefekt! Um den Prefix im Chat anzuzeigen musst du noch Vault + VaultChat auf jedem Server haben.

    MfG,

    crafterjuli
     
    #9
  10. CreeperMania
    Offline

    CreeperMania

    Registriert seit:
    17. November 2013
    Beiträge:
    8
    Minecraft:
    CreeperManHD
    Danke für die ganzen Antworten, aber das Problem hat sich schon lange erledigt.
    Der Server ist jetzt natürlich 1.8, als ich die Frage gestellt habe, waren noch alle Server auf 1.7.2.
     
    #10
    Malfrador gefällt das.