ServerPlugin Unsupported major.minor version 52.0 [Problem gelöst]

Dieses Thema im Forum "Programmierung" wurde erstellt von Payno4, 20. Juni 2015.

  1. Payno4
    Offline

    Payno4

    Registriert seit:
    12. Februar 2015
    Beiträge:
    117
    Hei Community ,

    Ich bin noch relativ neu in der Java Programmierer Szene und hab eine Frage zu einem Fehler der mir immer angezeigt wird .

    Code (Text):
    1.  
    2. org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: basics/main/main : Unsupported major.minor version 52.0
    3. [14:26:27] [Server thread/WARN]:     at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135)
    4. [14:26:27] [Server thread/WARN]:     at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329)
    5. [14:26:27] [Server thread/WARN]:     at co.technius.PluginManager.PluginControl.loadPlugin(PluginControl.java:209)
    6. [14:26:27] [Server thread/WARN]:     at co.technius.PluginManager.PMCommandExecutor.loadCmd(PMCommandExecutor.java:396)
    7. [14:26:27] [Server thread/WARN]:     at co.technius.PluginManager.PMCommandExecutor.onCommand(PMCommandExecutor.java:167)
    8. [14:26:27] [Server thread/WARN]:     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    9. [14:26:27] [Server thread/WARN]:     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141)
    10. [14:26:27] [Server thread/WARN]:     at org.bukkit.craftbukkit.v1_8_R2.CraftServer.dispatchCommand(CraftServer.java:646)
    11. [14:26:27] [Server thread/WARN]:     at net.minecraft.server.v1_8_R2.PlayerConnection.handleCommand(PlayerConnection.java:1139)
    12. [14:26:27] [Server thread/WARN]:     at net.minecraft.server.v1_8_R2.PlayerConnection.a(PlayerConnection.java:974)
    13. [14:26:27] [Server thread/WARN]:     at net.minecraft.server.v1_8_R2.PacketPlayInChat.a(PacketPlayInChat.java:45)
    14. [14:26:27] [Server thread/WARN]:     at net.minecraft.server.v1_8_R2.PacketPlayInChat.a(PacketPlayInChat.java:1)
    15. [14:26:27] [Server thread/WARN]:     at net.minecraft.server.v1_8_R2.PlayerConnectionUtils$1.run(SourceFile:13)
    16. [14:26:27] [Server thread/WARN]:     at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
    17. [14:26:27] [Server thread/WARN]:     at java.util.concurrent.FutureTask.run(FutureTask.java:262)
    18. [14:26:27] [Server thread/WARN]:     at net.minecraft.server.v1_8_R2.SystemUtils.a(SourceFile:60)
    19. [14:26:27] [Server thread/WARN]:     at net.minecraft.server.v1_8_R2.MinecraftServer.A(MinecraftServer.java:712)
    20. [14:26:27] [Server thread/WARN]:     at net.minecraft.server.v1_8_R2.DedicatedServer.A(DedicatedServer.java:368)
    21. [14:26:27] [Server thread/WARN]:     at net.minecraft.server.v1_8_R2.MinecraftServer.z(MinecraftServer.java:651)
    22. [14:26:27] [Server thread/WARN]:     at net.minecraft.server.v1_8_R2.MinecraftServer.run(MinecraftServer.java:554)
    23. [14:26:27] [Server thread/WARN]:     at java.lang.Thread.run(Thread.java:745)
    24. [14:26:27] [Server thread/WARN]: Caused by: java.lang.UnsupportedClassVersionError: basics/main/main : Unsupported major.minor version 52.0
    25. [14:26:27] [Server thread/WARN]:     at java.lang.ClassLoader.defineClass1(Native Method)
    26. [14:26:27] [Server thread/WARN]:     at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
    27. [14:26:27] [Server thread/WARN]:     at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    28. [14:26:27] [Server thread/WARN]:     at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
    29. [14:26:27] [Server thread/WARN]:     at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
    30. [14:26:27] [Server thread/WARN]:     at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
    31. [14:26:27] [Server thread/WARN]:     at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    32. [14:26:27] [Server thread/WARN]:     at java.security.AccessController.doPrivileged(Native Method)
    33. [14:26:27] [Server thread/WARN]:     at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
    34. [14:26:27] [Server thread/WARN]:     at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101)
    35. [14:26:27] [Server thread/WARN]:     at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86)
    36. [14:26:27] [Server thread/WARN]:     at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    37. [14:26:27] [Server thread/WARN]:     at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    38. [14:26:27] [Server thread/WARN]:     at java.lang.Class.forName0(Native Method)
    39. [14:26:27] [Server thread/WARN]:     at java.lang.Class.forName(Class.java:274)
    40. [14:26:27] [Server thread/WARN]:     at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64)
    41. [14:26:27] [Server thread/WARN]:     at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131)
    42. [14:26:27] [Server thread/WARN]:     ... 20 more
    43.  
    44.  
    Das passiert immer , wenn ich das Plugin aktivieren möchte . Wie behebe ich den Fehler ?

    Weitere Infos :
    JavaSE : 1.8
    Spigot : 1.8.3
    Compiler : 1.8

    Mit freundlichen Grüßen

    julian weber :)
     
    #1
  2. Kurlux
    Online

    Kurlux Moderator Redakteur

    Registriert seit:
    7. Juni 2015
    Beiträge:
    324
    Ort:
    Bayern
    Minecraft:
    Kurlux
    Hast du evtl auf deinem PC noch ältere Versionen von Java? die könntest du mal löschen.
     
    #2
  3. Malfrador
    Offline

    Malfrador

    Registriert seit:
    16. Juni 2013
    Beiträge:
    408
    Minecraft:
    Malfrador
    Ich nehme an das du das Plugin mit Java 8 erstellt hast, der Server aber nur mit Version 7 läuft. Zumindest war es das Problem bei mir ;)
     
    #3
  4. LoganBwDE
    Offline

    LoganBwDE

    Registriert seit:
    26. November 2014
    Beiträge:
    184
    Ort:
    Abtsgmünd
    Minecraft:
    LoganBwDE
    Normalerweise sagt dieser Fehler, dass deine Java Version inkompatibel mit der deines Servers ist. Eine Lösung des Problems wäre, das Plugin mit Java 7 zu kompalieren.
     
    #4
  5. Payno4
    Offline

    Payno4

    Registriert seit:
    12. Februar 2015
    Beiträge:
    117
    Danke an alle :) Ihr hattet recht , ich hab nicht beachtet , dass mein V-Server noch auf 1.7 läuft xD
     
    #5