Viele Plugins funktionieren nicht

Dieses Thema im Forum "Technischer Support" wurde erstellt von fabigamer235, 1. Februar 2015.

  1. fabigamer235
    Online

    fabigamer235

    Hallo,
    seit einem Anbieterwechsel zu mc-host24.de funktionieren warum auch immer viele Plugins nicht.
    Bis jetzt sind mir aufgefallen:
    - PvP 1vs1
    - CoreProtect
    - CustomJoinMessage

    Sie sind zwar installiert aber funktionieren nicht. Bei 1vs1 spawnt man nach dem Sterben nicht mehr in der Arena sondern am Hauptspawn, habe aber alle Dateien ja vom letzten Anbieter rüberkopiert.
    Bei CoreProtect sagt er ganze Zeit "No Data found", obwohl ich einen Block testweise entfernt habe. Auf meinem Testserver funktionierts.
    Bei CustomJoinMessage zeigt er nur die "default"-messages, nicht die bei "users". Auch dies funktioniert aber auf dem Testserver.
    Warum geht das aber nicht? Auch der neue Server läuft mit 1.7.9 ...

    Log: http://pastebin.com/4e6qZhSH

    Danke schonmal für Hilfen!
     
    #1
  2. Heikosservertutorials
    Offline

    Heikosservertutorials

    Registriert seit:
    27. Januar 2015
    Beiträge:
    57
    Ort:
    Deutschland
    Minecraft:
    HST_Tutorials
    Also mal abgesehen davon, dass ich nicht empfehlen kann, den Server auf Cracked zu stellen, ist eigentlich nur CoreProtect verhindert. Der Rest scheint zu laufen. ;) Nimm doch mal eine Frühere Version von Core-Protect (hier). Vielleicht funktioniert es damit.
    Bei CustomJoin Message wäre es praktisch deine Config zu sehen, um den Fehler zu rekonstruieren. ;) Gleiches gilt für PvP 1v1. Außerdem wäre es nicht schlecht, wenn du dich selber ein wenig mit dem Thema beschäftigen würdest und nicht immer uns um Hilfe fragst. Das ist jetzt nicht böse gemeint, aber die halbe erste Seite des Server-Supports ist mit deinen Threads voll.
    Denke doch einmal darüber nach. :)

    Mit lieben Grüßen

    Heiko l Heikosservertutorials
     
    #2
    Eisphoenix gefällt das.
  3. Vinnie
    Offline

    Vinnie

    Registriert seit:
    28. Juni 2014
    Beiträge:
    264
    Minecraft:
    Vinnie
    Heyho,
    wegen Coreprotect, die Version wird scheinbar nicht richtig geladen. Entweder sie ist zu alt oder nicht mehr kompatibel mit 1.7.9. Solltest du noch mal nachforschen, welche Version du gedownloadet hast und die Bemerkung vom Entwickler dazu durchlesen.

    Code (Text):
    1. [11:07:18] [Server thread/ERROR]: Error occurred while enabling CoreProtect v2.10.0 (Is it up to date?)
    2. java.lang.NoSuchMethodError: org.bukkit.Server.getOnlinePlayers()Ljava/util/Collection;
    3.         at net.coreprotect.model.Config.checkPlayers(Config.java:924) ~[?:?]
    4.         at net.coreprotect.model.Config.finishStartup(Config.java:979) ~[?:?]
    5.         at net.coreprotect.model.Config.init(Config.java:968) ~[?:?]
    6.         at net.coreprotect.CoreProtect.onEnable(CoreProtect.java:46) ~[?:?]
    7.         at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:316) ~[spigot1-7-9.jar:git-Spigot-1495]
    8.         at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:324) [spigot1-7-9.jar:git-Spigot-1495]
    9.         at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot1-7-9.jar:git-Spigot-1495]
    10.         at org.bukkit.craftbukkit.v1_7_R3.CraftServer.loadPlugin(CraftServer.java:465) [spigot1-7-9.jar:git-Spigot-1495]
    11.         at org.bukkit.craftbukkit.v1_7_R3.CraftServer.enablePlugins(CraftServer.java:383) [spigot1-7-9.jar:git-Spigot-1495]
    12.         at net.minecraft.server.v1_7_R3.MinecraftServer.n(MinecraftServer.java:359) [spigot1-7-9.jar:git-Spigot-1495]
    13.         at net.minecraft.server.v1_7_R3.MinecraftServer.g(MinecraftServer.java:333) [spigot1-7-9.jar:git-Spigot-1495]
    14.         at net.minecraft.server.v1_7_R3.MinecraftServer.a(MinecraftServer.java:289) [spigot1-7-9.jar:git-Spigot-1495]
    15.         at net.minecraft.server.v1_7_R3.DedicatedServer.init(DedicatedServer.java:193) [spigot1-7-9.jar:git-Spigot-1495]
    16.         at net.minecraft.server.v1_7_R3.MinecraftServer.run(MinecraftServer.java:457) [spigot1-7-9.jar:git-Spigot-1495]
    17.         at net.minecraft.server.v1_7_R3.ThreadServerApplication.run(SourceFile:628) [spigot1-7-9.jar:git-Spigot-1495]
    Dazu gibt es noch viele viele weitere Fehler in deinem LOG, bitte nehmen dir die Zeit und les ihn dir durch! Sie sind nicht zu übersehen.

    MfG

    Vinnie aka Dakvain
     
    #3
  4. Heikosservertutorials
    Offline

    Heikosservertutorials

    Registriert seit:
    27. Januar 2015
    Beiträge:
    57
    Ort:
    Deutschland
    Minecraft:
    HST_Tutorials
    Da kann ich @Dakvain nur zustimmen. Besonders bei deiner Lottery-Config solltest du noch einmal ordentlich was überarbeiten. Das Teil trieft nur von Fehlern. ;) Trotzdem scheint Core-Protect auf der neuesten Version zu sein, da es ja die 2.10.0 ist. Das ist definitiv die neuste. :)
     
    #4
  5. Vinnie
    Offline

    Vinnie

    Registriert seit:
    28. Juni 2014
    Beiträge:
    264
    Minecraft:
    Vinnie
    @Heikosservertutorials
    Ja, die neuste Version scheint es zu sein, ist sie denn aber noch mit der 1.7.9 Kompatibel? Denke nämlich nicht. :)

    @FireFlyer99
    Versuche es einfach mal mit ner älterern Version cp ^^
     
    #5
  6. Heikosservertutorials
    Offline

    Heikosservertutorials

    Registriert seit:
    27. Januar 2015
    Beiträge:
    57
    Ort:
    Deutschland
    Minecraft:
    HST_Tutorials
    Ich hab jetzt die Fehlerlösung für dein Core-Protect Problem gefunden. :) Das Plugin funktioniert mit der 1.7.9 nicht. Upgrade doch einfach auf die 1.7.10 und dann müsste alles funktionieren. :)
     
    #6
  7. fabigamer235
    Online

    fabigamer235

    Alte Version ging auch nicht von CP, hab mich jetzt dann mal uzu LogBlock entschieden.

    Config von CustomJoinMessage: http://pastebin.com/HF8hePjq

    Von 1vs1: http://pastebin.com/cBAFzvYY
    Aber da ist doch keine Database notwendig oder? Habe da auch beim alten Server nichts eingetragen und es ging so (gleiche config).
     
    #7
  8. Heikosservertutorials
    Offline

    Heikosservertutorials

    Registriert seit:
    27. Januar 2015
    Beiträge:
    57
    Ort:
    Deutschland
    Minecraft:
    HST_Tutorials
    Wieso hast du auch für verschiedene User diese Join-Nachrichten? Die sind doch alle gleich. Trage am besten bei default die gewünschten Nachrichten ein. ;)
    Bei 1v1 musst du nur die Spawns noch einmal festlegen, da er die beim kopieren wohl nicht richtig übertragen hat. :)

    Mit lieben Grüßen

    Heiko l Heikosservertutorials
     
    #8
  9. PyroFZ
    Offline

    PyroFZ

    Registriert seit:
    22. Januar 2013
    Beiträge:
    81
    Minecraft:
    PyroFZ
    CoreProtect 2.10 läuft auf der 1.7.9 nur sollte man die letzte Spigot für 1.7.9 nehmen. Das wäre snapshot 1543
     
    #9
  10. Majoox
    Offline

    Majoox

    Registriert seit:
    6. Mai 2014
    Beiträge:
    833
    Ort:
    Deutschland
    Minecraft:
    Majoox
    Code (Text):
    1. [11:07:17] [Thread-11/WARN]: [PermissionsEx] An update to PermissionsEx version 1.23.1 is available to download from http://dev.bukkit.org/bukkit-plugins/permissionsex/. Please review the changes and update as soon as possible!
    Update doch endlich mal dein PermissionsEx, das ist locker schon seit 152 Threads von dir unaktuell.

    Code (Text):
    1. Error occurred while enabling CoreProtect v2.10.0 (Is it up to date?)
    2. java.lang.NoSuchMethodError: org.bukkit.Server.getOnlinePlayers()Ljava/util/Collection;
    3.         at net.coreprotect.model.Config.checkPlayers(Config.java:924) ~[?:?]
    4.         at net.coreprotect.model.Config.finishStartup(Config.java:979) ~[?:?]
    5.         at net.coreprotect.model.Config.init(Config.java:968) ~[?:?]
    6.         at net.coreprotect.CoreProtect.onEnable(CoreProtect.java:46) ~[?:?]
    7.         at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:316) ~[spigot1-7-9.jar:git-Spigot-1495]
    8.         at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:324) [spigot1-7-9.jar:git-Spigot-1495]
    9.         at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot1-7-9.jar:git-Spigot-1495]
    10.         at org.bukkit.craftbukkit.v1_7_R3.CraftServer.loadPlugin(CraftServer.java:465) [spigot1-7-9.jar:git-Spigot-1495]
    11.         at org.bukkit.craftbukkit.v1_7_R3.CraftServer.enablePlugins(CraftServer.java:383) [spigot1-7-9.jar:git-Spigot-1495]
    12.         at net.minecraft.server.v1_7_R3.MinecraftServer.n(MinecraftServer.java:359) [spigot1-7-9.jar:git-Spigot-1495]
    13.         at net.minecraft.server.v1_7_R3.MinecraftServer.g(MinecraftServer.java:333) [spigot1-7-9.jar:git-Spigot-1495]
    14.         at net.minecraft.server.v1_7_R3.MinecraftServer.a(MinecraftServer.java:289) [spigot1-7-9.jar:git-Spigot-1495]
    15.         at net.minecraft.server.v1_7_R3.DedicatedServer.init(DedicatedServer.java:193) [spigot1-7-9.jar:git-Spigot-1495]
    16.         at net.minecraft.server.v1_7_R3.MinecraftServer.run(MinecraftServer.java:457) [spigot1-7-9.jar:git-Spigot-1495]
    17.         at net.minecraft.server.v1_7_R3.ThreadServerApplication.run(SourceFile:628) [spigot1-7-9.jar:git-Spigot-1495]
    Updaten.

    Code (Text):
    1. [11:07:18] [Server thread/INFO]: [MinecraftLottery] There is a new update for MinecraftLottery!
    2. [11:07:18] [Server thread/INFO]: [MinecraftLottery] Download it here http://servermods.cursecdn.com/files/777/940/MinecraftLottery-v1.2.2.jar
    Updaten.

    Code (Text):
    1. Cannot load plugins/MinecraftLottery/config.yml
    2. org.bukkit.configuration.InvalidConfigurationException: while scanning an anchor
    3. in 'string', line 30, column 14:
    4.       broadcast: &8[&eJiChraft&8]&r %PLAYER% hat  ...
    5.                  ^
    6. expected alphabetic or numeric character, but found [(91)
    7. in 'string', line 30, column 16:
    8.       broadcast: &8[&eJiChraft&8]&r %PLAYER% hat in ...
    Deine Config von MinecraftLottery bitte. Da ist ein ungültiges Zeichen, das du entfernen solltest.

    Code (Text):
    1. [11:07:18] [Server thread/WARN]: [MinecraftLottery] Please first remove the old config called 'database_old.sqlite', and then restart the server.
    Diese Datei löschen.

    Code (Text):
    1. [11:07:39] [Server thread/INFO]: Chunk coordinates: 32,-2336
    2. [11:07:41] [Server thread/INFO]: Chunk coordinates: 688,144
    3. [11:07:41] [Server thread/INFO]: Chunk coordinates: 736,96
    Dann sind hier auch noch haufenweise Chunks kaputt, die du mit einem Chunkfix korrigieren kannst. Ansonsten teleportierst du dich mal zu den Koordinaten und suchst selber nach dem Problem. Unsichtbare Blöcke, zu viele Tiere, zu viele Items usw.

    Korrigiere bitte diese Fehler bzw. update endlich deine Plugins! So macht es keinen Sinn dir zu helfen, da es so viele andere Fehler gibt, die eventuell auch daran Schuld sein können, wieso so viele Plugins nicht laufen...

    Bitte auch die Configs von den jeweiligen Plugins die nicht laufen. Gff. kannst du auch mal Hand angreifen und deine Configs einfach mal zurücksetzen. Läuft denn keines der Plugins mehr seit dem du was an der Config gemacht hast? Wird bei dir (sofern du Notepad++ benutzt) irgendetwas rot angezeigt?
     
    #10
    Eisphoenix, MeeriSchatz und Vinnie gefällt das.