ServerPlugin VoteEP (Votesystem)

Dieses Thema im Forum "Selbstgeschriebene Plugins | Mods | Programme" wurde erstellt von Nacktschicht, 16. November 2012.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Nacktschicht
    Offline

    Nacktschicht

    Moin Leute,

    hobibi und ich haben ein Plugin entwickelt, was eine Hilfe zum Voten ist. Sobald man den Befehl /vote eingibt, erscheint eine Hilfe zum Voten, inklusiv Link. Das Plugin gibt es zwar schon, wir haben jedoch eine Deutsche Version entwickelt (Eventuell wurde sogar schon eine veröffentlicht, wir haben das Plugin schon vor fast 2 Monaten entwickelt)

    Geschichte:

    Nachdem wir, vorallem durch jüngere User genervt waren, da diese absolut nicht gepeilt haben, wie man Votet, haben wir das Plugin entwickelt. Es erspart uns viel Erklärarbeit :)

    Commands:


    /vote - zeigt die Hilfe an

    Permissions:

    voteep.help - Hauptpermission (/vote)

    Versionen:
    Die Normale Version v1.1: Download
    Die U14 Version (für die Jüngeren unter uns :p) v1.0: Download

    Bekannte Bugs:


    • #1 Link arbeitet bisher nur sporadisch

    Behobene Bugs:


    • bisher noch keine (wie denn auch) :)

    In der Zukunft:


    • Eigener Listener, der in einer Datenbank abspeichert, wann jemand gevotet hat
    • Beim Joinen auf den jeweiligen Server wird man hingewiesen, falls man noch nicht gevotet hat
    • Listener verteilt zusätzlich Items
    • weitere Ideen? Schreibt ein Kommentar! :)

    Versionsgeschichte:


    • v1.0 16/11/2012 Release
    • v1.1 22/11/2012 Permissions implementiert - 1.4.5 Support

    Alte Versionen:

    v1.0: Download


    Viel Spaß und mehr Ruhe in der Zukunft,

    Nacktschicht // Thomas und hobibi // Dominik

    PS: Fehler/Bug gefunden? Bitte PN an Nacktschicht oder Email an thepluginproject@mc-url.de
     
    #1
  2. Cyxm
    Offline

    Cyxm

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    87
    Ort:
    Dresden
    Super wird gleich mal test weise installiert und ich gebe feedback :)
     
    #2
  3. hobibi
    Offline

    hobibi

    Registriert seit:
    21. November 2011
    Beiträge:
    59
    Minecraft:
    Hobibi
    Danke wen ihr uns ein Feedback gebt. Somit können wir dann auch Funktionen Verbessern oder Hinzufügen :)
     
    #3
  4. Es wäre mal schön Source zu haben oder wenigstens mal den unterschied der beiden Plugins erklären.
     
    #4
  5. Nacktschicht
    Offline

    Nacktschicht

    Die beiden Plugins unterscheiden sich im Text, der angezeigt wird. (Ist ein kleiner aber netter Unterschied)
    Source werden wir noch hochladen :)
     
    #5
  6. Ich würde euch ja eine Arbeit mit Github empfehlen, ist wirklich ziemlich praktisch für OpenSource. Ihr solltet außerdem ne /vote Permission reinbringen, man weiß ja nie :D
     
    #6
  7. Nacktschicht
    Offline

    Nacktschicht

    In Arbeit. Kommt in die v1.1. Github bin ich schon registriert, muss nur noch Uploaden :)
     
    #7
  8. Lexuland
    Offline

    Lexuland

    Registriert seit:
    1. Mai 2012
    Beiträge:
    5
    Bei mir erstellt sich kein Ordner in PLugins.

    Hallo,

    bei mir erstellt sich kein Ordner in PLugins mit der Conf. und wenn ich im Server /plugins eingebe kommt auch nichts raus von diesem Plugin.
    Was kann ich tun. Ich habe 1.4.4 Craftbukkit
     
    #8
  9. MrFlieder
    Offline

    MrFlieder

    Registriert seit:
    30. Dezember 2011
    Beiträge:
    333
    Ort:
    Österreich
    Minecraft:
    MrFlieder
    Dann kommt garantiert eine Fehlermeldung in der Console, weshalb das Plugin nicht geladen werden konnte.

    Es würde uns helfen, wenn du diese bekanntgibst :)
     
    #9
  10. Lexuland
    Offline

    Lexuland

    Registriert seit:
    1. Mai 2012
    Beiträge:
    5
    Ja! Da steht in meinem LOG:

    2012-11-22 00:30:05 [SEVERE] Could not load 'plugins/voteep_german_v1.0_u14 .jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/hobibi/voteep/Vote : Unsupported major.minor version 51.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:154)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:305)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:230)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:227)
    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:205)
    at net.minecraft.server.ServerConfigurationManagerAbstract.<init>(ServerConfigurationManagerAbstract.java:51)
    at net.minecraft.server.ServerConfigurationManager.<init>(SourceFile:11)
    at net.minecraft.server.DedicatedServer.init(DedicatedServer.java:111)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:398)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:856)
    Caused by: java.lang.UnsupportedClassVersionError: me/hobibi/voteep/Vote : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:44)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:334)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:264)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:143)
    ... 9 more
     
    #10
  11. Pappi
    Offline

    Pappi Gesperrt

    Registriert seit:
    28. Oktober 2012
    Beiträge:
    141
    Ort:
    H.a.S/NRW/Germany
    Minecraft:
    Pappi / PapaHarni
    Bitte benutze Java JRE 1.7 , Das ist die Typische Fehlermeldung für Java JRE 1.6 und kleiner. Also einfach Java aktualisieren.


    Erkennbar an dieser Log aussage :
    Diese Meldung spuckt jedes Plugin aus welches unter Java 1.7 Compiliert wurde und versucht wird mit Java 1.6 auszuführen.
     
    #11
  12. Lexuland
    Offline

    Lexuland

    Registriert seit:
    1. Mai 2012
    Beiträge:
    5
    Hallo,

    ich habe ein vServer und (Betriebsystem) Debian aber ich kriege da nicht JAVA 7 installiert.

    Ich kann leider kein anderes Betriebsystem installieren
     
    #12
  13. Benni1000
    Offline

    Benni1000 Ehem. Teammitglied

    Registriert seit:
    4. Mai 2012
    Beiträge:
    1.408
    Man kann auf debian problemlos Java7 installieren, wo liegt denn das Problem?
     
    #13
  14. Nacktschicht
    Offline

    Nacktschicht

    sudo apt-get install oracle-java7-installer
     
    #14
  15. Benni1000
    Offline

    Benni1000 Ehem. Teammitglied

    Registriert seit:
    4. Mai 2012
    Beiträge:
    1.408
    Das funktioniert nur wenn du die richtigen Repositories hinzufügst.
    Lade es einfach direkt von Oracle runter.
     
    #15
  16. Nacktschicht
    Offline

    Nacktschicht

    Das war ja nur mal der Befehl wie man das installiert ;) Natürlich kann man es auch auf die Gute Alte Variante laden, ich finde aber dass die Installation, vorallem wenn man keine grafische Oberfläche hat.
     
    #16
  17. Nacktschicht
    Offline

    Nacktschicht

    Update auf v1.1:

    Permissionssupport!
     
    #17
  18. Lexuland
    Offline

    Lexuland

    Registriert seit:
    1. Mai 2012
    Beiträge:
    5
    Der Befehl:

    sudo apt-get install oracle-java7-installer​



    geht nicht.
     
    #18
  19. Benni1000
    Offline

    Benni1000 Ehem. Teammitglied

    Registriert seit:
    4. Mai 2012
    Beiträge:
    1.408
    Hast du die benötigten repositories hinzugefügt und die packetliste neu geladen?
     
    #19
  20. Nacktschicht
    Offline

    Nacktschicht

    Closed. Entwicklung aus Zeitgründen vorerst eingestellt.
     
    #20
Status des Themas:
Es sind keine weiteren Antworten möglich.