• Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

Erledigt Voxelsniper startet nicht

Maxim0509

Kuhfänger
Registriert
14 Juli 2017
Beiträge
96
Diamanten
177
Hey,

ich hab derzeit das Problem, dass VoxelSniper nicht starten möchte. Im Log erhalte ich folgende Meldung:
Code:
[09:44:58] [Server thread/ERROR]: Could not load 'plugins/VoxelSniper-5.171.0-SNAPSHOT.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: javax/xml/bind/JAXBException
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:139) ~[spigot.jar:git-Spigot-1a3504a-84f3da3]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:332) ~[spigot.jar:git-Spigot-1a3504a-84f3da3]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:252) [spigot.jar:git-Spigot-1a3504a-84f3da3]
    at org.bukkit.craftbukkit.v1_13_R2.CraftServer.loadPlugins(CraftServer.java:325) [spigot.jar:git-Spigot-1a3504a-84f3da3]
    at net.minecraft.server.v1_13_R2.DedicatedServer.init(DedicatedServer.java:213) [spigot.jar:git-Spigot-1a3504a-84f3da3]
    at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:698) [spigot.jar:git-Spigot-1a3504a-84f3da3]
    at java.lang.Thread.run(Thread.java:834) [?:?]
Caused by: java.lang.NoClassDefFoundError: javax/xml/bind/JAXBException
    at java.lang.Class.forName0(Native Method) ~[?:?]
    at java.lang.Class.forName(Class.java:398) ~[?:?]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:60) ~[spigot.jar:git-Spigot-1a3504a-84f3da3]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot.jar:git-Spigot-1a3504a-84f3da3]
    ... 6 more
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.JAXBException
    at java.net.URLClassLoader.findClass(URLClassLoader.java:471) ~[?:?]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:136) ~[spigot.jar:git-Spigot-1a3504a-84f3da3]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:82) ~[spigot.jar:git-Spigot-1a3504a-84f3da3]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:589) ~[?:?]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:522) ~[?:?]
    at java.lang.Class.forName0(Native Method) ~[?:?]
    at java.lang.Class.forName(Class.java:398) ~[?:?]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:60) ~[spigot.jar:git-Spigot-1a3504a-84f3da3]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot.jar:git-Spigot-1a3504a-84f3da3]
    ... 6 more

Der Server läuft auf der 1.13.2. Derzeit sind folgende Plugins installiert: WorldGuard, WorldEdit, Vault, PlotSquared, Multiverse-Core, LuckPerms und Essentials.

Vielleicht kann ja jemand helfen.

Liebe Grüße
Maxim0509
 

SirYwell

PlotSquared Entwickler
Registriert
30 Juni 2017
Beiträge
540
Diamanten
338
Minecraft
SirYwell
Ich gehe mal stark davon aus, dass du eine Java-Version neuer als 8 hast. Wenn ja, ist das das Problem. Leider wird VS nicht mehr aktiv weiterentwickelt, bzw es gibt jede Menge Forks, die mehr oder minder aktiv betreut werden. Was da derzeit das beste ist, weiß ich allerdings nicht. Ich habe das hier auf Spigot gefunden und das hier auf Github.
 

Chrisliebär❤️

nur echt mit ❤️
Moderator
Registriert
19 Mai 2014
Beiträge
1.671
Diamanten
623
Wenn ich das richtig in Erinnerung habe, hast du einen 1.13. Server. Gibts dafür einen konkreten Grund oder wäre es nicht auch möglich auf eine Version zu wechseln, bei der du diese Probleme nicht hast? Generell ist es halt sowieso nicht so schlecht, wenn man irgendwann migriert, denn über die Zeit sammeln sich sonst sehr viele Altlasten an, und die Migration wird immer schwieriger. Einer der Gründe, warum so viele Server auf der 1.8 feststecken.
 

Malfrador

Threadripper
Registriert
16 Juni 2013
Beiträge
1.473
Diamanten
296
Minecraft
Malfrador
Die API-Änderungen mit der 1.16 waren nicht allzu groß, die meisten 1.15-Plugins sollten also inzwischen dort auch funktionieren.
Generell ist 1.16-Performance etwas besser als 1.15 und Paper wird in naher Zukunft wohl auch nur noch 1.16 entwickeln. Wenn die Auswahl also 1.15 oder 1.16 ist, macht in 99% 1.16 mehr Sinn.
 
Oben