WorldEdit (MC 1.5)

Dieses Thema im Forum "Technischer Support" wurde erstellt von Wolfi15, 15. März 2013.

  1. Wolfi15
    Offline

    Wolfi15

    Registriert seit:
    4. November 2011
    Beiträge:
    602
    Minecraft:
    Wolfi15
    Hey,
    Habe soeben meinen Server auf 1.5 geupdatet und alles funktioniert bis auf WorldEdit
    Er sagt mir jede Sekunde im Log ca. 20x diesen Fehler:
    "No compatible nms block class found."
    Hab danach gegoogelt aber keine Antwort gefunden.
    Weiß jemand was genaues darüber?
     
    #1
  2. games6471
    Online

    games6471

    Klar WorldEdit hat seine Blöcke fest einprogrammiert. Bei der neuen Version muss auch das Plugin geupdatet werden.

    Hier kannst du einen Beta-Build runterladen, wo dies gefixt ist.

    http://build.sk89q.com/job/WorldEdit/changes
     
    #2
  3. Cabraca
    Online

    Cabraca

    Genauere Infos gibt es hier: http://forums.bukkit.org/threads/safeguard-versioning-policy.123435/

    Kurz: Worldguard greift direkt auf eine Klasse zu die nach der Safeguard Policy mit version 1.4.7 gekennzeichnet ist.
    Die ist natürlich bei Version 1.5 jetzt mit 1.5.0 gekennzeichnet.
    Damit findet Worldguard die datei nicht mehr und wird deaktiviert.

    Dies wurde von Bukkit eingeführt damit es nicht mehr zu Problemen kommt bei denen veraltete Plugins die welten zerstören.
     
    #3
  4. Wolfi15
    Offline

    Wolfi15

    Registriert seit:
    4. November 2011
    Beiträge:
    602
    Minecraft:
    Wolfi15
    Das wusste ich auch nur hab kein Fix davon gefunden.
    Danke
     
    #4
  5. games6471
    Online

    games6471

    Hier von allen seinen Plugins. Es kann sein das manche Funktionen von Worldguard auch nicht funktionieren, aber die grundprotection sollte trotzdem funktionieren.

    http://build.sk89q.com/
     
    #5
  6. Cabraca
    Online

    Cabraca

    #6
  7. pvp-mc
    Offline

    pvp-mc

    Registriert seit:
    14. März 2013
    Beiträge:
    17
    Ort:
    www.pvp-mc.de
    du musst warten bis der entwickler das richtig updatet auf 1.5! bei mir laufen auch viele plugins nicht.
     
    #7