Worldgouard und PVP

Dieses Thema im Forum "Server Plugins" wurde erstellt von KungLaoHD, 9. Februar 2014.

  1. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    Also, ich habe eine MAP wo __global__ pvp erlaubt ist und das auch geht .

    Nun habe ich dort eine neue Arena gebaut, wo ich innerhalb der Arena Flächen so einstellen möchte, das man an manchen Stellen kein PVP hat.

    Ich habe versucht:

    /rg define pvpaus1 dann /rg flag pvpaus1 pvp deny

    doch mit /rg i find ich die Region nicht und pvp ist auch noch an.

    Bitte um Hilfe.
     
    #1
  2. DroggelBecherBW
    Offline

    DroggelBecherBW

    Registriert seit:
    7. Februar 2014
    Beiträge:
    3
    Zu erst Region makieren, dann /region define [Name] und dann /region flag [Name] pvp deny

    Wenn es geholfen hat
    Büdde
     
    #2
  3. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    geht nicht.

    Lies mal bitte was ich oben geschrieben habe. Das was du schreibst habe ich auch geschrieben und getestet und geht nicht.

    In Bukkit propperties PVP: true

    Komisch das in Region __global__ PVP geht nur eine neue Region erstellen mit PVP deny will nicht.
     
    #3
  4. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    Kann Niemand eine Tipp geben?

    habe in den server.propperties: allow-pvp: true und pvp: true

    In der Welt PVPARENA habe ich bei /region i: build: deny, Fly: deny, PvP: deny

    In der erstellten Region pvpan1 habe ich bei /region i: pvp: allow

    Trotz allem kann man den anderen User nicht schlagen bzw. töten da PVP nicht reagiert. Normalerweise sollte PVP doch in der erstellten region an sein. Ist komisch.

    Mit /region list werden mir beide Regionen (__global__) und (pvpan1) angezeigt.

    Trotzdem geht PVP nicht. Worldguard und Worldedit sind neuste für Bukkit 1.7.2 drauf.

    Muss das in Essentials auch auf true ?
    ---------------------------------------------------------------------------------------------------------------------------
    # Users with the essentials.protect.pvp permission will still be able to attack each other if this is set to true.
    # They will be unable to attack users without that same permission node.
    pvp: false
    ----------------------------------------------------------------------------------------------------------------------------

    Kann Niemand eine Tipp geben?
     
    #4
  5. neo2012
    Offline

    neo2012 Gesperrt

    Registriert seit:
    17. August 2011
    Beiträge:
    379
    Ort:
    An einem Ort weit weg von diesem Dreck
    Minecraft:
    bubbleblubbla
    Essentials ist nur relevant, wenn du essentialsprotect nutzt. Ggf solltest du mal bei multiverse in die worlds.yml gucken
     
    #5
  6. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    danke aber das habe ich bereits. bei den ganzen Welten steht pvp: true

    Habe /ungod eingegeben denke mal daran lag es denn nun gehts.

    kann geclosed werden das Ticket
     
    #6
  7. Fighter88
    Online

    Fighter88

    Priorität der Region

    das liegt an der priority der region __global__ glaub ich hat standart 0
    erstellst du eine neue Region ist die auch 0 also bei de regionen haben gleich viel zu sagen
    setz eine mit /region setpriority (RegionName) 2 <-----2= z.b könnte auch 5 oder 10 oder sowas sein
    um so höher um so mehr hat die region über andere die auch auf der stelle liegen zu sagen.
     
    #7
  8. neo2012
    Offline

    neo2012 Gesperrt

    Registriert seit:
    17. August 2011
    Beiträge:
    379
    Ort:
    An einem Ort weit weg von diesem Dreck
    Minecraft:
    bubbleblubbla
    Bullshit: __global__ -flags werden von jeder normalen Region überschrieben, eine priority oder auch einen parent zu setzen ist absoluter blödsinn. Worldguard hat eine globale und eine welt config, welche du vom Spiel aus nicht beeinflussen kannst. Gucke in den worldguard, der multiverse, den server-properties und falls du essential protect nutzt in der essentials config nach, ob dort irgendwo pvp disabled ist.
     
    #8
  9. Fighter88
    Online

    Fighter88

    Erstmal schön, dass du dich so würdelos zu Kommentaren äußerst.
    Aber nach der Probschilderung hat er in der Arena mehrere Regionen ("nur an manchen Stellen kein pvp").

    Also denk ich mal, wird er damit die Probs haben.
    Es könnte auch an Essentials oder an den server.properties liegen, natürlich aber auch an den configs von wg.
     
    #9
  10. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD

    Danke allen für eure Tipps aber das Problem lag woanders. Habe nur mal /ungod eingegeben und siehe da, nun geht es wieder mit PvP an und aus
     
    #10