WorldGuard Problem

Dieses Thema im Forum "Server Plugins" wurde erstellt von Basti07711, 7. November 2014.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Basti07711
    Offline

    Basti07711 Ehem. Teammitglied

    Registriert seit:
    2. August 2012
    Beiträge:
    714
    Ort:
    Hinter dir
    Minecraft:
    Basti07711
    Hi Leute,
    ich habe auf meinem Server den Usern verboten, wenn sie noch nicht freigeschaltet sind, die Spawn-Region nicht zu verlassen.
    Wie folgd habe ich es Protectet:
    1. Region makiert
    2. //expand vert
    3. /rg define <name>
    4. /rg flag <name> exit deny
    5. /rg addmembet <name> g:Neuling

    Wenn sich nun ein User in dieser Region freischaltet und los läuft, dann wird sein Chat mit der Nachricht zu gespammt, dass er die Region nicht verlassen darf.

    Wie kann ich das fixen?
     
    #1
  2. Kucki
    Offline

    Kucki

    Registriert seit:
    7. April 2014
    Beiträge:
    13
    Minecraft:
    Wisl3r
    Hallo!
    Dein Problem kann man nicht beheben, da die flag "exit" bei Worldguard nicht gruppenbasierend ist. Das heißt man kann sie nur auf allow, none oder deny stellen (http://wiki.sk89q.com/wiki/WorldGuard/Regions/Flags).

    Du kann das jedoch auch anders beheben, indem du dir das Plugin "Worldguard Region Commands" holt. Du erstellst um die Zone, in der die nicht freigeschalteten Spieler noch laufen können eine Region. Und dann stellst du bei dieser Flag (mit Hilfe des Plugins natürlich) einen Command ein, der bei Betreten der Region vom Spieler automatisch ausgeführt werden soll. Ich rate dir das mit /warp <...> zu machen.

    Link zum Plugin: http://dev.bukkit.org/server-mods/worldguard-region-commands/
     
    #2
    Trashi500 gefällt das.
  3. MrPyro13
    Offline

    MrPyro13

    Registriert seit:
    29. April 2013
    Beiträge:
    829
    Minecraft:
    MrPyro13
    Hallo,

    Das stimmt so nicht ganz! So wie das @Basti07711 gemacht hat, ist das schon richtig... (s.h. hier:
    (Selbst schon mit entry getestet und es funktioniert.

    zu @Basti07711
    - Hast du evtl. eine große Region, in der diese kleine Region enthalten ist? -> Dann: *klick*
    - ansonsten, wenn es nur ein Ausgang gibt, evtl eine Schicht-Region mit der flag entry deny
    - oder: eine andere Version
     
    #3
  4. Basti07711
    Offline

    Basti07711 Ehem. Teammitglied

    Registriert seit:
    2. August 2012
    Beiträge:
    714
    Ort:
    Hinter dir
    Minecraft:
    Basti07711
    Andere Version hab ich getestet, selbst da geht es nicht. Hab nun den spawn mit 4 Regionen umring statt eine große zu nehmen, das klappt perfekt ;)
     
    #4
Status des Themas:
Es sind keine weiteren Antworten möglich.