Problem Apache - .htacces

Dieses Thema im Forum "Offtopic" wurde erstellt von TimBone, 28. Juni 2013.

  1. TimBone
    Online

    TimBone

    Apache - .htaccess

    Hallo Community,
    ich habe ein Problem :( Ich habe mir einen gesicherten V-Server zum testen gemietet und spiele nun mit ihm rum. Ich wollte einfach nur ein Verzeichnis mit einer .htaccess sperren. Im Internet habe ich herausgefunden, dass man die .htacces in der apache2.conf freischalten muss.
    Das habe ich so versucht:
    Code (Text):
    1. Alias /www/ "/var/www"
    2.  
    3.     <Directory "/var/www">
    4.         AllowOverride All
    5.         Options All
    6.         Order allow,deny
    7.     </Directory>
    Dann habe ich in dem Verzeichnis /var/www eine .htaccess mit folgendem Inhalt angelegt (nur zum Testen):
    Code (Text):
    1. DENY FROM ALL
    Ich habe Apache schon mehrmals neu gestartet, aber nichts passiert.

    Kann mir jemand helfen?
     
    #1
  2. TimBone
    Online

    TimBone

    #push
    Kann mir keiner helfen? Im Internet finde ich nur das, was ich schon getan habe. Muss ich evtl. Noch etwas anderes einrichten?
     
    #2
  3. CraftAdmin
    Offline

    CraftAdmin

    Registriert seit:
    31. März 2012
    Beiträge:
    6
    Haste die Datei wirklich .htacces genannt? Wenn ja versuch es mal mit richtigem Namen also .htaccess (doppel s am ende!).
     
    #3
  4. TimBone
    Online

    TimBone

    Ja, ich habe es falsch geschrieben, daran lag es allerdings nicht :( -> D.h. Man kann weiterhin auf das Verzeichnis zugreifen.
     
    #4
  5. CraftAdmin
    Offline

    CraftAdmin

    Registriert seit:
    31. März 2012
    Beiträge:
    6
    2 Sachen fallen mir so auf anhieb ein die du kontrollieren könntest.

    1. ist irgendwo "AccessFileName" in der apache/httpd config hinterlegt? kann auch in einer Datei sein die includiert wird.
    2. kann die Datei von Apache überhaupt gelesen werden ? (z.B. testen mit chmod 555 .htaccess)

    Ich würde dir empfehlen aber noch mal mit grep zu gucken ob es irgendwo noch ein "AllowOverride none" gibt, sowie mal ins Error.log zu gucken ob da was steht.
     
    #5
  6. TimBone
    Online

    TimBone

    Erstmal danke für deine Hilfe :)
    1. Im Error.log steht nur, dass das FaveIcon nicht gefunden werden konnte :D
    2. Die .htaccess hat alle nötigen Rechte...
     
    #6
  7. CraftAdmin
    Offline

    CraftAdmin

    Registriert seit:
    31. März 2012
    Beiträge:
    6
    Und was ist mit dem "AccessFileName" ?

    Hast du mal versucht fehlerhafte Eintrage (z.B. abdssg) in die .htaccess zu schreiben ? das sollte wenn Apache die Datei einliest Fehler im log geben.
     
    #7
  8. TimBone
    Online

    TimBone

    AccessFileName ist .htaccess
     
    #8
  9. Hecke29
    Online

    Hecke29

    Was passiert, wenn du es direkt in der .conf verbietest?

    Code (Text):
    1.  
    2.     <Directory "/var/www">
    3.         AllowOverride All
    4.         Options All
    5.         Order deny,allow
    6.         deny from all
    7.     </Directory>
     
    #9
  10. TimBone
    Online

    TimBone

    Das Ganze hilft auch nichts :( Gibt es noch irgendeine Konfigurations Datei, die über dem ganzen steht?
     
    #10
  11. CraftAdmin
    Offline

    CraftAdmin

    Registriert seit:
    31. März 2012
    Beiträge:
    6
    Moin,

    Du hast immer noch nichts dazu gesagt was passiert wenn du falsche Anweisungen in die .htaccess Datei schreibst.

    Wichtig wäre evtl. auch noch ob das ein apache 2.2/2.3 ist oder ein Apache 2.4.

    Evtl. auch noch wichtig, gibt es eine VirtualHost Deklaration? Z.b. irgendwo ein include sites-enabled/*.conf ?
     
    #11
  12. oOFlaashOo
    Offline

    oOFlaashOo

    Registriert seit:
    3. Oktober 2012
    Beiträge:
    112
    Ort:
    /home
    Minecraft:
    oOFlaashOo
    Ich hatte das gleiche Problem vor nem halben Jahr, habe nie eine Lösung gefunden
     
    #12
  13. Drachie
    Offline

    Drachie

    Registriert seit:
    17. November 2012
    Beiträge:
    8
    Ort:
    Hamburg
    Minecraft:
    DrachieHH
    also... dein ersten eintrag denke ich mal ist aus der httpd.conf die kannst du so lassen.

    um ein verzeichnis zu sperren legst du IM zu sperrenden verzeichnis die datei .htaccess an und machst dort deine eintragungen
     
    #13
  14. TimBone
    Online

    TimBone

    Problem gelös,vielen Dank für eure Hilfe. Dashabe wurdein irgendeiner SecurityDatei überschriebenund außerdem hatte die .htacces nicht die ausreichenden Rechte.
     
    #14