Citizens2 Fehler unter neuster Bukkit 1.7.2r04

Dieses Thema im Forum "Server Plugins" wurde erstellt von KungLaoHD, 25. Februar 2014.

  1. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    Habe die neuste Citizens2 Version citizens-2.0.11-SNAPSHOT.jar Build 1080 vom 23.02.2014 und diese und auch die letzten 4 davor zeigen Fehler an. Wie macht sich dieser Fehler bemerkbar?

    Hier ein Beispiel:

    1. Ich erstelle einen neuen NPC
    2. Ich ändere den NPC namen oder mache etwas an dem NPC
    3. da steht plötzlich die Lebensanzeige unter dem NPC namen und der NPC macht nicht mehr die Dinge, die er machen soll. Alle NPC sind dann
    betroffen. Auch mit /npc equip sehe ich nicht gleich, was er bekommen hat, erst nach Relogin.
    4. Starte ich den Server neu, ist wieder alles ok mit den geänderten NPCs.

    Ich kann mir nicht vorstellen, woran das nun liegen kann. Hat jemand eine Idee ?
     
    #1
  2. [Dev] iTzSasukeHDxLP
    Offline

    [Dev] iTzSasukeHDxLP Ehem. Teammitglied

    Registriert seit:
    5. Januar 2014
    Beiträge:
    938
    Die neueste Version ist weitesgehend inkompatibel mit den Versionen von Zb. essentials und ciitizens. Nimm dir Craftbukkit bzw. Spigot Version 1.7.2R2.0, die ist meiner Meinung nach momentan die beste.
     
    #2
  3. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    Mit Craftbukkit 1.7.2-R0.4 Build 3023 gleiche Fehler mit neuster Citizens2
     
    #3
  4. [Dev] iTzSasukeHDxLP
    Offline

    [Dev] iTzSasukeHDxLP Ehem. Teammitglied

    Registriert seit:
    5. Januar 2014
    Beiträge:
    938
    Du sollst die fruehere verwenden, habe ich doch geschrieben! 1.7.2 >>>> R2.0 <<<<


    Ich verwende gegenwaertig jedoch Spigot, welches nie Probleme genacht hat.
     
    #4
  5. KungLaoHD
    Offline

    KungLaoHD

    Registriert seit:
    1. Oktober 2012
    Beiträge:
    286
    Minecraft:
    KungLaoHD
    Danke dir. Habe die Spigot 1.7.2R03 Build 1242 genommen und siehe da alles geht wieder.

    er Nachteil ist dann, das TooManyItems nicht mehr geht da es nur mit der neueren Spigot oder CraftBukkit funktioniert. Schade
     
    #5