Problem Excel-Formel für vorgefertigten Artikelstamm

Dieses Thema im Forum "Offtopic" wurde erstellt von C64, 12. Juni 2013.

  1. C64
    Online

    C64

    Moin,

    ich habe folgende Tabelle2 angelegt:
    [A = Artikelnummer][B = Artikelbeschreibung][C = Artikeleinzelpreis]
    [0000000001][Apfel, rot][0,15€]
    ganz viele weiteren Zeilen mit Daten

    Tabelle 1:
    [Artikelnummer][Artikelbeschreibung][Artikeleinzelpreis][Anzahl][Zwischensumme]

    Nun;
    Artikelnummer wird im 1. Feld eingegeben, wenn vorhanden, wird in den nächsten beiden Feldern die Daten eingetragen, ansonsten erscheint ein "unbekannt" oder weis der Papst.

    Problem:
    Ich weis nicht, wie ich die Formel gestalten soll. In PHP würde ich das einfach als Array verarbeiten. In Excel soll aber die Artikelnummer in der Liste gesucht werden, wenn vorhanden die Datensätze der entsprechenden Zeile eintragen

    Ich hoffe ihr versteht was ich meine.

    Danke für Vorschläge/Ideen :)
     
    #1
  2. TheCookie
    Offline

    TheCookie

    Registriert seit:
    17. März 2013
    Beiträge:
    17
    Schon mal unter den Funk. geschaut ? Was es da alles so schönes gibt ?
    Wenn man einmal durchblickt ist das soweit alles ganz einfach und lässt sich bei Exel auch mit easy if is wenn Abfragen gestalten.
    Ich bin momentan auch noch am Reinfuxen.
    Gruß.
     
    #2
  3. C64
    Online

    C64

    Was an Excel sehr gay ist, ist die tatsache dass die Syntax in DEUTSCH ist ...

    Das was ich suchte war wohl "index", das ist wohl nen Array für Arme.
     
    #3
  4. TheCookie
    Offline

    TheCookie

    Registriert seit:
    17. März 2013
    Beiträge:
    17
    HAHA.
    Also hat sich die sache jetzt schon erldigt ?
    Ich habe mal nach search geschaut natürlich findet man dies unter Suche :D.
    Oder genauso bescheuert die derzeitige Uhrzeit und Datum:
    =jetz() :D ??!
     
    #4
  5. C64
    Online

    C64

    Das war jetzt mal die Umsetzung, wenn es einen interessiert:

    Code (Text):
    1.  
    2. =WENN(ISTNV(INDEX(Artikelstamm!$C$5:$C$48;VERGLEICH(Reparaturbericht!A26;Artikelstamm!$B$5:$B$48;0)));"-----";INDEX(Artikelstamm!$C$5:$C$48;VERGLEICH(Reparaturbericht!A26;Artikelstamm!$B$5:$B$48;0)))
    3.  
     
    #5
  6. fstingl
    Offline

    fstingl

    Registriert seit:
    9. Januar 2012
    Beiträge:
    64
    Minecraft:
    fstingl
    Einfacher wärs mit nem Verweis
     
    #6