Fehlermeldung (Konsole)

Dieses Thema im Forum "Diskussion" wurde erstellt von LucaXD8, 20. Januar 2015.

  1. LucaXD8
    Offline

    LucaXD8

    Registriert seit:
    20. Februar 2014
    Beiträge:
    6
    Ich habe keine Ahnung wieso mein Plugin auf Servern von Online-Hostern nicht funktionieren, aber auf meinem Privatserver (Hamachi) einwandfrei laufen.
    Es wird eine bestimmte Fehlermeldung in der Konsole ausgegeben :



    [16:28:43 ERROR]: Could not load 'plugins/SkyWave.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: tevOncePlugins1SkyWave/Main : Unsupported major.minor version 52.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:328) ~[server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugins(CraftServer.java:364) [server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at org.bukkit.craftbukkit.v1_7_R4.CraftServer.<init>(CraftServer.java:326) [server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at net.minecraft.server.v1_7_R4.PlayerList.<init>(PlayerList.java:68) [server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at net.minecraft.server.v1_7_R4.DedicatedPlayerList.<init>(SourceFile:14) [server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at net.minecraft.server.v1_7_R4.DedicatedServer.init(DedicatedServer.java:133) [server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at net.minecraft.server.v1_7_R4.MinecraftServer.run(MinecraftServer.java:436) [server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at net.minecraft.server.v1_7_R4.ThreadServerApplication.run(SourceFile:628) [server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    Caused by: java.lang.UnsupportedClassVersionError: tevOncePlugins1SkyWave/Main : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_72]
    at java.lang.ClassLoader.defineClass(ClassLoader.java:800) ~[?:1.7.0_72]
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.7.0_72]
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:449) ~[?:1.7.0_72]
    at java.net.URLClassLoader.access$100(URLClassLoader.java:71) ~[?:1.7.0_72]
    at java.net.URLClassLoader$1.run(URLClassLoader.java:361) ~[?:1.7.0_72]
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355) ~[?:1.7.0_72]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_72]
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354) ~[?:1.7.0_72]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:77) ~[server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62) ~[server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_72]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_72]
    at java.lang.Class.forName0(Native Method) ~[?:1.7.0_72]
    at java.lang.Class.forName(Class.java:274) ~[?:1.7.0_72]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:40) ~[server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[server.jar:git-Bukkit-1.7.9-R0.2-20-g0b2ed13-b3108jnks]
    ... 9 more
     
    #1
  2. CaptAim
    Offline

    CaptAim

    Registriert seit:
    25. September 2011
    Beiträge:
    268
    Ort:
    Hamburg
    Minecraft:
    kinglibero
    #2