Fragen zu Bukkit/Spigot-Server

Dieses Thema im Forum "Technischer Support" wurde erstellt von GammelfleischOi, 4. Oktober 2014.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. GammelfleischOi
    Offline

    GammelfleischOi

    Registriert seit:
    3. Oktober 2014
    Beiträge:
    8
    Moin.
    Wir bauen grad einen Bukkitserver mit einer Craftbukkit für die 1.7.2 auf.
    Nun möchte ich aber gern dass man mit allen 1.7.* Versionen Joinen kann und würde somit gern zu Spigot wechseln.
    Probiert habe ich die (wahrscheinlich) neueste Version, die leider nicht mit einigen Plugins kompatibel ist und auch die 1.8 rein lässt.
    Ich möchte aber "nichts halbes" und bräuchte demnach eine Spigotversion die nur für die 1.7.*-Versionen gedacht ist.
    Gibt es da irgendwelche Bezugsquellen, jetzt wo die offiziellen Downloads down sind? Wenn ja, welche ist die stabilste?
    Wäre nett wenn mir da jemand Tipps geben kann. :)

    Zweite Frage bzw. Problem:
    Ich möchte das LWC Plugin für die PvP-Welt ausschalten und Griefprevention für die Kreativwelt aktivieren.
    Irgendwie kriege ich das nicht so wirklich hin. Bei GriefPrevention sollte ich das durch viel ausprobieren sicher selbst hinkriegen, aber LWC in einer Welt ausschalten, da finde ich einfach keine passenden einträge in der Konfiguration.

    Danke im voraus und hoffe es ist nicht "frech" direkt rein zu platzen und soviel auf einmal zu fragen.

    Schönen Gruß
     
    #1
  2. M_Johny
    Offline

    M_Johny

    Registriert seit:
    16. Februar 2014
    Beiträge:
    57
    Minecraft:
    M_Johny
    Damit man nur mit den 1.7.x joinen kann, brauchst du die Build #1627 ( http://ci.md-5.net/job/Spigot/ )

    Unter der Homepage werden alle builds aufgelistet, dort steht auch die Info für die 1.7.
     
    #2
  3. GammelfleischOi
    Offline

    GammelfleischOi

    Registriert seit:
    3. Oktober 2014
    Beiträge:
    8
    #3
  4. Janhektor
    Offline

    Janhektor

    Registriert seit:
    10. Januar 2013
    Beiträge:
    11
    Du könntest auch einen Protokollhack nutzen und das Protokoll so modifizieren, dass sowohl Clients mit 1.7.2, als auch mit z.B. 1.7.10 den Server betreten können. Nachteil: Wenn du neue Blöcke auf dem Server hast, die es in den niedrigen Versionen nicht gibt, werden die Pakete an alle Clients übermittelt, was in einigen Fällen zu Abstürzen von Minecraft deiner Spieler kommen kann.
    Um dies zu verhindern, müsstest du Abfragen einbauen, oder ausschließlich die Features aus der niedrigsten unterstützten Version nutzen.
     
    #4
  5. GammelfleischOi
    Offline

    GammelfleischOi

    Registriert seit:
    3. Oktober 2014
    Beiträge:
    8
    Moin.
    Danke, hab schon ne Mirrorseite gefunden. :) Unglaublich, verbraucht (im leerlauf) die hälfte weniger speicher und die Meldung "server overloaded,...." ist auch weg.

    Die Sache mit LWC habe ich mit World-Flags gelöst. Allerdings kriege ich /fly in Skyblock nicht aus (die Flag schon, aber man kann Fliegen, wenn Fly in der normalen Welt noch an war).
     
    #5
  6. Middicom
    Offline

    Middicom

    Registriert seit:
    9. Januar 2014
    Beiträge:
    74
    Minecraft:
    Middicom
    Könntest du mir einen Downloadlink evtl. zukommen lassen (PN), ich wäre dir sehr dankbar.
     
    #6
  7. GammelfleischOi
    Offline

    GammelfleischOi

    Registriert seit:
    3. Oktober 2014
    Beiträge:
    8
    Moin. Wenn ich den wieder finde.. Ansonsten kann Ichs dir gerne weiter schicken (#1627) :)
     
    #7
  8. Middicom
    Offline

    Middicom

    Registriert seit:
    9. Januar 2014
    Beiträge:
    74
    Minecraft:
    Middicom
    Wäre sehr nett ;)
     
    #8
  9. M_Johny
    Offline

    M_Johny

    Registriert seit:
    16. Februar 2014
    Beiträge:
    57
    Minecraft:
    M_Johny
    @GammelfleischOi ich hab das mit dem fly so geregelt, dass ich ne globale flag gesetzt habe mit dem gamemode survival. Dann ist das fly auch aus wenn man die Welt betritt.
     
    #9
  10. GammelfleischOi
    Offline

    GammelfleischOi

    Registriert seit:
    3. Oktober 2014
    Beiträge:
    8
    Moin.
    Mir rg Flags hab Ichs gemacht, aber wechselt iwie nicht.

    Kann keine PN schreiben, bzw. Finde keine PN Funktion. :D würde das auf meinen Server hochladen und hier posten, wenn ich die Erlaubnis bekomme. :)
     
    #10
  11. obviousAce
    Offline

    obviousAce

    Registriert seit:
    16. Mai 2014
    Beiträge:
    28
    Minecraft:
    EtwasBequem; obviousAce_
    Welches Plugin benutzt du um die Welten zu verwalten?
    Wenn du Multiverse verwendest gibt es da eine Bypass-Permission. Wenn man diese negiert/entzieht behält man nicht den Gamemode von der vorherigen Welt.
     
    #11
  12. GammelfleischOi
    Offline

    GammelfleischOi

    Registriert seit:
    3. Oktober 2014
    Beiträge:
    8
    Benutze Multiverse. Jetzt scheints auch zu funktionieren. Danke. :)
     
    #12
Status des Themas:
Es sind keine weiteren Antworten möglich.