Nervende Meldung von Worldguard

Dieses Thema im Forum "Server Plugins" wurde erstellt von Gelöschter Nutzer, 11. März 2012.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Ok ich hab ein Problem. Ich hab den auf 1.2.3 geupdatet sowie die Plugins neu runtergeladen. Nun macht glaube ich Worldguard Probleme.
    Immer und wirklich bei jeder Bewegung von mir oder anderen Spielern kommt diese Meldung:

    Code (Text):
    1. 16:50:38 [SCHWERWIEGEND] Could not pass event PlayerMoveEvent to WorldGuard
    2. org.bukkit.event.EventException
    3.         at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.j
    4. va:303)
    5.         at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.ja
    6. a:62)
    7.         at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.
    8. ava:441)
    9.         at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:208)
    10.         at net.minecraft.server.Packet10Flying.handle(SourceFile:126)
    11.         at net.minecraft.server.NetworkManager.b(NetworkManager.java:229)
    12.         at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:112)
    13.         at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:
    14. 8)
    15.         at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:554)
    16.         at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:452)
    17.         at net.minecraft.server.ThreadServerApplication.run(SourceFile:490)
    18. Caused by: java.lang.NoSuchMethodError: org.bukkit.entity.Player.getVehicle()Lo
    19. g/bukkit/entity/Vehicle;
    20.         at com.sk89q.worldguard.bukkit.WorldGuardPlayerListener$PlayerMoveHandl
    21. r.onPlayerMove(WorldGuardPlayerListener.java:113)
    22.         at sun.reflect.GeneratedMethodAccessor8.invoke(Unknown Source)
    23.         at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    24.         at java.lang.reflect.Method.invoke(Unknown Source)
    25.         at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.j
    26. va:301)
    27.         ... 10 more
    Der Server laggt nicht, stürtzt nicht ab und es gibt sonst auch keine Probleme. Nur da wirklich bei jeder Bewegung von anderen Spielern und mir diese lange Meldung
    auftaucht frage ich mich nun: Wie kann man dieses Problem lösen? Ist irgendein Plugin oder sowas nötig? Danke schon mal für die die antoworten :D
     
    #1
  2. Dean
    Offline

    Dean Administrator Entwickler

    Registriert seit:
    11. August 2011
    Beiträge:
    2.109
    Ort:
    NRW
    Minecraft:
    DeanR
    hast du die Dev Version von Worldedit? Die bekommst du auf der Homepage von dem Plugin.
     
    #2
  3. Mega Fail ich hab Worldedit mit Worldguard verwechselt

    EDIT: Und ja ich hab die Dev Version von dem Plugin. ^^
     
    #3
  4. Wieso kommt keine Antwort :D Wär doof wenn jetzt alles unprotectet wär und man ungehemmt griefen kann.
     
    #4
  5. H4RDC0REx3
    Offline

    H4RDC0REx3

    Registriert seit:
    17. Dezember 2011
    Beiträge:
    888
    kenn mich zwar nicht so arg damit aus aber lösch einfach mal den ordner das es sich neu generiert^^
     
    #5
  6. Ok das werd ich dann versuchen ich werd dann wieder einen Beitrag schreiben obs geklappt hat oder nicht :D
     
    #6
  7. Cabraca
    Online

    Cabraca

    vergiss das Backup nicht falls du schon regionen definiert hast
     
    #7
  8. Nein geht immernoch nicht immernoch das gleiche wie ich oben beschrieben hab :(
     
    #8
  9. Cabraca
    Online

    Cabraca

    sicher dass worldedit und worldguard für 1.2.3 sind? sieht für mich danach aus als ob du ne alte worldguard version drin hast.
     
    #9
  10. Das hatte ich auch gedacht...ich hab dann mal kontrolliert ob es so ist indem ich statt der Version die ich jetzt habe die 1.1 Version
    reingemacht ob das das selbe kommt. Ist leider überhaupt nicht so. Mit der falschen Version kommt nur einmal eine schwerwiegende Meldung,
    ob es "Up to date" ist. Das ist die richtige. Und Worldedit bin ich mir zu 100 % sicher da sonst was von Worldedit in der Console steht.
    Ich weiss nicht wieso diese Meldung dauernd erscheint.
     
    #10
  11. Kann es vielleicht sein das Worldedit dran Schuld ist? Ich hab vorgestern mit Worldedit gearbeitet und als ich //replace 78 0 machen wollte
    kam JavaNullPointerExeption Oder sowas ähnliches. Hat das was damit zu tuen oder :?:
     
    #11
  12. Jobsti
    Offline

    Jobsti

    Registriert seit:
    18. August 2011
    Beiträge:
    1.226
    Ort:
    Steinau (Hessen)
    Minecraft:
    Jobsti
    Wenn WE oder WG Update, IMMER WG und WE auf den neusten Stand bringen, schaut mit cmdbook und cmdhelper genauso aus,
    steht auch fett auf SKs seite, im Bukkit dev usw.
     
    #12
  13. Hab ja auch eigentlich...um ganz sicher zu gehen könnte einer so nett sein und die richtigen Links zu Wordedit UND Worldguard im
    Forum posten, nicht das ich tatsächlich die falsche Version hab. Bis auf diese störende Meldung von Worldguard und bei Worldedit
    die NullPointerExeption manchmal bei dem ausfürhen von Befehlen zb //replace oder //set .
     
    #13
  14. Jobsti
    Offline

    Jobsti

    Registriert seit:
    18. August 2011
    Beiträge:
    1.226
    Ort:
    Steinau (Hessen)
    Minecraft:
    Jobsti
  15. Danke Jobsti, vielen dank ^^ für den Link, hatte wohl tatsächlich die falsche Version! Der Fehler im Log ist weg! Habe mich bewegt und keine Spur
    von der Meldung :D Jetzt nur noch nachprotecten und schon ist alles beim alten :) Super danke nochmal :D

    Da es jetzt geklärt ist kann dieses Thema geschlossen werden ^^
     
    #15
Status des Themas:
Es sind keine weiteren Antworten möglich.